Download it now!
Bug 55838 - EDITING: ctrl + end does not jump to end of document
Summary: EDITING: ctrl + end does not jump to end of document
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2012-10-10 11:04 UTC by stfhell
Modified: 2021-01-03 23:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document control_end.odt (160.73 KB, application/vnd.oasis.opendocument.text)
2012-10-10 11:07 UTC, stfhell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stfhell 2012-10-10 11:04:46 UTC
In some documents, the key combination "ctrl+end" (bound to "To Document End") does not move the cursor to the end of the document. Sometimes it jumps to the footer area, sometimes it doesn't move at all.

Very old bug, first reported for OpenOffice on 2008-01-15, see Apache issue #85255:
https://issues.apache.org/ooo/show_bug.cgi?id=85255

I had the same problem with the XTextRange method gotoEnd() in 2009.
Comment 1 stfhell 2012-10-10 11:07:07 UTC
Created attachment 68400 [details]
Sample document control_end.odt

The ODT shows that Ctrl+End does not move the cursor to end of document
Comment 2 Joel Madero 2013-06-02 02:39:32 UTC
First, apologies for the long delay, QA team is overworked but we're growing so hopefully going forward bugs won't take months to confirm :)

That being said:

Updating version as you said it was inherited by OOo - version field reflects oldest version we see the problem - if we inherited it then 3.3 beta would be appropriate - really we should have a version "OOo days" ;)

Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - doesn't prevent high quality work, slows it down a tiny bit
Lowest - the inconvenience of this one not working seems to be very minimal


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 QA Administrators 2015-03-16 23:00:43 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-03-31 08:35:46 UTC
Confirmed.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 5 QA Administrators 2017-05-22 13:19:58 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-12-03 14:07:14 UTC Comment hidden (obsolete)
Comment 7 andrew.james.heard 2021-01-03 23:50:17 UTC
Still a bug for me. ctrl+end in <Sample document control_end.odt> jumps to the footer, but no further. Sometimes confusing an my own documents as you start adding text to what you thought was the end of the document but is somewhere else. Seems to be when there is a section break.

Version: 7.1.0.0.beta1 (x64)
Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-AU (en_AU); UI: en-GB
Calc: CL