Bug Hunting Session
Bug 55842 - EDITING: no access to objects in of top margin or bottom margin area
Summary: EDITING: no access to objects in of top margin or bottom margin area
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 55937 56361 56570 57944 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-10-10 13:44 UTC by Florian Effenberger
Modified: 2013-12-12 16:19 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Template for writing different letters in Writer (14.09 KB, application/vnd.oasis.opendocument.text)
2012-10-12 09:45 UTC, Roman Schleicher
Details
Simple Sample (14.09 KB, application/vnd.oasis.opendocument.text)
2013-01-27 08:31 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Effenberger 2012-10-10 13:44:44 UTC
I have a document here where I cannot edit a frame by clicking into it. The frame just does not get the focus (iow. no blinking cursor). When I do Ctrl+click or a right click, it opens the context menu and the frame gets its focus, so this is my workaround at the moment.

I was not able to reproduce that behaviour when creating a new document, but it might be related to the Mac focus problems we recently had.

As the document is an official letterhead, I'd prefer to send it to someone privately to have a look.
Comment 1 Florian Effenberger 2012-10-10 13:45:23 UTC
As it's an official TDF document, adding three fellow BoD members to recommend someone to have a look :)
Comment 2 Roman Schleicher 2012-10-12 09:45:42 UTC
Created attachment 68479 [details]
Template for writing different letters in Writer

Different pagestyles called "Briefseite1" and "Briefseite2" with multiple textframes. The textframes contain placeholder and other pre-defined values.
You can test the bug by editting the top border e.g. in the style "Briefseite1". After that try to edit the different textframes.
Comment 3 Roman Schleicher 2012-10-12 09:52:27 UTC
(In reply to comment #2)
> Created attachment 68479 [details]
> Template for writing different letters in Writer

I can reproduce this error when using the installed or the portable edition of LO 3.6.2.2 on Windows 7 64bit. But it only occurs if the frames are not in the area from a "normal" page like you get if you start a new document.
I changed the top-border of the first page back to a normal size (2 cm from top) and then the frames are in the page-area and I can edit them as normal. If I have my top-border edited to 13 cm from the top, the frames are out of this area and the focus error occurs.

This error wasn't in a portable (maybe also installed) version of LO 3.6.1.2.
Comment 4 manj_k 2012-10-13 11:04:10 UTC
*** Bug 55937 has been marked as a duplicate of this bug. ***
Comment 5 hyper_ch 2012-10-13 11:07:13 UTC
Shouldn't status be changed to confirmed and regression (as it was in my duplicate report - https://bugs.freedesktop.org/show_bug.cgi?id=55937 )?
Comment 6 manj_k 2012-10-13 11:07:13 UTC
Added keyword 'regression'.

From bug 55937:

Confirmed (on WinXP 32b) with
- LibO 3.6.2.2
- LibO 3.6.3.1
- LibO-Dev_3.6.4.0+
  Win-x86_9-Voreppe libreoffice-3-6
  pull time 2012-10-12 13:47:16
  core:14a24950c56d85e275ea2b2fd13e5cefc25d6635
- LibO-Dev 3.7.0.0.alpha0+
  W2008R2@20-With-Symbol-Bytemark-Hosting MASTER
  pull time 2012-10-01 05:02:30
  core:e12f501bebf83ea8121e517283c25c24587268a7

Works fine with LibO 3.5.7.2.
Comment 7 manj_k 2012-10-24 22:42:14 UTC
*** Bug 56361 has been marked as a duplicate of this bug. ***
Comment 8 Harald Koester 2012-10-29 15:54:25 UTC
Also works fine with LO 3.6.1.
Comment 9 Michael Meeks 2012-10-29 16:06:28 UTC
Ho hum, I wonder if this is a side-effect of the click-to-add-header/footer change there. It'd be lovely to get a git bisection.
Comment 10 Cédric Bosdonnat 2012-10-29 16:29:08 UTC
mine and dupe

*** This bug has been marked as a duplicate of bug 52182 ***
Comment 11 Harald Koester 2012-11-01 17:32:55 UTC
This bug occured the first time with Version 3.6.2. So it can't be a duplicate of a bug, which occured already with Version 3.5.x. Hence reopened.
Comment 12 Thorsten Behrens (CIB) 2012-11-01 22:56:27 UTC
Then let's reopen it all the way.
Comment 13 manj_k 2012-11-02 09:53:19 UTC
*** Bug 56570 has been marked as a duplicate of this bug. ***
Comment 14 manj_k 2012-12-03 00:05:07 UTC
LibO-Dev_4.0.0.0.alpha1+
Win-x86@6 MASTER
pull time 2012-12-02 05:22:03
core:704fdf2b23d0e0480f29e0e56f631c2835eed02b
(on WinXP)


(1) Tested attachment 68479 [details]
Template for writing different letters in Writer
letter_template.odt
(see comment #2, comment#3)

Editing works fine for me.


(2) Tested attachment 68479 [details]
Honorar.odt
(from duplicate bug 55937)

Editing works fine for me.


(3) Tested attachment 69286 [details]
not_set_cursor_in_section.odt
(from duplicate bug 56570)

Editing works fine for me.


WORKSFORME – apparently fixed with bug 52182 .


@Florian Effenberger:
Waiting for your test result with a *current* Master build, 
meanwhile marked as NEEDINFO.

Other confirmations welcome ...
Comment 15 Florian Effenberger 2012-12-03 11:44:30 UTC
Thanks a lot for the fix, works for me now :)
Comment 16 Karsten Henning 2012-12-03 11:53:18 UTC
The Attachments don't work in Version 3.6.4.3!
It ist the same behavior as befor.
Comment 17 manj_k 2012-12-03 12:29:49 UTC
Apparently fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=e8fbe97900f13305b17015d9044993bde4adab36 (bug 52182).

[See comment #14, comment #15]

Marked as WORKSFORME.

For suggestions to backport to 3.6 branch: Bug 52182 - cannot put cursor into frames with Wrap "In Background" (RESOLVED FIXED · target:4.0.0).
Comment 18 Robert Großkopf 2012-12-03 15:39:34 UTC
Works for everybody, who would use 4.0.0.0 Alpha 1+, but didn't work with LO 3.6.4.3.
Could we say, that this is "solved"? Couldn't it be solved for any 3.6-version?
Comment 19 manj_k 2012-12-05 12:31:01 UTC
@robert@familiegrosskopf.de (comment #18),
@Karsten Henning (comment #16):

See comment #17,
and bug 52182_comment_#17
→  https://bugs.freedesktop.org/show_bug.cgi?id=52182#c17 .
Comment 20 manj_k 2012-12-08 16:05:32 UTC
*** Bug 57944 has been marked as a duplicate of this bug. ***
Comment 21 Andreas Ziegler 2013-01-26 18:27:53 UTC
i am reopening this bug because with my files and the attached testfile it still doesn't work with 3.6.5 RC2, so the patch from bug 52182 doesn't solve this one :-(
Comment 22 Rainer Bielefeld Retired 2013-01-27 08:21:09 UTC
I tried to find a problem with 3.6.5.2 in Sample "2012-10-12 09:45 UTC, Roman Schleicher"  by opening the document and a copy in ad 4.0.0.2 (to compare the behavior.

Steps how to reproduce (do steps parallel in both versions):

0. Launch LibO
1. Open Sample document from Start Center
   > In both documents caret flashed in front of "Sehr geehrte"
2. Move mouse pointer to Word "Betreff" between "TR"
   > In both documents mouse pointer view changes to "Hand"
3. Mouse click
   Expected (as in 4.0): Place holder field becomes selected, typing some letters
            will replace the placeholder by your text
   Actual (With 3.5.6.2): you can't access elements in top margin and bottom 
   margin area (even if they also  are in left margin or right margin area).

So [Reproducible] with Server Installation of "LibreOffice 3.6.5.2 rc" German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit).

I think I already am involved in a Bug concerning at least very similar effects (if I remember correctly it was about Drawing elements like shapes), I will need a little time to find that one and to check whether this one is a DUP or only shows similar symptoms.
Comment 23 Rainer Bielefeld Retired 2013-01-27 08:31:55 UTC
Created attachment 73718 [details]
Simple Sample

I created a more simple sample with less special conditions like footer, fields, ...

Problem with access to elements in top and bottom margin area already reproducible with WIN version
* 3.6.2

Still was ok with WIN version
* 3.6.0.4
Comment 24 Rainer Bielefeld Retired 2013-01-27 08:42:44 UTC
I also used ma simple sample document for tests concerning "Bug 54453 - EDITING: Impossible to draw shapes in top margin or bottom margin". That one also appeared between 3.6.0.4 and 3.6.2.1, so I think the suspect that these bugs have common roots (or are DUPs) is appropriate.

I'm a little worried "concerning Bug 50195 - EDITING: Can't Select Image in Header when outside margins", what seems related, but already appeared with 3.5.
But I think we should try to fix all these effects wihtin 1 fix session.

@Cédric:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf
Comment 25 Andreas Ziegler 2013-04-06 18:52:35 UTC
i just installed 4.0.2.2 and the problem isn't there anymore - so it got fixed apparently somewhere between 3.6.5 and 4.0.2.2
Thanks!
Comment 26 Karsten Henning 2013-04-08 06:22:48 UTC
 Sorry,

I have installed the Version 3.6.6.2 and in this Version the Problem is not 
solved. 
In Version 4.0.2.2 it works fine. 


Am Samstag, 6. April 2013, 18:52:35 schrieben Sie:
> https://bugs.freedesktop.org/show_bug.cgi?id=55842
> 
> Andreas Ziegler <bugs.freedesktop.org@andreas-ziegler.de> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> Status|NEW                         |RESOLVED
>          Resolution|---                         |WORKSFORME
> 
> --- Comment #25 from Andreas Ziegler
> <bugs.freedesktop.org@andreas-ziegler.de> --- i just installed 4.0.2.2 and
> the problem isn't there anymore - so it got fixed apparently somewhere
> between 3.6.5 and 4.0.2.2
> Thanks!