Bug Hunting Session
Bug 56316 - EDITING: CONDITIONAL FORMATTING not included in copy-paste cell
Summary: EDITING: CONDITIONAL FORMATTING not included in copy-paste cell
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.1 rc
Hardware: Other Windows (All)
: medium critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.6.4
Keywords: regression
: 54748 57516 (view as bug list)
Depends on:
Blocks: Conditional-Formatting mab3.6
  Show dependency treegraph
 
Reported: 2012-10-23 09:10 UTC by Rainer Bielefeld Retired
Modified: 2017-07-17 09:25 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (52.00 KB, application/x-zip-compressed)
2012-10-23 09:10 UTC, Rainer Bielefeld Retired
Details
Example on problems with conditional formatting (53.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-03 19:05 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-23 09:10:22 UTC
Created attachment 68944 [details]
Test Kit

This one might be related to or DUP of "Bug 54748 - EDITING: CONDITIONAL FORMATTING not included in copy-paste cell". I also see the problem with
3.6.3.1 rc

Steps how to reproduce with Server Installation of  "LibreOffice  3.6.4.0+  English UI/ German Locale [Build-ID: 6644666],{tinderbox: Win-x86@9 pull time 2012-10-22 23:52:55}  on German WIN7 Home Premium (64bit):
0. Download / unzip attached Test kit 
1. Open source and target
2. in Source click row heading 
   > row becomes selected
3. <control+c> for copy
4. switch to tarrget
5. Click row heading 5
   > all row becomes selected
6. <control+v> for paste
   > contents appears and looks fine
7. Click cell I5
   > Cell cursor marks cell I5
8. Menu 'Format -> Conditional Formatting ->  Conditional Formatting
   Expected: Condition shown as in source document
   Actual: No source document

I additional observed that sometimes an arbitrary other formatting will be applied for cells with CF, but currently I can't make that reproducible.

I selected "Critical", but I see that as a 3.6.4 blocker 
With a little luck a backport of fix for Bug 54748 can heal the problem.

Worked with 3.5, so Regression
Comment 1 Rainer Bielefeld Retired 2012-11-01 05:45:47 UTC
Because it seems there is not much interest in this bug, I confirm this one because bug is [Reproducible] with Server Installation of  "LibreOffice  3.6.4.0+  English UI/ German Locale [Build-ID: be49b70],{tinderbox: Win-x86@9 pull time 2012-10-31 08:03:29}  on German WIN7 Home Premium (64bit), User-Profile 3.6.4 dailies  

I think we can't ship a 3.6.3 with this known bug.

@Spreadsheet Team:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 2 Markus Mohrhard 2012-11-04 17:17:24 UTC
This is fixed in master. I have no idea why it is back in 3-6.

I fixed this bug some time ago. I'm now going to build a 3-6 build to check what is different than in my master build.
Comment 3 Markus Mohrhard 2012-11-04 18:08:52 UTC
Found why it is not fixed in 3-6. Seems I did not backport this quick fix.

Patch is now waiting for review.
Comment 4 Not Assigned 2012-11-05 16:53:56 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df2736e3e8b6a49aeac26e8f86f943923ed45053&g=libreoffice-3-6

only delete cond formats if the correct attributes are passed, fdo#56316


It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Kohei Yoshida 2012-11-05 16:55:07 UTC
I'll mark this fixed.
Comment 6 Markus Mohrhard 2012-11-05 21:37:22 UTC
*** Bug 54748 has been marked as a duplicate of this bug. ***
Comment 7 Rainer Bielefeld Retired 2012-11-11 06:28:38 UTC
*** Bug 55032 has been marked as a duplicate of this bug. ***
Comment 8 m.a.riosv 2012-11-11 15:40:41 UTC
Seems strange, the originals are the duplicates.
Comment 9 Markus Mohrhard 2012-11-27 14:10:06 UTC
*** Bug 57516 has been marked as a duplicate of this bug. ***
Comment 10 andis.lazdins 2012-12-03 16:48:19 UTC
It seems that the problem still persist in 3.6.4 RC3. When I copy whole sheet with different conditional formatting elements, after pasting they all are gone. I'm on Linux platform (Ubuntu linux 12.04).
It is interesting, that, when I do undo of paste operation, the conditional formatting elements disappear also from previous content of the destination sheet.
Comment 11 Rainer Bielefeld Retired 2012-12-03 18:17:53 UTC
In between I did a lot of work with "LibreOffice 3.6.4.3 rc" German UI/ German Locale [Build-ID: 2ef5aff] {pull date 2012-11-28} on German WIN7 Home Premium (64bit) and I am pretty sure that I did not see this problem again.

@andis.lazdins@gmail.com
<http://wiki.documentfoundation.org/BugReport_Details#Version>
<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>
Of course it might be that the problem with attached test kit due to step by step instruction still is visible for you, please test! But only reopen this bug if you see EXACTLY the reported problem.

For ANY other CF problem please submit a separate Bug (if it has not been reported already); I will try to reproduce your results and add you ot CC if I open a new bug.
Comment 12 andis.lazdins 2012-12-03 19:05:28 UTC
Created attachment 70975 [details]
Example on problems with conditional formatting

Sample file showing problems with conditional formatting, when copy larger blocks of text and merged cells
Comment 13 andis.lazdins 2012-12-03 19:29:11 UTC
I just attached time sheet we are using in our work. It is 1 month extracted from yearly time sheet. There are several blocks of cells with conditional formatting, for instance J12:AN26 and F161:AJ178.

Way to reproduce error:

You can try to open the file and first move/copy sheet - for instance copy sheet janv to the beginning of file with name janv_2. You will see that conditional formatting is still there in new sheet janv_2.

Then put cursor into any cell in sheet janv and press Ctrl+A to select all cells and press Ctrl+C to copy sheet content. Then go to sheet janv_2, put cursor at A1 cell and press Ctrl+V to paste sheet content. After some flickering (it seems that copy/paste of complex structures is broken somehow in 3.6) you will see new content of sheet and all conditional formatting is gone.

Then try to press undo. After some flickering you will see previous content of sheet, but ... without conditional formatting.

Then move again to sheet janv, press Ctrl+A and Crtl+C and move to Sheet2. Leave cursor in A1 cell and press Ctrl+V. No flickering this time, but new sheet content is also without conditional formatting. Undo rapidly return us to empty sheet.

Then move back to sheet janv and select, for instance, J12:O16 and press Ctrl+C. Move to any cell (like A1) in Sheet2 and press Ctrl+V. You will see that conditional formatting is in place.

Then select C5:AV26 in sheet janv, press Ctrl+C, move any cell in Sheet2 (e.g. A8), press Ctrl+V and there is no more conditional formatting.

I'm not sure if it is the same bug, I guess the regression is more fundamental, because many complex spreadsheets (created some 5-10 years ago and constantly used with all following versions of openoffice.org and libreoffice) are now crashing during copy/paste operations or even simple filling in numbers cause problems; in spite it didn't make any sense to Openoffice.org 2.4.2 and very little trouble with 3.5.5.
Comment 14 andis.lazdins 2012-12-03 19:42:48 UTC
When I use Test kit as described in instruction (copy/paste single row) conditional formatting reproduces in the target file. But when I select the whole sheet in source file and copy/paste it to target file, conditional formatting disappear.

I guess this means that the bug is not solved and it is critical regression. 

With older versions of openoffice.org or libreoffice it doesn't matter, how I copy/paste sheet content. Conditional formatting is still there.
Comment 15 Rainer Bielefeld Retired 2012-12-04 05:13:29 UTC
Comment on attachment 70975 [details]
Example on problems with conditional formatting

andis.lazdins@gmail.com:
This bug has been closed because it has been fixed, it is a very bad Idea to discuss a different problem here.
Comment 16 Rainer Bielefeld Retired 2012-12-04 05:20:52 UTC
Comment on attachment 70975 [details]
Example on problems with conditional formatting

@andis.lazdins@gmail.com:
"The" bug is the problem defined with the original report and the sample document. 

You observed something related, but different, for what we have "Bug 57849 EDITING: CONDITINAL FORMATTING lost after copy / paste of all sheet contents to new sheet"
So I obsolete the new sample here.
Comment 17 Markus Mohrhard 2012-12-05 18:10:14 UTC
(In reply to comment #14)
> When I use Test kit as described in instruction (copy/paste single row)
> conditional formatting reproduces in the target file. But when I select the
> whole sheet in source file and copy/paste it to target file, conditional
> formatting disappear.
> 
> I guess this means that the bug is not solved and it is critical regression.

No. This bug here is fixed as you can see witht he original test document. The other problem has a different root cause that is already tracked in another bug report.

Please open new bug reports for new issues. Only if you still can reproduce the original steps you should comment in an old bug report. Hijacking bug reports only leads to lost bug reports.
Comment 18 Jean-Baptiste Faure 2016-05-21 18:03:56 UTC
Added regression keyword from description.