Bug 57324 - VIEWING: Garbled screen after cell freeze, save, and reopen
Summary: VIEWING: Garbled screen after cell freeze, save, and reopen
Status: RESOLVED DUPLICATE of bug 40070
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 38646 59823 63626 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-20 14:20 UTC by Rubem
Modified: 2013-12-15 22:50 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Excel sheet (XLSX) (17.24 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-11-20 14:20 UTC, Rubem
Details
Screenshot showing garbled screen at left (14.14 KB, image/png)
2012-11-20 14:23 UTC, Rubem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rubem 2012-11-20 14:20:54 UTC
Created attachment 70314 [details]
Excel sheet (XLSX)

Problem description: 

Calc screen is severely garbled after freezing a cell from a XLSX spreadsheet, saving and reopening.

Steps to reproduce:
1. Load XLSX spreadsheet attached.
2. Select cell E3.
3. Select Window > Freeze.
4. Save as another file.
5. Close the spreadsheet.
5. Reopen the spreadsheet.

Current behavior:

After reloading, the screen is garbled. Also, Window > Split is checked, but Window > Freeze is not. Unchecking Window > Split corrects the problem.

Expected behavior:

The screen should not be garbled. Also, Window > Freeze should be checked.

Platform (if different from the browser): 

Windows 7 SP1
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11
Comment 1 Rubem 2012-11-20 14:23:22 UTC
Created attachment 70315 [details]
Screenshot showing garbled screen at left
Comment 2 A (Andy) 2013-04-19 21:40:09 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

@Eike: Could this issue maybe be something for you?
Comment 3 Rubem 2013-04-29 21:16:04 UTC
> @Eike: Could this issue maybe be something for you?

Yes I can help with testing. However I cannot help with the code, sorry.
Comment 4 ign_christian 2013-05-09 09:28:44 UTC
reproducible with LO 3.6.6.2 (Ubuntu 12.04.2 LTS)

But that bug not happen if you save as .xls
Seems that problem with .xlsx format
Comment 5 ign_christian 2013-05-09 09:38:21 UTC
*** Bug 63626 has been marked as a duplicate of this bug. ***
Comment 6 ign_christian 2013-05-09 09:40:34 UTC
*** Bug 59823 has been marked as a duplicate of this bug. ***
Comment 7 ign_christian 2013-05-09 10:31:49 UTC
*** Bug 38646 has been marked as a duplicate of this bug. ***
Comment 8 ign_christian 2013-08-07 03:03:31 UTC

*** This bug has been marked as a duplicate of bug 40070 ***