Bug 57443 - Recent documents circus when the file is missing
Summary: Recent documents circus when the file is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0
Keywords:
: 70225 76510 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-23 05:24 UTC by Urmas
Modified: 2014-03-23 16:18 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-11-23 05:24:35 UTC
If you're trying to open a Recent file which no longer exists, the following hilarity ensues:

1. The error message "%FILE% does not exist" appears.
2. The error message "%FILE% does not exist" appears once again.
3. The dialog "%FILE% is locked for editing by Unknown User" with 2 options appears. Either of them will bring...
4. "Object not accessible" error message.

Should I say more?
Comment 1 Rainer Bielefeld Retired 2012-11-23 06:43:19 UTC
NOT Reproducible with parallel installation of Master "LOdev  4.0.0.0.alpha1   -  ENGLISH UI / German Locale  [Build ID: dec8fe)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch

Steps how to reproduce:
1. From LibO Start Center open an existing document "newtest.odt", do a 
   smaller edit, save and close
2. Rename "newtest.odt" to "_newtest.odt" in WIN File Explorer
3. Menu 'File -> Recent Documents - "newtest.odt"
   As expected, a message 
   "C:\Users\Public\Documents\....\newtest.odt does not exist."
   appears

@Urmas
> Should I say more?

Yes, for details please see  the bug report basics on <http://wiki.documentfoundation.org/BugReport> ;-)
Comment 2 Urmas 2012-11-23 09:05:17 UTC
Looks like it's Starter Center-only.
Comment 3 Rob Snelders 2012-12-06 21:43:54 UTC
Confirmed with 4.1.0.0-Master on Ubuntu 12.04 x86_64.

Indeed only in the start center.
Comment 4 Joel Madero 2012-12-06 21:50:15 UTC
I am unable to reproduce this with: Version 4.1.0.0.alpha0+ (Build ID: dfd474710f959dcf78038deb990c3618b467ec6)

On Bodhi Linux
Comment 5 Jorendc 2013-08-03 13:32:26 UTC
Still reproducible using LibreOffice 4.1.0.4, not using LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 2f6cbe13e61c44d4bab8192a4708b698d3d9da33
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-25_00:00:21
So, looks fixed to me. When clicking on a non-existing file in the list, only 1 time the dialog appears. After clicking OK, nothing more appears/no circus anymore.

Kind regards,
Joren
Comment 7 Jorendc 2013-10-15 20:05:55 UTC
*** Bug 70225 has been marked as a duplicate of this bug. ***
Comment 8 Urmas 2014-03-23 16:18:08 UTC
*** Bug 76510 has been marked as a duplicate of this bug. ***