Bug Hunting Session
Bug 58018 - Help texts appear as menu items in menu "File"
Summary: Help texts appear as menu items in menu "File"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.0.0.0.beta2 target:4.1.0
Keywords:
: 58332 (view as bug list)
Depends on:
Blocks: 58025
  Show dependency treegraph
 
Reported: 2012-12-08 15:03 UTC by Robert Großkopf
Modified: 2012-12-15 18:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the wrong menu entries in Writer (270.88 KB, image/png)
2012-12-15 11:01 UTC, Roman Eisele
Details
Screenshot showing the wrong menu entries in Calc (294.01 KB, image/png)
2012-12-15 11:02 UTC, Roman Eisele
Details
Screenshot: Correct (?) menu "File" - LOdev build dated 2012-11-15 (243.16 KB, image/png)
2012-12-15 11:41 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2012-12-08 15:03:52 UTC
Open a database in LO 4.0.0.0 beta1.
Open menu File.
There are, under the entry "Save all", some entries, which aren't menu-entries ("This is the action to create a private working copy      of the
document on the server ...")
Comment 1 Rainer Bielefeld Retired 2012-12-08 17:35:53 UTC
 [Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta1   -  GERMAN UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch.
Same bug in English UI
Comment 2 Roman Eisele 2012-12-15 11:00:14 UTC
Also REPRODUCIBLE on Mac OS X 10.6.8 (Intel) with 4.0.0.0beta1.

But IMHO this problem is not limited to Base -- I see the same wrong menu entries also in the File menus of Writer and Calc. I will attach screenshot showing these wrong entries (it is always useful to see what we are talking about ;-).

Hint: This bug is *not* related to any corrupted local settings, etc. -- resetting both the “LibreOffice” and the “LOdev" user profile before testing does not change the results.
Comment 3 Roman Eisele 2012-12-15 11:01:31 UTC
Created attachment 71541 [details]
Screenshot showing the wrong menu entries in Writer
Comment 4 Roman Eisele 2012-12-15 11:02:01 UTC
Created attachment 71542 [details]
Screenshot showing the wrong menu entries in Calc
Comment 5 Roman Eisele 2012-12-15 11:24:57 UTC
*** Bug 58332 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2012-12-15 11:25:58 UTC
Related to Bug 58019#c2?

In Bug 58019c2 András told that currently translations are out of sync., what might cause lots of similar problems,even if in the particular menu the number of items is matching between the languages
Comment 7 Roman Eisele 2012-12-15 11:34:55 UTC
In bug 58332, which I have marked as a duplicate of the present one, Christoph Sold analyzes this issue as following:

> The Help text for Menu items
>   File - Save all
> and 
>  File - Check out
> appears as menu item, rendering the menu wider than most screens.

The idea that the wrong menu entries are just the help text strings seems compelling to me. Therefore I modify the Summary field accordingly.


> Related to Bug 58019#c2?
The observation makes me doubt if this is really just a translations problem ...
Comment 8 Roman Eisele 2012-12-15 11:41:30 UTC
Created attachment 71544 [details]
Screenshot: Correct (?) menu "File" - LOdev build dated 2012-11-15

However, I am not sure if the two long menu entries visible now in the File menu are really the help texts for “File - Save all” and “File - Check out”; the texts visible on my two screenshots don’t fit as help texts for Save All ...

This screenshot shows one of the last daily builds before the problem first appeared; it is dated from 2012-11-5. It shows some new entries in the File menu:
after “Save All”, we read
  Check-Out
  Cancel Check-Out...
  Check-In...

So I would guess that the two long and wrong menu entries are the help texts for “Check-Out” and “Check-In...”, and are show in error in the place of these two menu entries.
Comment 9 Andras Timar 2012-12-15 17:44:12 UTC
It was just a typo, developer wrote xml_lang instead of xml:lang. The help text is really for the translators, not for end-users.
Comment 10 Not Assigned 2012-12-15 17:44:31 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2988f4bbc9c381e91a372a6aad5d0334d7134383&g=libreoffice-4-0

fdo#58018 typo: s/xml_lang/xml:lang/


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Not Assigned 2012-12-15 17:44:53 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c321f0d21281cc6b1d5303f24de00d5bb2849db

fdo#58018 typo: s/xml_lang/xml:lang/



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Roman Eisele 2012-12-15 18:42:12 UTC
@ András:
Thank you very much for fixing this issue!

> It was just a typo, developer wrote xml_lang instead of xml:lang.
Well, quite some bugs (including important ones) are “just typos” ;-)