Bug 58826 - FORMATTING: When conditional formatting is use by unprotected cell, is even so protect by protected sheet
Summary: FORMATTING: When conditional formatting is use by unprotected cell, is even s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: high critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords: regression
: 59289 59968 60897 61048 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-28 12:11 UTC by vlb
Modified: 2013-02-27 11:49 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Examle issue in sheet (7.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-28 12:11 UTC, vlb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlb 2012-12-28 12:11:44 UTC
Created attachment 72208 [details]
Examle issue in sheet

LO Version 4.0.0.0.beta2+ (Build ID: c5229f497008051b078e9f76e00031dfb3b6f41)
Windows 7 64 bits

I have do the next:
1) open sheet attachment
2) in cell c9 is coditional formatting used
3) when in cell A1=1 the conditional format is correct
4) when in cell A1=2 the cell c9 is protect, but must didn't protect
5) when unprotect the sheet -> see cell c9=unprotect menu-format-cells-cell Protection



In LO 3.6.4 is cell unprotect oke, but in the conditional formatting is the protect cells not correct.
Comment 1 Markus Mohrhard 2012-12-31 01:56:29 UTC
I fixed the bug that conditional formats don't respect sheet protection and additionally fixed that specifying cell protection in conditional format styles had no effect. So now conditional formats also affect cell protection.
Comment 2 vlb 2013-01-02 20:00:11 UTC
What i mean is that:

1) When there is conditional formatting in a cell, but the cell is in the format unprotected, even so the cell become protected in cell ("c9"). This is wrong and by my a bug.

2) When in conditional formatting is use cell protection, this had no effect. -> This is also be present 3.6.4 and not a bug.

I have check in LO Version 4.0.0.0.beta2+ (Build ID: afa240330b51fb3607cfa6390aeb4e085cd1c52) and also present.

Can you tell me if this is solved?
Comment 3 Joel Madero 2013-01-10 19:08:10 UTC
marking as NEW as Marcus has said it is confirmed
Comment 4 vlb 2013-01-25 13:24:35 UTC
confirm in LO Versie 4.0.0.2 .0.2 (Bouw-id: 5991f37846fc3763493029c4958b57282c2597e)
windows 7 64 bits
Comment 5 Michel Rudelle 2013-01-26 17:54:12 UTC
Hi,
I reproduce with rc2:
Version 4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e) - Vista

The behaviour is as follows:
1 / When the condition is satisfied, ​​the style is applied with respect for the choice protected / unprotected (that's ok)
2 / Otherwise, the cell is always protected regardless of the style applied

Critical => this bug forbids to use previous spreadsheets where conditional formatting are applied on cells where you have to enter values ! A lot of users will be concerned
Comment 6 vlb 2013-01-26 18:18:31 UTC
@ Michel Rudelle,

Thanks for your attention and this is very boring! I hope it can solved.
Comment 7 Joel Madero 2013-01-26 21:45:14 UTC
While I disagree with this being a critical bug (no crash, no memory eat up, etc...) which is usually a pre-condition for such a high priority...I hope Markus can take a look at this one soon.

Markus -- can we assign you to this one?
Comment 8 headsup 2013-01-29 21:08:54 UTC
*** Bug 59968 has been marked as a duplicate of this bug. ***
Comment 9 Not Assigned 2013-01-30 01:23:34 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e29af062de877476f5382e8d7368c3de4409b47

if no cond format is valid use the existing protection, fdo#58826



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Michel Rudelle 2013-01-31 10:31:09 UTC
*** Bug 59289 has been marked as a duplicate of this bug. ***
Comment 11 vlb 2013-02-01 14:21:40 UTC
I have test in master LO Version 4.1.0.0.alpha0+ (Build ID: 027bb41aa16793e88e9fc1b3550c8c893363647).
The bug is solved and works correct now.
Thanks for the attention and i hope it can be solved for LO 4.0.0
Comment 12 Not Assigned 2013-02-01 17:04:21 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c6b21c31904b2ed007f961e4bf094af1a1981c7&h=libreoffice-4-0

if no cond format is valid use the existing protection, fdo#58826


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 janekptacijarabaci 2013-02-24 07:20:56 UTC
*** Bug 60897 has been marked as a duplicate of this bug. ***
Comment 14 janekptacijarabaci 2013-02-24 07:22:55 UTC
*** Bug 61048 has been marked as a duplicate of this bug. ***
Comment 15 Michel Rudelle 2013-02-25 14:55:43 UTC
Verified with:
Version 4.0.1.1 (Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659) - Vista-32b
It's ok
Thanks
Comment 16 David 2013-02-27 11:49:36 UTC
Verified that it's ok and solved on:

Version 4.0.1.1 (.deb 64bits)
Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659
S.O: Linux Mint14 64bits


Thanks for your great work Markus!
David.