Bug Hunting Session
Bug 58978 - FILEOPEN and FILESAVE causes General Error for .odt
Summary: FILEOPEN and FILESAVE causes General Error for .odt
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: highest blocker
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.1.0
Keywords:
: 61567 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-01-03 11:25 UTC by Jorendc
Modified: 2013-05-19 20:51 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Error while opening a .odt (120.90 KB, image/png)
2013-01-03 11:25 UTC, Jorendc
Details
Error while saving a document as .odt (19.96 KB, image/png)
2013-01-03 11:26 UTC, Jorendc
Details
general error gdb log (8.92 KB, application/rtf)
2013-04-14 22:38 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-01-03 11:25:23 UTC
Tested with Mac OSX 10.8.2

How to reproduce:
* Open a random .odt file (by double clicking on the file in Finder, or open it with LibreOffice)

Current behavior: General Error and the file opens correctly (as far I can see)

Expected behavior: No general error


While saving a .odt file same behavior:

How to reproduce:
* Open Writer
* Write something down (or nothing)
* File > Save
* Save file somewhere with a name as .odt

Current behavior: Error saving the document <document name>: General Error.
The file saves correctly as far I can see.

Expected behavior: No general error

LibreOffice 4.1.0.0.alpha0+ (Build ID: 73731b01cd65defdf9b42a9754bede3ba84221d)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-02_08:47:51
Comment 1 Jorendc 2013-01-03 11:25:46 UTC
Created attachment 72439 [details]
Error while opening a .odt
Comment 2 Jorendc 2013-01-03 11:26:12 UTC
Created attachment 72440 [details]
Error while saving a document as .odt
Comment 3 Jorendc 2013-01-03 11:53:38 UTC
CAN'T reproduce:
4.1.0.0.alpha0+ (Build ID: bb51791ae49ecded0f618b4534893adb8fcf917)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-22_01:05:08

CAN'T reproduce:
4.1.0.0.alpha0+ (Build ID: 45a85b5af82d130bb3eea2b6a168f4ceaff9975)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-28_01:21:51

CAN reproduce:
4.1.0.0.alpha0+ (Build ID: 00234d0578419c3d0847dd89554186146121f60)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-01_08:03:47

CAN'T reproduce:
4.1.0.0.alpha0+ (Build ID: 27a66ce174d8c5c2947056cbf39533be55e1417)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-29_14:04:45

CAN'T reproduce:
4.1.0.0.alpha0+ (Build ID: c5132e30fb09477aa46d810dd86727b3aa8cf20)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-30_01:12:12

Conclusion: bug is entered between December 30 01:12:12 and January 1 08:03:47
Comment 4 Jorendc 2013-01-03 12:04:57 UTC
I add bug 43246 to 'See Also' because this bug isn't 100% a duplicate of this bug. There they speak about 'MinGW'; I use build for Mac OS X and this bug is related to 4.1, not master old - 3.6
Comment 5 Jorendc 2013-01-10 16:27:49 UTC
works again in Version 4.0.01 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799) TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-09_10:49:53

-> WORKSFORME
Comment 6 Jorendc 2013-01-20 00:35:30 UTC
I mark this bug back as unconfirmed because the problem is there again ... (same instructions)
Comment 7 Jorendc 2013-01-20 00:41:17 UTC
Can't reproduce using 4.0.0.1 RC1; same OS (Mac OSX 10.8.2)
Comment 8 Emir Sarı (away) 2013-01-21 20:14:34 UTC
I can confirm this. A simple .odt file gives this error, while saving and opening. But at last file saves and opens fine. 

Version 4.1.0.0.alpha0+ (Build ID: dc44862f0e711fe0cf93063f72ebe1dec598d92)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-19_22:49:36
Comment 9 Don't use this account, use tml@iki.fi 2013-01-24 07:49:03 UTC
Could not reproduce with libreoffice-4-0~2013-01-21_18.50.48_LibO-Dev_4.0.0.1_MacOS_x86.dmg on 10.8.2.

(But I *have* seen such an apparently bogus "General Error" dialog popping up in a self-built LO from current master, built with --enable-debug and using latest Xcode Clang, against SDK 10.7.)
Comment 10 Emir Sarı (away) 2013-01-25 17:35:14 UTC
So, it seems this bug rather affects the master builds but not the 4.0 branch.
Comment 11 Alberto Ferreira 2013-01-27 20:11:15 UTC
I have the same problem in Ubuntu 12.10 withVersion 4.1.0.0.alpha0+ (Build ID: a1808e0d38dd36d590a5bae26a02c49252d6162) when I try to open or save a in odt.

I can open and save any document in .doc or .docx, when i try to save in .odt libreoffice crash.


In the console I get this message:

raptor_sequence.c:419: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.
raptor_sequence.c:419: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.


good luck.
AFerreira
Comment 12 Petr Mladek 2013-02-04 12:52:30 UTC
This bug seems to be reproducible only in the 4.1.0.0.alpha0+ builds => let's move it from 4.0 to 4.1 MABs.
Comment 13 Julien Nabet 2013-02-09 05:57:03 UTC
Alberto: could you try to retrieve a bt, even without symbols, by following this link:
https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_.28on_Linux.29 ?
Comment 14 Rainer Bielefeld Retired 2013-02-20 18:25:58 UTC
Hm, can it be that correct Operation System selection is missing? I only see Mac in the comments.

"Bug 61021 - MinGW: FILESAVE Writer document shows "General Error" also shows the same symptoms, Error message, but opens documents correctly; what ever that might mean (and that one might be DUP of Bug 43246
Comment 15 Jorendc 2013-03-01 21:25:28 UTC

*** This bug has been marked as a duplicate of bug 61567 ***
Comment 16 Jorendc 2013-03-01 21:26:02 UTC
I'm sorry, I need to do it the other way around. Sorry for the spam
Comment 17 Jorendc 2013-03-01 21:26:31 UTC
*** Bug 61567 has been marked as a duplicate of this bug. ***
Comment 18 Jean-Baptiste Faure 2013-03-01 22:44:15 UTC
Could not reproduce with my own build of Version 4.1.0.0.alpha0+ (Build ID: 74e40fbbbdb0b09f6529a26984f942a3d4b788b) under Ubuntu 12.04 x86-64

Best regards. JBF
Comment 19 Jorendc 2013-03-27 17:39:10 UTC
I did not reproduce this behavior anymore past few weeks... So I think this is fixed somehow (Linux Mint 14 x64 as well as Mac OSX 10.8.3). Therefore I mark this as RESOLVED WORKSFORME.
Thanks <don't know who> for fixing it!

Kind regards,
Joren

PS: if someone is still dealing with this issue/if this issue returns, please mark this bug as REOPEN.
Comment 20 Jorendc 2013-04-14 22:38:10 UTC
I have to reopen this bug :(.

I can reproduce it again (with my own build) on my Mac OSX 10.8.3. LibreOffice Version: 4.1.0.0.alpha0+ Build ID: afb3af7ce5fef803d42a549095863e6bb8210ef

I ran a gdb debug on it (without breakpoints, so I can see the console output/log). I saw this warning passing by when opening a random odt file:

warn:legacy.osl:3691:1:tools/source/ref/errinf.cxx:334: Error nicht behandelt

and then some other warnings:

warn:sfx2.control:3691:1:sfx2/source/control/dispatch.cxx:1476: Childwindow slot missing: 10367
Reading symbols for shared libraries . done
warn:sfx2.control:3691:1:sfx2/source/control/dispatch.cxx:1476: Childwindow slot missing: 10367
warn:sfx2.control:3691:1:sfx2/source/control/dispatch.cxx:1476: Childwindow slot missing: 10367

I'll attach the full gdb log (I only opened a file from the start center).
Comment 21 Jorendc 2013-04-14 22:38:45 UTC
Created attachment 77960 [details]
general error gdb log
Comment 22 Caolán McNamara 2013-04-15 13:40:51 UTC
Is this a mac only bug, and a failure to find/load the upgraded libraptor on that platform ?
Comment 23 Stephan Bergmann 2013-05-16 14:26:54 UTC
(In reply to comment #21)
> Created attachment 77960 [details]
> general error gdb log

says:

> warn:sal.osl:3691:1:sal/osl/unx/module.cxx:168: dlopen(/Users/Joren/lo/core/solver/unxmacxi.pro/installation/opt/LibreOffice.app/Contents/MacOS/../program/libunordflo.dylib, 9): dlopen(/Users/Joren/lo/core/solver/unxmacxi.pro/installation/opt/LibreOffice.app/Contents/MacOS/../program/libunordflo.dylib, 9): Library not loaded: /@.__________________________________________________OOO/lib/libraptor2-lo.0.dylib
>   Referenced from: /Users/Joren/lo/core/solver/unxmacxi.pro/installation/opt/LibreOffice.app/Contents/MacOS/librdf-lo.0.dylib
>   Reason: image not found
> warn:cppuhelper:3691:1:cppuhelper/source/shlib.cxx:502: loading component library failed: file:///Users/Joren/lo/core/solver/unxmacxi.pro/installation/opt/LibreOffice.app/Contents/MacOS/../program/libunordflo.dylib

So this is a bug in how LO's librdf-lo.0.dylib is built and references libraptor2-lo.0.dylib with a bad path (that hasn't been resolved via solenv/bin/macosx-change-install-names.pl as it should have been).  This might have been an intermittent bug in the build system that has been fixed by now.
Comment 24 Commit Notification 2013-05-16 19:35:29 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b89d4c7fb1c3dd3a4af42380eb8de92d60a102e

fdo#58978 Typo



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Jorendc 2013-05-19 20:51:17 UTC
I can not reproduce this anymore using Mac OSX 10.8.3 with LibreOffice Version: 4.1.0.0.alpha1+ Build ID: 43c234b0481fe63b8c4823affad066c6362f506 , so looks fixed indeed.

I build that version my own, with parameters: 

--enable-debug
--enable-dbgutil
--without-java

Kind regards,
Joren