Bug 59418 - EDITING: Use F4 for absolute reference toggle
Summary: EDITING: Use F4 for absolute reference toggle
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.1.0
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2013-01-15 12:58 UTC by bugquestcontri
Modified: 2016-10-25 19:17 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-01-15 12:58:23 UTC
quote:
Absolute reference is set to Shift+F4 (because F4 is set to Data Sources). This is quite annoying since F4 is the STANDARD key since Lotus 123...
unquote
Above quote is from 
http://ask.libreoffice.org/en/question/9898/asbolute-cell-reference-shortcut-key/?answer=9900#post-id-9900

I do feel the same and just changed the key allocation my self. However, it would avoid a lot of frustration and questions in AskLibO if the the key allocation could be changed to F4= absolute/relative reference and Shift-F4 = Datasource.

              
Operating System: Windows XP
Version: 3.6.4.3 release
Comment 1 Steve Leffler 2013-04-25 21:24:18 UTC
Agreed. The F4 shortcut to toggle through relative and absolute reference options has been the standard for a long time, supported by many different spreadsheet programs. LibreOffice should retain this behavior.
Comment 2 Ed Weber 2014-08-08 15:49:10 UTC
As a Professor trying to show students the legitimacy of Libre Office as an alternative to expensive office application solutions, having this kind of inconsistency adds a completely unnecessary perception of incompatibility which has to be explained away or compensated for.  This minor change will go a long way to help bring along converts!
Comment 3 blackton2002-mail 2015-04-08 16:31:36 UTC
I highly support the request.
It is causing great trouble if you want to persuade people to look at Calc.

Regards
Andy
Comment 4 Yousuf Philips (jay) 2015-10-17 12:39:13 UTC
My suggestion to a dev who may fix this is to have both F4 and Shift+F4 both for absolute reference toggle, so that new and old users are not negatively affected by the change and have data sources as Ctrl+Shift+F4.

This is similar to navigator always being activated by F5 in all modules except Impress, where F5 starts the presentation and Ctrl+Shift+F5 is for navigator.
Comment 5 Commit Notification 2015-10-17 15:22:33 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=893b07c6cb429c2c9815ad2249a803e668e59499

tdf#59418 : Use both F4 and SHIFT+F4 for absolute reference toggle in calc

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Cor Nouws 2015-10-17 15:53:00 UTC
So sh/could we offer Ctrl+F4 or Ctrl+Shft+F4 for opening Source browser in Calc, would that make a good choice?
Comment 7 Alex Thurgood 2015-10-17 16:45:16 UTC
Has anyone bothered to consider the impact changing this shortcut will have on users of :

1) Base
2) Writer and mailmerge database sources
3) Shortcuts on Mac OSX ?

https://wiki.openoffice.org/wiki/Mac_OS_X_Porting_-_Keyboard_Shortcuts
Comment 8 Alex Thurgood 2015-10-17 16:50:21 UTC
So now we have F4 in Writer to reveal the data source browser and an as yet undefined solution for Calc ? Not very coherent from an application wide perspective is it ?
Comment 9 Cor Nouws 2015-10-17 19:28:01 UTC
(In reply to Alex Thurgood from comment #8)
> So now we have F4 in Writer to reveal the data source browser and an as yet
> undefined solution for Calc ? Not very coherent from an application wide
> perspective is it ?

That is true. But the advantage for new users to use F4 as known, might be given more weight? And - maybe I'm wrong - I do not expect the data source browser to be used that often in Calc.. ?
Comment 10 m.a.riosv 2015-10-17 21:44:13 UTC
I'm with @Alex, I don't understand this changes in this way. And I was used to F4 with 123.

OTH, if we are not editing a cell, with the modification pressing F4, what does? if nothing, could seems like a bug, for the user LibreOffice/OpenOffice user.

Maybe a solution satisfying better all users could be:

For calc:
- While not editing a cell, F4 works like now, opening the Source browser.
- Editing a cell, F4 toggles through relative and absolute reference.

Hope this is feasible solution.
Comment 11 Yousuf Philips (jay) 2015-10-18 16:00:45 UTC
(In reply to Cor Nouws from comment #6)
> So sh/could we offer Ctrl+F4 or Ctrl+Shft+F4 for opening Source browser in
> Calc, would that make a good choice?

Ctrl+F4 is a globally unusable shortcut key is its the Windows key to close the current window.

(In reply to Alex Thurgood from comment #8)
> So now we have F4 in Writer to reveal the data source browser and an as yet
> undefined solution for Calc ?

The patch changed data sources to Ctrl+Shift+F4 as suggested in comment 4.

> Not very coherent from an application wide perspective is it ?

A number of lesser used advanced features seem to be hogging up the easily accessible Fx keys and it would be good that there were coherence of their shortcut key by changing them globally to a different shortcut key.
Comment 12 Alex Thurgood 2015-10-19 14:42:41 UTC
(In reply to Yousuf (Jay) Philips from comment #11)
> (In reply to Cor Nouws from comment #6)
> > So sh/could we offer Ctrl+F4 or Ctrl+Shft+F4 for opening Source browser in
> > Calc, would that make a good choice?
> 
> Ctrl+F4 is a globally unusable shortcut key is its the Windows key to close
> the current window.

1) On OSX, the function key Fn needs to be pressed at the same time as the actual F1-F12 keys in order for anything to happen. So the current change to Calc now means that if I want to display the data source brwoser, I need to press 4 keys in all to get a result, compared to 2 keys in current 5.0.2.2. 

2) Additionally, and even worse, Ctrl-Shift-F4 on Mac is assigned to cycling through the open windows on a given desktop space.

In other words the change that has been made doesn't even work on OSX.


Now please tell me where the rationale is for introducing a change of this type which causes a regression, as there is now no shortcut at all in Calc for accessing the data source browser.
Comment 13 Alex Thurgood 2015-10-19 14:47:47 UTC
FWIW, I have just tested 
 Version: 5.1.0.0.alpha1+
Build ID: a80c3a5c14399802d7bbd6fb9a1b57621a594445
Locale : fr-FR (fr.UTF-8)

OSX 10.11 which is my justification for comment 12 so I know that that newly defined shortcut doesn't work.
Comment 14 Ed Weber 2015-10-19 21:29:05 UTC
(In reply to Alex Thurgood from comment #12)

> Now please tell me where the rationale is for introducing a change of this
> type which causes a regression, as there is now no shortcut at all in Calc
> for accessing the data source browser.

The rationale is quite simple: In calc, the ability to change cell references between absolute and relative references will occur extremely more frequently by all users (especially those migrating from Excel) than the invoking of the data source browser.
Comment 15 Alex Thurgood 2015-10-20 07:10:22 UTC
(In reply to Ed Weber from comment #14)

> 
> The rationale is quite simple: In calc, the ability to change cell
> references between absolute and relative references will occur extremely
> more frequently by all users (especially those migrating from Excel) than
> the invoking of the data source browser.

<irony on>
Oh, so that's alright then. Wouldn't want to upset potential migrants from Excel, in comparison to those who have been using F4 to display their data sources for the last 20 years since StarOffice/OpenOffice.org/LibreOffice has been in use.
With that kind of rationale, you may as well just kill off Base straight away, after all, who would it bother ?
<irony off>

More seriously, and absent the disgruntled population of "advanced users" of database features that this change has created, the rationale you mention has led to collateral damage for which the implemented solution doesn't work on OSX. Is there a fix for that ?
Comment 16 Yousuf Philips (jay) 2015-10-20 16:17:23 UTC
(In reply to Alex Thurgood from comment #12)
> 1) On OSX, the function key Fn needs to be pressed at the same time as the
> actual F1-F12 keys in order for anything to happen. So the current change to
> Calc now means that if I want to display the data source brwoser, I need to
> press 4 keys in all to get a result, compared to 2 keys in current 5.0.2.2. 

Thanks for the info and sad to hear that mac forces you to have to press an additional key to access the Fx keys.

> 2) Additionally, and even worse, Ctrl-Shift-F4 on Mac is assigned to cycling
> through the open windows on a given desktop space.

Then likely that key should be blocked similar to Ctrl+F4 in the keyboard shortcut dialog. So what alternative shortcut do you suggest that would work fine OSX?
Comment 17 Alex Thurgood 2015-10-20 16:30:07 UTC
Jay : my suggestion is to revert the change of course, not suggest an alternative that would work on all OSes.
Comment 18 blackton2002-mail 2015-10-20 17:51:16 UTC
Guys,

I think I need to step-in from user perspective.

Shift+F4 for absolute reference you use nearly every day if you are a heavy user. E.g. you are an analyist or controller.
The datasource via F4 is very rarely used.

And now guess what, it's not only apple where you have to click another key to access FN1-12. It's also a lot of Lenovo Laptops... So for absolute reference which you need all the time you need to press three keys then. And for datasource which you need once a week or even less... just F4.

And please don't explain me that I should change the keyboard shortcuts myself. 98% of the users do not know and will not do it. I have done it but I cannot explain anybody else that there is a good reason for that and that they shall change it by their own. It's users you need to provide solutions, not experts. 

My suggestion: why not globally switching datasource to Shift+F4 and keeping absolute reference with F4.

Best regards
Andy
Comment 19 Jean-Francois Nifenecker 2015-10-20 19:10:11 UTC
It is out of my understanding why one would actually break an existing and working functionality, just for the sake of pleasing newcomers with an Excel background.
If the Excel users are heavily using that F4 shortcut, then learning it is a breeze. For the ones who don't use it (often), then they'll have to refer to the help system, which is what they would do with Excel, anyway.
Given all the pros and cons that are being exposed in this report, I think a status quo (ie, keep the Shift-F4 shortcut for Calc absolute refs and F4 for datasource display) is the better solution, by far.
Comment 20 blackton2002-mail 2015-10-20 20:07:19 UTC
(In reply to Jean-Francois Nifenecker from comment #19)
> It is out of my understanding why one would actually break an existing and
> working functionality, just for the sake of pleasing newcomers with an Excel
> background.

My suggestion is just to put in exchange of each other F4<->Shift F4 functionality everywhere. That wouldn't lead to a break in working functionality.

> If the Excel users are heavily using that F4 shortcut, then learning it is a
> breeze. For the ones who don't use it (often), then they'll have to refer to
> the help system, which is what they would do with Excel, anyway.
> Given all the pros and cons that are being exposed in this report, I think a
> status quo (ie, keep the Shift-F4 shortcut for Calc absolute refs and F4 for
> datasource display) is the better solution, by far.


This is not changing that users are facing waste with Shift+F4 as it creates unneeded motion in the sense of Tachi Ohno's TPS.
If your point is that excel users shall learn their way I have to object that. It distracts users, users donate or pay indirectly to the project or just distribute the software further. If we can increase the number of users by such a simple change it is folly not doing it because it means more cash for development.
Hence status quo is not the better solution. It's not even the lean one.
Comment 21 Francisco 2015-10-21 01:58:11 UTC
Instead of adding Ctrl key to this mess, why not simply invert them: F4 for absolute references and shift+F4 for database source? And if somebody misses the opposite, he/she can revert it from the shortcut configuration dialog.
Comment 22 Cor Nouws 2015-10-21 16:15:38 UTC
Tools > Options > Calc > Interoperability has the choice for Default or OOo legacy key bindings.

Could be an option to set F4 for Data source as legacy and F4 for toggle + Ctrl+F4 for Data source as Default ?
Comment 23 blackton2002-mail 2015-10-21 16:49:08 UTC
(In reply to Cor Nouws from comment #22)
> Tools > Options > Calc > Interoperability has the choice for Default or OOo
> legacy key bindings.
> 
> Could be an option to set F4 for Data source as legacy and F4 for toggle +
> Ctrl+F4 for Data source as Default ?

I like this notion as well.

But if this change shall be globally, then we will need to find a global entry in the settings.
Comment 24 Mikeyy - L10n HR 2015-11-30 09:25:15 UTC
+1 for F4 as absolute reference
I would just exchange keys like suggested and announce it in changelog and 5.1 materials. Yes, some people will not be happy with it, but from my point of view, absolute cell referencing is used daily and I'm not sure if I used data sources twice this year. Plus, it's F4 in every other application except LO/OO.
Comment 25 zahra 2016-01-31 11:54:43 UTC
hi. 
you mentioned that control+f4 is not good option for replacement, because this is standard keyboard for windows, while alt+f4 is special key in windows for exiting the programs.
Comment 26 Yousuf Philips (jay) 2016-02-27 22:19:20 UTC
The change has been added to the 5.1 release notes and the issue with the new shortcut key not working on mac was incorrect as Fn needed to be pressed with the new combination in order for it to work.