Bug 59961 - counting characters per line in status bar
Summary: counting characters per line in status bar
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: CursorPosition (view as bug list)
Depends on:
Blocks: 79059 Statusbar Word-Count
  Show dependency treegraph
 
Reported: 2013-01-28 09:30 UTC by vulcain
Modified: 2017-12-04 10:43 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
An example document of how doing subtitles in LibO is easier than ever. (22.89 KB, application/vnd.oasis.opendocument.text)
2015-04-08 23:30 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2013-01-28 09:30:05 UTC
In LibreOffice 3.6, there are a new feature:
" Word count (whole document and selection) in status bar"
https://wiki.documentfoundation.org/ReleaseNotes/3.6#Writer

But some professions need more, like a counting per line. At this time, we could only have a count for all the text or for a selection.

The counting by line could be choose in status bar by a click right and selection with a contextual menu. After that, the status bar show the counting where the cursor is.

In LibreOffice 3.6's status bar: 
+----------+------------+----------------+----------+---
| Page 1/1 | Words : 42 |  Default Style | Language | ... 
+----------+------------+----------------+----------+---

Expected :
+----------+----------------------+----------------+----------+---
| Page 1/1 | Words (per line) : 6 |  Default Style | Language | ... 
+----------+----------------------+----------------+----------+---
Comment 1 m.a.riosv 2013-01-29 01:10:02 UTC
Hi vulcain,

It is a request for enhancement.

Please change the importance from normal to enhancement.
Comment 2 Owen Genat (retired) 2013-12-14 09:41:50 UTC
Confirmed by related Apache issue. Status set to NEW. Component set to UI. Version set to Inherited From OOo.
Comment 3 Adolfo Jayme 2013-12-14 19:54:35 UTC
From an UX POV: I think this could go in a tooltip over the current word counter in the status bar, otherwise it would be even more crowded.
Comment 4 Owen Genat (retired) 2013-12-15 00:11:10 UTC
I tend to agree with comment #3. Either a tooltip or change this area so it cycles through different forms of display (characters, words, lines, etc.) per mouse click. I remember reading a recent discussion about changes to this part of the status bar either on the mailing lists or in another bug report, but I could not find it to reference.
Comment 5 vulcain 2013-12-15 00:14:06 UTC
@ Adolfo Jaym: Why not a mouse selection? You make mouse's right click in status bar and select how it show you the counting.

In other words like the same operation for the language or the style (the both show in status bar).

The goal of this bug is only to have a feature: a count by line. How it show you it secondary for me.
Comment 6 Cor Nouws 2013-12-15 14:06:13 UTC
Hi Vulcain,

(In reply to comment #0)

> But some professions need more, like a counting per line. 

And this real time for each line?
(for occasional counting selecting a line or whatever is simple enough.)

thanks,
Cor
Comment 7 vulcain 2013-12-15 14:36:17 UTC
(In reply to comment #6)
> And this real time for each line?
> (for occasional counting selecting a line or whatever is simple enough.)
> 

I open this after a discussion with a french translator: http://nabble.documentfoundation.org/Est-il-possible-d-afficher-le-nombre-de-caracteres-saisis-td4032129.html 
If you see the Apache's bug, it's the same problem for this profession: translator: https://issues.apache.org/ooo/show_bug.cgi?id=108826
>" My wife translates subtitles for tv programs in Brazil." 

As i understand, for TV or film subtitle we could write only some characters per line (after the screen is too small). 
http://nabble.documentfoundation.org/Est-il-possible-d-afficher-le-nombre-de-caracteres-saisis-td4032129.html#a4032332

I think it 's for real time for the line where is the cursor (where you write).
Comment 8 Owen Genat (retired) 2014-01-06 10:29:21 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 9 Owen Genat (retired) 2014-06-28 10:54:40 UTC
This report would appear to be a duplicate of bug 59791. Character and column position are the same thing and the translation of subtitles for TV are mentioned in both. There are however more links and information in this later report e.g., Apache OO issue, words per line, cycling through various information displays, using a tooltip, etc. It may be more prudent to close the earlier bug as a duplicate of this one. I will leave this for Cor, Joren, or Miguel to best determine how QA want to handle this.
Comment 10 mahfiaz 2015-04-08 23:29:10 UTC
Here is much simpler way to use this:
1) Change your text width to be x characters wide (change page width or margins)
2) Use mono-space font, if you are counting characters, otherwise use the font the TV will be using.
3) To easily spot too long lines one could add indent left 2 cm and for first line -2 cm.
4) For next translation use this one as template.
5) Profit.

As for my opinion, I don't think this enhancement should be implemented. Feel free to persuade me.
Comment 11 mahfiaz 2015-04-08 23:30:01 UTC
Created attachment 114694 [details]
An example document of how doing subtitles in LibO is easier than ever.
Comment 12 mahfiaz 2015-04-08 23:34:24 UTC
*** Bug 59791 has been marked as a duplicate of this bug. ***
Comment 13 mahfiaz 2015-04-08 23:36:29 UTC
I copy over good ideas by un5412@web.de from the duplicate (although I am unsure what the major benefits would be):

The cursor position should be displayed within the in status bar 
(line-no. / x-measure-unit/ y-measure-unit), e.g.

l:8 | c:1 | x:8,54cm | y:21,8cm or
8 | 1 | 8,54 | 21,8 (short version if design-wise running out of space within the status bar)

The measure values should be absolute values staring from the page borders (0/0) if not, optionally, being made available in a configurable way.

This would bring major benefits with regard to creating and editing forms and page layouts and, moreover, ease the everyday use of LibreOffice writer.
Comment 14 Yousuf Philips (jay) (retired) 2015-04-11 10:46:02 UTC
This sounds like it could be merged into bug 79059, as another status context menu option to change the word count field.
Comment 15 Robinson Tryon (qubit) 2016-08-25 05:39:01 UTC Comment hidden (obsolete)
Comment 16 Heiko Tietze 2017-11-14 12:36:11 UTC
Voting for WONTFIX.

A workaround is described in comment 10, another is to just select the line (pos1, shift+end). You can also write a macro. Starting perhaps with this:

| oPos=thisComponent.GetCurrentController.ViewCursor
| x = oPos.Position.x/254 //twips
| y = oPos.Position.y/478
| ThisComponent.CurrentController.StatusIndicator.Start(x & ":" & y,0)
| (doesn't work out the box)

Showing the total word/character count _and_ the cursor position with line and col as known from text editors would clutter the status bar. That could be solved with a toggle function (context menu to chose what to show) rather than tooltip. But I think the cursor position is not of general interest at formatted documents.