Bug Hunting Session
Bug 60425 - Slow document scrolling due to WMF/EMF picture
Summary: Slow document scrolling due to WMF/EMF picture
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
: 97385 100079 (view as bug list)
Depends on:
Blocks: EMF-WMF Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2013-02-07 15:49 UTC by fabien.michel
Modified: 2019-07-30 10:17 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (356.74 KB, application/vnd.oasis.opendocument.text)
2013-02-07 15:49 UTC, fabien.michel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fabien.michel 2013-02-07 15:49:54 UTC
Created attachment 74354 [details]
Sample file

This document was created from MS Office.
I've extracted a problematic page in the attached document.
When the page is showed to screen, LibO become very slow.

The bug comes from the image.
The original file format of image was a png.

The workaround is to extract image from document (right click > save image) and reimport it in place.

This happen on MacOS 10.5 and 10.7 with Libreoffice 3.6.5.2 and LibreOffice 4.0 beta.
Comment 1 tommy27 2013-04-21 10:13:18 UTC
tried test document on Win7 32bit using LibO 4.0.2

scrolling the first 2 document pages is slow.

setting as NEW
Comment 2 Maris Nartiss 2014-06-08 16:47:15 UTC
Same on ~AMD64 Gentoo with LO 4.2.4.2

It seems to happen also with documents created in LO, as indicated by Bug 78529
Comment 3 QA Administrators 2015-07-18 17:43:42 UTC Comment hidden (obsolete)
Comment 4 tommy27 2015-07-19 18:27:56 UTC
still reproducible with LibO 4.4.5.1 and recent 5.1.0.0 alpha daily build
Comment 5 Buovjaga 2016-02-09 08:53:09 UTC
*** Bug 97385 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2016-05-28 03:26:58 UTC
*** Bug 100079 has been marked as a duplicate of this bug. ***
Comment 7 Jean-Baptiste Faure 2016-09-24 20:14:03 UTC
I guess it is a duplicate of bug 45820.

Best regards. JBF
Comment 8 Telesto 2018-06-25 20:22:32 UTC
Repro
Version: 6.2.0.0.alpha0+
Build ID: 7414e07f52af87094240f5c3d9a0eb764e8642f5
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-24_01:44:59
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 Telesto 2019-03-28 18:40:22 UTC
Repro
Version: 6.3.0.0.alpha0+
Build ID: 20ea90a557b5bc744fd234e3a20ab1db484cf88b
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-03-22_03:21:58
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded