Download it now!
Bug 60573 - Conditional formatting does not allow scrolling
Summary: Conditional formatting does not allow scrolling
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0
Keywords: regression
: 69502 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2013-02-10 09:35 UTC by p_kongstad
Modified: 2017-07-17 09:21 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p_kongstad 2013-02-10 09:35:06 UTC
Problem description: 

If you need to apply conditional formatting to a cell not shown presently on your screen you cannot scroll to the position you would like to use.

Steps to reproduce:
1. Open a new spreadsheet.
2. On cell A1 you open the 'Format/Conditional Formatting/Condition'
3. This is not important which condition you choose.
4. Try to have the condition to point at a cell outside your present wiev

Current behaviour:

Point and accept only works on your present view of the part of spreadsheet.

Also using the usage of the arrow key's are blocked. 

Expected behaviour:

That the application allows you to scroll to the cell in the spreadsheet you would like to use for the condition. 

Arrow key's should allow to navigate around in the spreadsheet. 

The same issue applies to:
Version 4.1.0.0.alpha0+ (Build ID: fbfda39d26da6747edb3a4c6d593be7e6b2b0f1)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:master, Time: 2012-12-09_22:33:10
Comment 1 p_kongstad 2013-02-10 09:37:54 UTC
I guess that this is related to the same issue.

The conditional formatting dialogue does not allow to point to cells in another sheet either.
Comment 2 Thomas Arnhold 2013-02-10 10:46:15 UTC
I can confirm this. The range selection dialog for conditional format doesn't allow scrolling in another window.

Tested on Windows 7 with Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89).
Comment 3 Markus Mohrhard 2013-02-14 20:41:42 UTC
I suppose I need to look into that one at some point.

This one might become nasty because I had to add some really ugly hacks to make the dialog modal. This might be the reason why we are no longer able to scroll in the dialog. However we should not return to modeless dialogs for the reference edit dialogs as this causes some nasty problems and will kill the current design of how the conditional format dialogs work together.
Comment 4 p_kongstad 2013-03-12 10:47:22 UTC
Hi,

What is the outlook for this issue?
Comment 5 p_kongstad 2013-04-29 13:42:45 UTC
Hi, I think needs to be changed to confirmed bug. Please see reply from Markus.
Comment 6 Thomas Arnhold 2013-04-29 15:03:32 UTC
@p_kongstad: NEW means confirmed.
Comment 7 p_kongstad 2013-06-15 11:41:11 UTC
Can be reproduced in Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)
Comment 8 p_kongstad 2013-08-17 13:51:48 UTC
Can be reproduced in Version: 4.1.1.1
Build ID: a990db030b8125868501634ff662be1d89d0868
Comment 9 dave 2013-09-21 17:13:26 UTC
This problem started right after version 3.5.7
Comment 10 ign_christian 2013-09-23 05:31:22 UTC
*** Bug 69502 has been marked as a duplicate of this bug. ***
Comment 11 p_kongstad 2013-11-26 15:47:22 UTC
Horizontal scrolling is still in modal mode and not working. However if you move down the vertical scrolling then it will open up for horizontal scrolling.

Vertical scrolling working in Version: 4.3.0.0.alpha0+
Build ID: ee1b1b865b0ccc7418bbfad2a60cd14f851135a8
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-11-22_23:47:31
Comment 12 dave 2013-11-29 00:47:19 UTC
It seems this bug was posted in February of 2013. Now it's November, ( almost December ) and still not fixed. I didn't understand why it was ever changed, but it was. Anyway, I couldn't wait any more. Locking 3.5.7 was killing me on other things that needed upgrading, but couldn't be upgraded because of 3.5.7's needs. So I uninstalled Libreoffice all together. Put Win7 in a VirtualBox and Bought MS Office. Problem Solved.
Comment 13 p_kongstad 2013-12-07 16:06:43 UTC
Bug still present version Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
Comment 14 p_kongstad 2013-12-12 19:41:29 UTC
Bug still present in Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 15 p_kongstad 2014-06-01 17:05:00 UTC
Still an issue in Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
Comment 16 p_kongstad 2014-09-07 11:16:58 UTC
Still unresolved in Version: 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848

This bug is cripling LibreOffice. Please resolve issue as this is long standing. Generally the whole way of working with conditional formatting need to be finished.
Comment 17 p_kongstad 2014-11-11 21:57:06 UTC
Hi, this long standing bug has not evolved during more than one year and still present in
Version: 4.4.0.0.alpha2+ Build ID: b7c4c78a097f76314982d8c1a9f2e58df95080a1
Version: 4.3.4.1 Build ID: bc356b2f991740509f321d70e4512a6a54c5f243
Comment 18 dave 2014-11-15 04:59:06 UTC
Version 3.5.7 was the last working version of Calc with good conditional formating. I had abandoned libreoffice long ago on 11/29/2013. Cranking out new version after new version with the same old bug is kind of pointless. I just want to get taken off this bug list, and stop getting emails about this thing. I have no plans to ever use libreoffice again.
Comment 19 p_kongstad 2014-11-22 09:53:26 UTC
This is now a longstanding bug, which makes using conditional formatting invalid. This is far from user friendly. Still in Version: 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Locale: en_US
Comment 20 Matthew Francis 2015-03-29 16:07:15 UTC
@Adolfo: You set this bug to ASSIGNED, but didn't point the "Assigned To" field to yourself. If this isn't what you intended, please adjust accordingly
Thanks
Comment 21 Adolfo Jayme 2015-04-06 02:08:40 UTC
@Matthew: it’s not that I forgot to, but the person working on this bug doesn’t seem to have a Bugzilla account ;-)

https://gerrit.libreoffice.org/14258
Comment 22 Commit Notification 2015-05-12 09:55:54 UTC
Henry Castro committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b5915da481990fd6ea272104215d82b6fbf5dbb

tdf#60573 Conditional formatting does not allow scrolling

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.