Download it now!
Bug 60858 - Menu doesn't list anything for horizontal line.
Summary: Menu doesn't list anything for horizontal line.
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard: bibisected40 UX
Keywords: regression
: 65719 83852 (view as bug list)
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2013-02-14 19:21 UTC by Gary Kearney
Modified: 2015-12-22 01:33 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document (9.37 KB, application/vnd.oasis.opendocument.text)
2013-06-19 10:18 UTC, Miklos Vajna
Details
Screenshot on Win7 of Reproducer.odt (78.33 KB, image/jpeg)
2013-07-05 14:40 UTC, Luuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gary Kearney 2013-02-14 19:21:55 UTC
Menu entry for horizontal line seems to be missing or moved. I can work around by entering a graphic, but that doesn't allow for using all the styles easily. --gk
Comment 1 Jorendc 2013-02-23 21:34:54 UTC
I can confirm this is missing using Mac OSX 10.8.2 LibreOffice 4.0.0.3 release. It's still there using 3.6.5.2. Therefore I mark this as regression.

Following our own wiki-guide: https://help.libreoffice.org/Writer/Inserting_a_Horizontal_Line it's located at Insert > Horizontal line.

Kind regards,
Joren
Comment 2 Joel Madero 2013-02-23 21:48:40 UTC
786d524d5ef5d7026b14861c104a5100c5c34f86 is the first bad commit
commit 786d524d5ef5d7026b14861c104a5100c5c34f86
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 06:25:06 2012 +0000

    source-hash-41c2b0375773b2d2945d75e255ea6bb6c7fd378d
    
    commit 41c2b0375773b2d2945d75e255ea6bb6c7fd378d
    Author:     László Németh <nemeth@numbertext.org>
    AuthorDate: Sat Nov 24 17:15:17 2012 +0100
    Commit:     Gerrit Code Review <gerrit@vm2.documentfoundation.org>
    CommitDate: Sat Nov 24 16:19:58 2012 +0000
    
        Updated core
        Project: help  48c8755aca088c7af28cd8ef47c4834175914dff
        fdo#57483 remove check capitalization (ugly 1980 thing)

:100644 100644 c3c6030ca2524901562ab3929e935673afc71830 aef1e548ce98a45bfe5985b09d2a8216ffffd30f M	autogen.log
:100644 100644 537efee1f0aa43276018fbef22f31a039d585277 0d03cdd08ac0b1a4e736e7a74465a8800ca981d1 M	ccache.log
:100644 100644 f2a75602878c4df7953cbf1b55a359cbd9bb0517 ddd1deead2548e7237334d419220468f89fdc6a0 M	commitmsg
:100644 100644 85a79a37af08bd274e297046fa4a10c1d63c9723 c72be0167d41f6011e06840a042d290790db9a40 M	dev-install.log
:100644 100644 92233f8a81a90f0d4783a29c9b4d18e29331386e 15937adfaadaa5398797fb14a5f5f45f32d03d77 M	make.log
:040000 040000 1a8cd079128c641268a10a127c07921bd46b0003 87c1a75f4d31a803fecb37c3cfeef9ffba68873f M	opt



# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# good: [114fd3b76bcba890e6d702d00cef910f1493c262] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect good 114fd3b76bcba890e6d702d00cef910f1493c262
# good: [47498a36f7af8f54e6e3dda89cd4708802a409e6] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
git bisect good 47498a36f7af8f54e6e3dda89cd4708802a409e6
# bad: [66083171ba534818399937597388d325091fffab] source-hash-9d83ad0e99ab182506be99f7d6a2bec7f6fbe8c6
git bisect bad 66083171ba534818399937597388d325091fffab
# good: [5dddcff8ae35692d89751ae98ab8acbbf802b5b4] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
git bisect good 5dddcff8ae35692d89751ae98ab8acbbf802b5b4
# good: [99fa32bfa0d6116217da0834f3a630b3775aa16a] source-hash-246ffb108c7e1f762f8d497750ad2414b85b99ef
git bisect good 99fa32bfa0d6116217da0834f3a630b3775aa16a
# bad: [786d524d5ef5d7026b14861c104a5100c5c34f86] source-hash-41c2b0375773b2d2945d75e255ea6bb6c7fd378d
git bisect bad 786d524d5ef5d7026b14861c104a5100c5c34f86
Comment 3 Joel Madero 2013-02-23 21:49:44 UTC
@ Gary - thanks for reporting, when you report please provide steps even in very simple ones like this one. For instance:

1. Open writer
2. Go to insert

Expected:
used to say "horizontal line"

Observed:
This is now missing


Thanks!
Comment 4 Michael Meeks 2013-02-26 15:00:44 UTC
I assume that is this commit:

commit 3be15a051444d4d2f805d95e27831d5f466c1497
Author: Cédric Bosdonnat <cedric.bosdonnat@free.fr>
Date:   Fri Nov 23 23:59:10 2012 +0100

    Removed horizontal rule ugly 1990 thing
    
    Change-Id: Ifafd8b2ffd9af90b6ac4ed2ee0ccd3c5e980731c
    
    Conflicts:
        sw/source/ui/misc/insrule.cxx

That dialog, and the artwork set / gallery that went with it were indeed a horror.

So - I assume this is formally a NOTABUG - but of course we should ensure that the UX advise people have given their input and that we havn't completely removed the ability to insert an attractive horizontal rule.

So feel free to open if you feel strongly about it :-) Cedric - I guess if this generates more angst, we should take this to ux-advise for some more feedback ?
Comment 5 V Stuart Foote 2013-06-13 17:01:50 UTC
Some indication this is not acceptable UX, and could find no UX-Advise discussion. 

http://nabble.documentfoundation.org/LO-4-0-3-3-Insert-Horizontal-rule-is-missing-tt4061308.html#none

http://ask.libreoffice.org/en/question/15930/selection-of-horizontal-rule-no-longer-possible/

An enhancement to fully add function to styles or restore some semblance of its use in direct styling as before?
Comment 6 Joel Madero 2013-06-13 17:03:27 UTC
Reopened is thus incorrect status - REOPENED is only if the bug is assigned. Marking as UNCONFIRMED again and adding UX advice whiteboard status to try to get them to comment.
Comment 7 V Stuart Foote 2013-06-13 18:29:14 UTC
*** Bug 65719 has been marked as a duplicate of this bug. ***
Comment 8 Regina Henschel 2013-06-13 21:54:32 UTC
Those rulers were not embedded in the document but linked from the gallery theme. Therefore removing of the theme breaks the design of older documents. Even if you remove the item from the menu, it is still necessary to keep the folder with the ruler pictures.
Comment 9 maurice 2013-06-14 16:20:47 UTC
(In reply to comment #8)
> Those rulers were not embedded in the document but linked from the gallery
> theme. Therefore removing of the theme breaks the design of older documents.
> Even if you remove the item from the menu, it is still necessary to keep the
> folder with the ruler pictures.

Yes indeed! I tried to make that compatibility problem in:

   https://bugs.freedesktop.org/show_bug.cgi?id=65719

which I raised after failing to find this one, and has now been marked as a duplicate of this.
  I have a document that has fallen foul of this function omission.
Comment 10 Joel Madero 2013-06-14 16:23:11 UTC
Well are there two issues here - one of which is the initial description (inability to easily add horizontal line) - the 2nd issue is that the gallery has been tweaked in a way that breaks old documents. Technically we could fix problem #2 without reversing the change that Michael mentioned in comment 4
Comment 11 V Stuart Foote 2013-06-14 16:30:27 UTC
We have an open UX-Advise thread on this subject here:

http://nabble.documentfoundation.org/How-to-provide-horizontal-rule-paragraph-separators-tt4061353.html
Comment 12 Joel Madero 2013-06-14 16:31:14 UTC
My suggestion is NEEDINFO until that topic is finalized, then mark this as NEW with the findings from that thread. Is this acceptable?
Comment 13 V Stuart Foote 2013-06-14 17:28:57 UTC
(In reply to comment #12)
>...acceptable?

Sure, also a good test of your UX whiteborad to see if it steers folks to the discussion.
Comment 14 Joel Madero 2013-06-14 17:30:20 UTC
which actually may become a component instead so that the mailing list is auto cc'ed ;) But for now, NEEDNIFO until the mailing thread/UX team reaches a conclusion

Thanks V Stuart Foote for the details here
Comment 15 Miklos Vajna 2013-06-19 10:18:18 UTC
Created attachment 81060 [details]
Reproducer document

Created using system-LO 3.6 on openSUSE 12.3.
Comment 16 Miklos Vajna 2013-06-19 10:22:26 UTC
It sounds to me that this never really worked, e.g. the bugdoc has ../../../../../../../../../usr/lib64/libreoffice/program/../share/gallery/rulers/blurulr2.gif; now opening that on Windows won't work at all, I imagine.

OTOH I agree that if you consistently used e.g. only the LO version shipped by your Linux distro, that worked, and probably after upgrading to 4.0, it no longer does.
Comment 17 V. Crommen 2013-06-26 07:45:43 UTC
Meny entry for horizontal line is missing since the 4.0 release.
Comment 18 Luuk 2013-07-05 14:39:00 UTC
I openend the reproducer-doc in LO (Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2))
I selected the 'line', went to Insert/Picture/From file
and made the attached screen-shot
Comment 19 Luuk 2013-07-05 14:40:46 UTC
Created attachment 82077 [details]
Screenshot on Win7 of Reproducer.odt
Comment 20 Michael Meeks 2013-07-05 15:18:51 UTC
So - thanks for the document; it confirms - as we suspect that this feature was historically broken - hard-coding platform, and version, and install-directory specific cruft into files; as such there is almost nothing we can do about legacy files with these rulers loosing their rulers.

Similarly, the feature was sufficiently disliked by UX, devs (and sufficiently problematic) that it was disabled & removed: hopefully that will stop new broken documents from being created.

If people want to open a new enhancement around building a new gallery of modern & attractive ruler artwork, and adding a new feature to copy those into the document then they are welcome to do so :-) even more welcome would be someone to work on coding that feature.

Thanks !
Comment 21 V Stuart Foote 2013-07-05 16:44:22 UTC
The horizontal rule in Writer was just a specialized (and functional) case of decorative artwork which had a  convenient, if poorly implemented, Insert -> Horizontal rule(r) menu option. 

Removal of the patchwork of galleries supporting horizontal rules--with no ability to relink/fix existing < 4.0 documents--is an unfortunate consequence of what was probably necessary code maintenance. 

Can understand that it was done, unfortunately it leaves many users confused and concerned about broken documents. And the remaining > 4.0 provisions to assert Paragraph border styles are confusing to users and render rudimentary results at best. 

Frankly, the simplicity of the Insert menu item was clean UX.

Maybe a little quick to set this particular issue resolved? There has been very little discussion or UX advice of what could be the scope and mechanism of decorative art borders and separators in all LibreOffice components. Suspect opening a new UX enhancement issue would end up a running wish list with little focus and too broad a scope.
Comment 22 Michael Meeks 2013-07-05 19:37:14 UTC
> Removal of the patchwork of galleries supporting horizontal rules--with
> no ability to relink/fix existing < 4.0 documents--is an unfortunate
> consequence of what was probably necessary code maintenance. 

Well - it is possible to imagine a whole load of schemes for fixing existing documents with broken horizontal rulers in them :-) what is hard to see is wil will have time to work on that; it's fundamentally an easy hack if someone has the time to dig out all the code pointers to try to do the repair. This feature never worked interoperably across platforms eg. in the past; that those documents continued to work for the original user was ultimately pure chance.

> Maybe a little quick to set this particular issue resolved? There has been
> very little discussion or UX advice of what could be the scope and mechanism 

Please create a new bug - use the UX-Advise component - we now use that to track open UX requests & input and it's mirrored to the mailing list. That is by far the best way to track and handle the: "should we add some insert->ruler functionality" back issue. Until there's some input there, I can't see this "missing menu" bug being fixed (it is as-designed) - hence the request for another, clean bug, vs. that component to discuss it.

Anyhow - thanks for your concern :-)
Comment 23 Stefan Knorr (astron) 2013-07-27 12:17:40 UTC
Do we have a new UX-advise bug for this already?
If not, let me add my 2 cents...

My best idea would be to check for the various paths that were used for these symbols in the past and try to come up with a similar UTF-8 representation for that ruler (i.e. most of those elements could be replaced with simple bullets). Is that possible somehow?
Otherwise, if that's not supported, we probably need to try with a simple rule.

(Btw, note that MSO has/had(?) a similarly stupid ruler functionality:
http://www.robweir.com/blog/2006/07/game-of-zendo.html )
Comment 24 Luuk 2013-07-27 12:38:31 UTC
enter "---" or "___", and you will see a nice horizontal line....
Comment 25 maurice 2013-07-27 12:47:20 UTC
(In reply to comment #24)
> enter "---" or "___", and you will see a nice horizontal line....

Sadly, that is not a solution for documents that already have the original 'Horizontal Line'.
  What is needed is a horizontal line as a simple object in its own right.
Comment 26 Luuk 2013-07-27 17:13:48 UTC
its solved in 4.1
http://www.libreoffice.org/download/4-1-new-features-and-fixes/
On Windows, modern IMEs show their suggestion windows at more easy-to-read position. fdo#64298 (Yohei Yukawa - Google)
(https://bugs.freedesktop.org/show_bug.cgi?id=64298)

The bullets (and the lines?, but i did not test that ) are saved in the odt file.
Now the only problem is to find the bullets if you removed your old version ;)
Comment 27 Regina Henschel 2014-09-14 17:25:20 UTC
*** Bug 83852 has been marked as a duplicate of this bug. ***
Comment 28 Christopher Wright 2015-08-14 03:49:22 UTC
Since the functionality was intentionally altered and the menu item will not be restored, this is a documentation bug. I do not have edit permissions on the wiki. Someone who does, please edit the page at https://help.libreoffice.org/Writer/Inserting_a_Horizontal_Line to reflect the recommended method of adding a horizontal line.
Comment 29 Joel Madero 2015-08-14 04:31:39 UTC
REOPENED isn't right - setting to NEW
Comment 30 V Stuart Foote 2015-08-14 11:50:21 UTC
Added to the Local Help and documentation Meta bug 80430 for correction of help.

This back to Resolved Wontfix
Comment 31 Yousuf Philips (jay) (retired) 2015-09-03 05:03:37 UTC
I've re-added the horizontal line menu item into the insert menu with the work i'm doing in bug 91781.
Comment 32 Robinson Tryon (qubit) 2015-12-22 01:33:11 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]