Bug 60992 - FILESAVE as .docx ignores 'Background' property in 'Wrap-Through' of DRAW shape
Summary: FILESAVE as .docx ignores 'Background' property in 'Wrap-Through' of DRAW shape
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 70640 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-17 09:08 UTC by Rainer Bielefeld Retired
Modified: 2015-05-15 18:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test kit with source document and some export results (27.47 KB, application/x-zip-compressed)
2013-02-17 09:08 UTC, Rainer Bielefeld Retired
Details
Fail to reproduce (210.24 KB, image/png)
2015-05-15 18:34 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-17 09:08:39 UTC
Created attachment 74967 [details]
Test kit with source document and some export results

I found this problem during my tests for "Bug 54660 - FILEOPEN .docx (MSO2007) (OOXML) ignores wrap property 'Background'"

The combination of these bugs might show that we currently have a more general misunderstanding concerning the Draw 

Steps how to reproduce [Reproducible] with  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit):

1. open "Wrapthroughbackground.odt" from attached test kit
2. Save as .docx (MSO2007) or (OOXML), does not matter
3. close
4. Reopen with MS WORD Viewer
   Expected: Rectangle in Background
   Actual: Rectangle in foreground

That's already broken in LibO 3.3.0

Works fine for Save as .doc (MSO97)
Comment 1 Jorendc 2013-05-29 23:53:08 UTC
I can reproduce this using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: c7da99f37197fb1446af07f17ba33978f15e7f6

Kind regards,
Joren
Comment 2 tommy27 2013-10-19 08:39:00 UTC
*** Bug 70640 has been marked as a duplicate of this bug. ***
Comment 3 tommy27 2013-10-19 08:41:02 UTC
see attachment 87848 [details] 
screenshot of LibO 4.1.2.3 showing the bug

I add Writer expert to CC-list since he already worked on related bugs.
Comment 4 QA Administrators 2015-04-01 14:41:22 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 5 Buovjaga 2015-04-23 13:20:33 UTC
Repro still.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 6 Jorendc 2015-05-15 18:34:55 UTC
Created attachment 115627 [details]
Fail to reproduce

I fail to reproduce, tested using Version: 5.0.0.0.alpha1+
Build ID: f3070563c3071e05e9c448e261fec1e397bffb48
Locale: nl-BE (nl_BE.UTF-8)