Bug 61390 - ACCESSIBILITY: [Template Manager] All key board navigation is lacking
Summary: ACCESSIBILITY: [Template Manager] All key board navigation is lacking
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.1.0 target:4.0.3
Keywords:
: 61468 (view as bug list)
Depends on:
Blocks: Start-Center a11y mab4.0
  Show dependency treegraph
 
Reported: 2013-02-24 11:26 UTC by pierre-yves samyn
Modified: 2016-10-25 19:41 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-02-24 11:26:55 UTC
Hello

The Template Manager is only functional with the mouse:
-It lacks all mnemonic (alt + underlined character)
-Only the arrow keys are used to navigate between tabs.
-Impossible to "go down" in the bottom of the dialog (choice of
categories, and model selection in a category) with the keyboard

Regards
Pierre-Yves
Operating System: All
Version: 4.0.1.1 rc
Comment 1 Jacques Guilleron 2013-02-24 15:08:10 UTC
confirmed under LO 4.0.1.1, windows 7 Home Premium

Jacques Guilleron
Comment 2 V Stuart Foote 2013-02-28 18:48:37 UTC
The UI looks to need addition of basic UAA accessibility functions.
Comment 3 V Stuart Foote 2013-03-02 19:55:33 UTC
*** Bug 61468 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2013-03-02 20:04:06 UTC
replacing bug 61468 on MAB 4.0 (bug 54157)
Comment 5 V Stuart Foote 2013-03-02 20:12:54 UTC
Adding substantive notes from bug 61468:

Description:
 Cor Nouws 2013-02-25 22:33:58 UTC

File > New > Templatemanager

* Tab - no result
* Ctrl+Tab - cycles through the tabs of the dialog, which is odd
  Ctrl+PgDwn/PgUp - does the same, which is OK
* No way to get focuson the folders as shown in the main window

Select folder with the mouse ..

* Enter does not open it
* Tab does not work , ..

Double click to open it ..

* No way to get focus on the templates

Select template with mouse ..

* Enter does not work
* Labels with buttons do not have accelerators..

Comment 1
 Cor Nouws 2013-02-25 22:37:35 UTC

see http://lists.freedesktop.org/archives/libreoffice-ux-advise/2013-January/001730.html
Comment 6 Cédric Bosdonnat 2013-03-19 10:45:25 UTC
One first fix for that:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=eff94128b8434501a6f9c26a5a47cfd7d408f472

With that one, the tab can move the focus to the toolbars
Comment 7 Cédric Bosdonnat 2013-03-20 16:32:27 UTC
Some more fixes for this one:

This commit enables the thumbnail view to get the focus when using the Tab key.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=5fa5f9561dddd2c53511fb951660b4ad397321e8

and this one selects the first item when the thumbnails view gets the focus.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec2f84b376f595b0553297d25b7716f6b97e1b87

The next things to do, will be easier as it is all about implementing the different keys for the thumbnail view.
Comment 8 V Stuart Foote 2013-03-21 17:23:16 UTC
(In reply to comment #7)

> The next things to do, will be easier as it is all about implementing the
> different keys for the thumbnail view.

Pulled a Windows TB Version 4.1.0.0.alpha0+ (Build ID: ff140bb6b8b109f14c270ff059f0b8d71dab5d6)
TinderBox: Win-x86@6, Branch:master, Time: 2013-03-20_23:56:12

Java Access Bridge v2.0.2 w/JRE 1.6u43, NVDA 2012.3.1 active as AT

So far so good! Have arrow control to move across the page tab list & tab control to move into page tabs (Documents, Spreadsheets, Presentations,& Drawings).  

JavaMonkey/JavaFeret responding to focus changes with tab and cursor movements.

But seems a little muddled about parent/descendent roles, seems to read entire tool bar listing with each focus event. And of course no names/alternates in place yet so effectiveness of AT support remains unclear.

Also, with template manager structured as a dialog rather than a pane, F6 does not take session back to the LibreOffice root pane as would be preferred.

Will grab a Linux TB and see how ORCA and ATK/AT-SPI do with it so far.
Comment 9 V Stuart Foote 2013-03-21 17:32:44 UTC
@Joanmarie,

Would you poke at this a bit and give Cédric your take on better instrumenting the template manager for ATK?  TIA.
Comment 10 Commit Notification 2013-03-22 12:33:51 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee819bdd2dab5756cc3bad74f24e50bd7409f308

fdo#61390: simple keybard support in TemplateManager



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2013-03-22 16:17:16 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a25aa2821ccf7318ce4a13efe171763989009d5

fdo#61390: Fixed the tabstop in the TemplateView.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2013-03-22 17:15:13 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43bbcfc7a1625aa79b69c443c492f0969b31baad&h=libreoffice-4-0

fdo#61390: simple keybard support in TemplateManager


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2013-03-22 17:15:33 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9296cf4088a0637f0326803fe220816ebc8daf22&h=libreoffice-4-0

fdo#61390: Fixed the tabstop in the TemplateView.


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 V Stuart Foote 2013-03-23 07:22:29 UTC
@Cédric,

Grabbed todays Master builds Windows TB 6 -- 97edb75d08e35eb014037fa6a4f93eeb16e11271, and the 64-bit Linux TB 8 -- 9b612f568a5c88f1a65654ad2bdd3df7211a9f3a so everything thus far.

Poked at them a bit -- some initial feed back for you, but to be honest I hoped Joanie might start going through it with Accerciser and ORCA on GNOME because I am still trying to figure the tools out. For now I'm doing better with JAB and JavaFerret.

Anyhow, first thing I notice is that the Template Manager opens as a Dialog role rather than a Frame role. I think this causes some issues--<alt>F4 or <Esc> or even mouse click on X are only way to close the manager other than making a template selection.  Until then, the Template manager stays open with no F6, or other key stroke to cycle directly back into the open soffice.bin frame.

I could do a random mouse click on the desktop to break out, or could cycle through by <alt><Tab> to get back to the top level soffice.bin frame, but it seems like there should be tighter linkage and F6 response-- not sure but I think assigning a frame role helps with that. The "Styles and Formatting" frame seems to have to right behavior.

Noticed a probably undesired behavior, that if you close the top-level soffice.bin frame the Template Manager dialog remains open, and then kicks off a session recovery when soffice.bin is relaunched.

Notice also that on launch, the Template Manger opens on the Document tab, but that the New Folder - push button role has focus and shows a un-named Parent to have a role of "tool bar".  But can only <Tab> from this location.
 
Using <Tab> to cycle through -> Search, which also has "tool bar" parent -> and then Thumbnail View  where the parent changes to "panel", and two additional objects with "push button" roles--Import & Delete--are added. And <LEFT> & <RIGHT> moves between them.

And with next <Tab> moves up to "Documents" again. But now Documents is a "page tab" and parent role is again unnamed but is assigned a "page tab list" role. 
But the <LEFT> and <RIGHT> move between tabs. 

Of the four "page tab" objects-- Documents, Spreadsheets, Presentations, and Drawings --the Documents tab shows it is focusable, but it does not assert focus. Don't think that is right.

So, lots of progress with keyboard accessibility! But I think the roles and parent/descendent structure may still need some tweaking--I'm just not exactly sure of the specifics to make it consistent. Missing the F6 and linkage back to the top-level soffice.bin frame probably needs some work, and then there is all the naming and labeling and assignment of key bindings for accelerators.

Sorry I can't be more direct help.
Comment 15 Cor Nouws 2013-03-24 15:04:59 UTC
(In reply to comment #14)
 
> Noticed a probably undesired behavior, that if you close the top-level
> soffice.bin frame the Template Manager dialog remains open, and then kicks
> off a session recovery when soffice.bin is relaunched.

On Windows I noticed this several times. 
On Linux, it seems less likely to happen.
Comment 16 Commit Notification 2013-03-25 17:26:20 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cc599e914e7ade9f10da460fc1c77ea07454d7ff

fdo#61390: allow arrow keys to show hidden thumbnail items



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2013-03-26 08:47:25 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=369cb8e216f9287234d601f4b28e0332a2ec29a5&h=libreoffice-4-0

fdo#61390: allow arrow keys to show hidden thumbnail items


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2013-04-06 01:59:51 UTC
Rafael Dominguez committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9993d25441e8b4d19b8dc8e818cd311114e74e49

fdo#61390 - Thumbnail navigation by shift-click and shift-keyboard.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2013-04-08 07:47:18 UTC
Rafael Dominguez committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b51875f39c86bd8082c983773756630b53df88af&h=libreoffice-4-0

fdo#61390 - Thumbnail navigation by shift-click and shift-keyboard.


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Rainer Bielefeld Retired 2013-04-16 15:31:02 UTC
Something went wrong here, this one has nothing to do with Bug 63585
Comment 21 pierre-yves samyn 2013-04-21 07:37:37 UTC
Hello

WORKSFORME with Windows 7 64bits &
Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)

Thank you
Regards
Pierre-Yves
Comment 22 Cor Nouws 2013-05-10 09:35:33 UTC
Many improvements . thanks!

What I can't find out: move from one category / folder, up one level, and thus being able to select another folder.
Is this on the radar already?
Comment 23 Cor Nouws 2013-10-20 19:25:55 UTC
(In reply to comment #22)

> What I can't find out: move from one category / folder, up one level, and
> thus being able to select another folder.
> Is this on the radar already?

created bug 70691 for that
Comment 24 Cor Nouws 2013-10-20 20:24:23 UTC
no idea why 64370 should be related to this one ..
Comment 25 V Stuart Foote 2014-01-04 18:18:05 UTC
Issues of original post and discussion have all been resolved.

Setting resolved fixed.
Comment 26 pierre-yves samyn 2014-05-11 04:54:30 UTC
Hello

I reopen the Issue, not completely solved: we forgot "File>  Templates> Save as template"

(keyboard navigation available for "File> New> Templates" and "File> Templates> Manage")

Workaround: 
1. File> Save as> OTT (odf template)
2. File> Templates> Manage> Import

Platform: windows 7/64 & Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

Regards
Pierre-Yves
Comment 27 V Stuart Foote 2014-05-11 07:23:33 UTC
Believe in genearl this issue has been resolved fixed on Master via .UI implementations.

working with
Version: 4.3.0.0.alpha1+
Build ID: 081a0854635f4bc9f6f743ef4e2675c208405f74
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-06_23:32:18

the F_ile -> T_emplates -> S_ave as template accelerators are fully implemented. And keyboard navigation into the templates is now correctly implemented as UI.

Also, for issue of keyboard navigation issue see bug 73766, where the change UI change has not been (and will not be?) back ported to 4.2.5, so done with changed sequences in templatedlg

So with
Version: 4.2.5.0.0+
Build ID: 1b9f4a686c5f397db3bd996acf53e0ad2b5d9ded
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-05-10_08:15:00

the File -> Template -> Save as template accelerators work, but the Template Manager dialog can not be navigated via keyboard to complete the save.

Lets leave this resolved fixed for the general issue, and either reopen bug 73766 or file as new bug against File -> Template -> Save as template specifically against 4.2.x

@Andrzej, thoughts on a simpler non-.UI implementation for this as well? Perhaps accelerator assignment to toggle IsSaveMode