Bug 61422 - UI: Integrate basic playback controls for audio/video when doing a slide show
Summary: UI: Integrate basic playback controls for audio/video when doing a slide show
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 90467 107349 (view as bug list)
Depends on:
Blocks: Media-Playback
  Show dependency treegraph
 
Reported: 2013-02-25 03:04 UTC by Bastián Díaz
Modified: 2019-08-18 12:31 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Mockup of playback controls in LO (default player in firefox) (320.42 KB, image/png)
2013-02-25 03:04 UTC, Bastián Díaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2013-02-25 03:04:18 UTC
Created attachment 75470 [details]
Mockup of playback controls in LO (default player in firefox)

The idea to embed or link to a video or audio on a slide, is that it can be viewed dynamically within the slideshow.

Tested on:
Fedora 18 32 bit LO 3.6.5.2 and LO 4.0.1.0
Windows 7 pro; LO 4.0.0.3

Description of the problem:
now when you embed or link a video in LibreOffice Impress and starts the slide show, the video starts automatically and to perform the click stops and goes to the next slide.
This has many drawbacks and summarized that not control video playback:
→ Just the video starts, if you do a little introduction this should be done with a great title in a previous slide.
→ There is no way to pause the video (in long videos are delimited topics that can be discussed with the audience)
→ Can not forward / rewind the video. Again in long videos by "X" reasons parties must go back to see them again (or advance). (now you have to cross your fingers and hope everything turns out well)

how reproducible
1. Create a presentation with LibreOffice Impress
2. Embed or link to a video on one of your slides
3. Start the slide show and advance slides up to the video

Actual Results:
The video starts playing automatically (and full volume). By clicking on the video stops and goes to the next slide.

Expected results:
Controlling video playback via a playback control (play / pause, progress bar, volume and full screen)

Additional Information:
I think the grace of a presentation is that it can be dynamic in itself. Currently in my classes I use external player or web pages with videos (like youtube) which leads me to close the slide and open the player with the video (look if it hides an elf).

The ides of full screen button I add it because it would be very useful, the video could be embedded in an area of ​​the slide (like a picture) and then could be expanded and played in full screen.

* I read that mentioned a way to play / pause the video through an animation effect. Honestly I could not find the option and find it a very unintuitive.

thanks
Comment 1 Bastián Díaz 2013-02-25 03:06:24 UTC
Bug related:

https://bugs.freedesktop.org/show_bug.cgi?id=46625
Comment 2 Thorsten Behrens (CIB) 2013-02-25 10:34:38 UTC
(In reply to comment #0)
> Created attachment 75470 [details]
> Mockup of playback controls in LO (default player in firefox)
> 
Hi Bastian, again, this is great input - would you also propose this to the UX discussion list?
Comment 3 A (Andy) 2013-03-23 21:24:04 UTC
I would agree, that this would be a good enhancement (I have therefore marked it as enhancement).
Comment 4 Richard Neill 2013-04-09 16:59:18 UTC
This is still relevant for 4.0.2.2

I agree that a nice, GUI would be really helpful here.

(especially when presenting on an external monitor, so there is some space for playback controls on the laptop's screen).

But as a short-term workaround, could we perhaps just have the basic:
  play, pause, stop, play-again-from-start
options in the right-click menu?

Thanks.
Comment 5 raal 2015-04-28 19:07:16 UTC
*** Bug 90467 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2017-04-28 16:28:06 UTC
*** Bug 107349 has been marked as a duplicate of this bug. ***
Comment 7 pieter kristensen 2017-09-15 12:58:33 UTC
+1 here. This would be a great enhancement! I read that Impress would have flicker free 3d slide transitions with LO 6.0. When there would be (basic) playback control for media in the presenter console Impress would be a real first class citizen.
Comment 8 Saren Tasciyan 2019-04-11 22:26:15 UTC
I am surprised that this got so little attention. In life sciences, this is necessary to discuss part of a movie.
MS Office implements this very nicely. When user moves mouse over the video, a video playback control field appears at the bottom edge of the video (partially covering the video bottom edge). There, user can play/pause and navigate the video. After leaving from that area, control bar fades away quickly to display whole video unmasked.
Comment 9 mgundogdu 2019-04-16 13:13:21 UTC
(In reply to Saren Tasciyan from comment #8)
> I am surprised that this got so little attention. In life sciences, this is
> necessary to discuss part of a movie.
> MS Office implements this very nicely. When user moves mouse over the video,
> a video playback control field appears at the bottom edge of the video
> (partially covering the video bottom edge). There, user can play/pause and
> navigate the video. After leaving from that area, control bar fades away
> quickly to display whole video unmasked.

This bug continues from 2011. It is really annoying. I depend on videos for my slide shows to then LO Impress useless for me. I'm linux user and I have to use WPS-Office for my presentation works, because there is no way to use videos on my presentation via Impres:(
This bug has to be handle...