Bug 61561 - EDITING: senseless limitation for Placement values in duplicate function (Shft+F3)
Summary: EDITING: senseless limitation for Placement values in duplicate function (Shf...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Laurent BP
URL:
Whiteboard: BSA target:6.0.0
Keywords: needsDevEval
: 56010 74076 (view as bug list)
Depends on:
Blocks: Shapes-Duplicate
  Show dependency treegraph
 
Reported: 2013-02-27 16:20 UTC by bjoern
Modified: 2018-01-16 23:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bjoern 2013-02-27 16:20:57 UTC
Problem description: In a drawing with e.g. scale 1:400 and unit meter, the "Duplizieren" (duplicate?) function does not accept any x or y arguments ("Verschiebung X-Achse" / "Verschiebung Y-Achse") larger than 1,00 m - although the page size (A4) is equivalent to 84 m x 118,80 m

Steps to reproduce:
1. open empty drawing
2. set scale to 1:400 and unit to Meter
3. sometimes you need to repeat step 2 - but on the second try the scale and unit change always work out (this is a bug I know from several OpenOffice versions, too)
4. create a rectangle e.g. 1m x2m
5. evoke the duplicate function (Shift+F3) and enter e.g. 1,5m in the x- or y-shift field 

Current behavior:
as soon as one goes on to a different input field, the input is truncated to 1,00 m

Expected behavior:
The function should accept input as least as large as the paper size (taking into account the actual scale)

              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-03-20 17:03:02 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor - doesn't prevent high quality work, just requires a workaround (ie. manually setting size)
Low (default, seems appropriate)

It seems like the scaling is causing the issue - if you skip that step there are no artificial barriers to size.


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 robert 2014-04-05 19:11:04 UTC
*** Bug 74076 has been marked as a duplicate of this bug. ***
Comment 3 robert 2014-04-05 19:12:24 UTC
Could reproduce the bug with LO 3.3.0beta1. So I have set the Version to "Inherited FROM OOo".
Comment 4 robert 2014-04-05 19:14:52 UTC
*** Bug 56010 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2015-06-08 14:42:21 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2016-09-20 10:01:26 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2016-12-05 20:19:56 UTC
Still the same in master 5.4.

@jani: possible easy hack?
Comment 8 Laurent BP 2017-04-19 20:21:56 UTC
Duplicate dialog is located here:
http://opengrok.libreoffice.org/xref/core/sd/uiconfig/sdraw/ui/copydlg.ui

Min/Max values of x, y width and height variations are arbitrary limited to -/+120. See:
http://opengrok.libreoffice.org/xref/core/sd/uiconfig/sdraw/ui/copydlg.ui#18

Min/Max values should be recalculated at run time like in TrendLine dialog. See:
http://opengrok.libreoffice.org/xref/core/chart2/source/controller/dialogs/res_Trendline.cxx#323
Comment 9 Commit Notification 2017-08-13 11:48:51 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b133fdb67cc56fba46ec355283144e611e8bf83

tdf#61561 Increase limitation placement and enlargement

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.