Bug 62293 - FILEOPEN: Table from RTF going outside the page - too wide (OK if resaved in MSO as RTF or DOC/X)
Summary: FILEOPEN: Table from RTF going outside the page - too wide (OK if resaved in ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
Whiteboard: BSA
Keywords: filter:rtf
: 67568 (view as bug list)
Depends on:
Blocks: RTF-Tables
  Show dependency treegraph
Reported: 2013-03-13 13:11 UTC by mloc
Modified: 2023-04-25 15:52 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

RTF file with problematic table (7.73 KB, text/rtf)
2013-03-13 13:11 UTC, mloc
Expected behaviour: PDF file generated from MS Word 2003 (3.52 KB, application/pdf)
2013-03-13 13:12 UTC, mloc
Unexpected behaviour: how it is displayed in LibO 3.6.4 (PDF) (27.83 KB, application/pdf)
2013-03-13 13:14 UTC, mloc
RTF resaved in MSO (45.79 KB, application/msword)
2019-12-09 13:33 UTC, Timur

Note You need to log in before you can comment on or make changes to this bug.
Description mloc 2013-03-13 13:11:26 UTC
Created attachment 76468 [details]
RTF file with problematic table

Problem description: 
Some tables are stretched and go outside the document. Last column not shown, remaining values that should be found inside the cells of the next row are dumped and concatenated under the table. I have no idea how the document has been generated.

Table never worked in any version of LibreOffice I have tried these last years. The table used to crash LibreOffice until 3.4 I think (not tested, not sure if relevant anyway). Now it is just displayed inappropriately, at least since version 3.6.4

Steps to reproduce:
1. Open attached file in MS Word 2003
2. Notice how the table is 4 columns and 3 rows long
3. Open attached file in LibO 3.6.4 or LibO 4.0.1
4. Notice how the table only shows 3 columns, 2 rows and gets outside the right of the page.
Operating System: Windows 7
Version: release
Comment 1 mloc 2013-03-13 13:12:46 UTC
Created attachment 76469 [details]
Expected behaviour: PDF file generated from MS Word 2003
Comment 2 mloc 2013-03-13 13:14:45 UTC
Created attachment 76470 [details]
Unexpected behaviour: how it is displayed in LibO 3.6.4 (PDF)
Comment 3 Julien Nabet 2013-04-06 16:49:33 UTC Comment hidden (obsolete)
Comment 4 mloc 2013-04-08 11:03:39 UTC Comment hidden (obsolete)
Comment 5 Julien Nabet 2013-04-08 21:38:48 UTC
mloc: thank you for your feedback.

Indeed, I've been able to test on pc Debian x86-64 with master sources updated today, I can reproduce the problem.

I noticed a lot of these logs (about 30?):
warn:writerfilter:31532:1:writerfilter/source/rtftok/rtfdocumentimpl.cxx:143: trying to set property when no type is define

Miklós: one for you?
Comment 6 mloc 2013-10-09 07:51:20 UTC Comment hidden (obsolete)
Comment 7 Alexandr 2014-07-17 19:16:00 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2015-09-04 02:49:45 UTC Comment hidden (obsolete)
Comment 9 Alexandr 2015-09-19 17:48:09 UTC
Reproducible with LibreOffice 5.0.1 on Debian x86_64.
Comment 10 Robinson Tryon (qubit) 2015-12-14 11:26:02 UTC Comment hidden (obsolete)
Comment 11 Cor Nouws 2016-08-29 12:43:50 UTC
*** Bug 67568 has been marked as a duplicate of this bug. ***
Comment 12 QA Administrators 2017-09-01 11:20:35 UTC Comment hidden (obsolete)
Comment 13 mloc 2017-09-01 11:45:45 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2018-10-06 02:49:34 UTC Comment hidden (obsolete)
Comment 15 mloc 2018-10-08 08:06:31 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2019-10-09 02:29:19 UTC Comment hidden (obsolete)
Comment 17 mloc 2019-10-09 07:45:35 UTC
Bug is still present.

Version: (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
Threads CPU : 6; OS : Windows 10.0; UI Render : GL; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded
Comment 18 Timur 2019-12-09 13:33:08 UTC
Created attachment 156433 [details]
RTF resaved in MSO

Repro in master LO 6.5+ with attached RTF. 
But no repro if that RTF resaved in MSO as RTF (as attached) or DOC or DOCX.
This is still a bug, but I set low priority.
Comment 19 QA Administrators 2021-12-09 04:30:39 UTC Comment hidden (obsolete)
Comment 20 Gabor Kelemen (allotropia) 2023-04-25 15:52:55 UTC
Last row still falls out of the table in

Version: (X86_64) / LibreOffice Community
Build ID: 006b35d50024b1932d84380b5d2fec1f7066bccd
CPU threads: 14; OS: Windows 10.0 Build 19045; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded