Bug 99440 - FILEOPEN: docx table (created with Pandoc) stretches way beyond screen - property: IsWidthRelative
Summary: FILEOPEN: docx table (created with Pandoc) stretches way beyond screen - prop...
Status: RESOLVED DUPLICATE of bug 109524
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
: 101767 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2016-04-21 18:57 UTC by Brian Lavender
Modified: 2021-07-22 07:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample documents showing error (20.87 KB, application/x-zip-compressed)
2016-04-21 18:57 UTC, Brian Lavender
Details
document.xml extracted from docx generated by pandoc (17.25 KB, application/xml)
2016-04-21 20:54 UTC, Brian Lavender
Details
document.xml extracted from docx opened in MS word and then saved again. (22.37 KB, application/xml)
2016-04-21 20:55 UTC, Brian Lavender
Details
The example file in Word and Writer (182.57 KB, image/png)
2021-07-22 07:30 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Lavender 2016-04-21 18:57:07 UTC
Created attachment 124554 [details]
Sample documents showing error

If I use pandoc to generate a docx file that contains tables and I open it in Writer, the tables extend way off the screen. MS Office opens it correctly. If I tell pandoc to generate an ODT, it appears better in Writer.
Comment 1 Cor Nouws 2016-04-21 19:56:45 UTC Comment hidden (obsolete)
Comment 2 Cor Nouws 2016-04-21 19:58:02 UTC
NB http://pandoc.org/
Comment 3 Brian Lavender 2016-04-21 20:54:25 UTC
Created attachment 124557 [details]
document.xml extracted from docx generated by pandoc
Comment 4 Brian Lavender 2016-04-21 20:55:41 UTC
Created attachment 124559 [details]
document.xml extracted from docx opened in MS word and then saved again.
Comment 5 Brian Lavender 2016-04-21 20:58:33 UTC
(In reply to Cor Nouws from comment #1)
> Thanks for filing this, Brian.
> I confirm the problem in a daily build from 2016-04-20 and in LibreOffice
> 3.3.4. Both on Linux.
> 
> Could it he that pandoc creates some 'special' docx?
> 
> Cheers,
> Cor

If I open the default pandoc generated docx file in MS Word and then I save it again, it changes the attributes for the table. I am willing to guess that with the attributes that pandoc writes to the file, that it could render correctly in LO, but some attribute is not set to a default. Anyway, I attached the two extracted document.xml files for compare and contrast. I am not an expert on docx format.
Comment 6 Cor Nouws 2016-04-22 20:36:11 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2016-04-23 07:25:56 UTC
(In reply to Cor Nouws from comment #6)

> Neither am I.

Obviously I did a diff, but that resulted in nothing clearly useful.
And there are many properties that I should start to study first ;)
Comment 8 Telesto 2016-11-28 17:26:49 UTC
Confirming with:
Version: 5.4.0.0.alpha0+ (x64)
Build ID: 7aa2b5a041df8e71a435cccbc79ee13799ec9138
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-11-24_11:40:27
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 Justin L 2016-12-23 16:29:34 UTC
This exception is probably related to the table problem: warn:sw.uno:6498:1:sw/source/core/unocore/unotext.cxx:2289: Exception when setting property: IsWidthRelative. Message: relative width cannot be switched on with this property
Comment 10 QA Administrators 2017-12-24 03:28:57 UTC Comment hidden (obsolete)
Comment 11 edwinvanl 2019-10-08 13:46:01 UTC
I can confirm that this is still an issue in version 6.3.1
Comment 12 Timur 2019-12-09 14:15:07 UTC
*** Bug 101767 has been marked as a duplicate of this bug. ***
Comment 13 Timur 2019-12-09 14:17:09 UTC
Repro in LO 6.5+. 
But, if DOCS resaved in MSO (any option: DOC, DOCX, compatible DOCX), it opens fine.
Similar to duplicated bug 101767 with attachment 127055 [details] which is resaved in MSO as attachment 156435 [details] .
Comment 14 NISZ LibreOffice Team 2021-07-22 07:30:56 UTC
Created attachment 173768 [details]
The example file in Word and Writer

How it looks in Word 19 and a fresh nightly:

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0cda081c9aa3b3dcb363f97bac60c845ce9a13e0
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Preferred width is turned off and "Automatically resize to fit contents" is enabled. This is basically bug 109524, but the problem is better explained there.
Comment 15 NISZ LibreOffice Team 2021-07-22 07:31:14 UTC

*** This bug has been marked as a duplicate of bug 109524 ***