Bug 101767 - LO does not display table width correctly from generated DOCX (OK if resaved in MSO as DOC/X)
Summary: LO does not display table width correctly from generated DOCX (OK if resaved ...
Status: RESOLVED DUPLICATE of bug 99440
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-28 15:37 UTC by Uwe Brauer
Modified: 2019-12-09 14:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
docx with a problematic table (9.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-08-28 15:37 UTC, Uwe Brauer
Details
docx resaved in MSO (14.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-12-09 13:53 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Brauer 2016-08-28 15:37:52 UTC
Created attachment 127055 [details]
docx with a problematic table

Hello 

the docx file attached contains a table which is displayed correctly in MS Word, but LO only shows one column, with a very large width.

Since I can only attach one file, I attach the docx, not the screenshot
Comment 1 V Stuart Foote 2016-08-28 19:35:22 UTC
Confirming.

On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.4 (x64)
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

The total table column width opens at 46.23", but able to bring it down to reasonable size using Table Properties dialog.
Comment 2 Cor Nouws 2016-08-29 12:45:12 UTC
Thanks for reporting Uwe - I think we can safely mark this a duplicate of bug 41468

*** This bug has been marked as a duplicate of bug 41468 ***
Comment 3 Timur 2019-12-09 13:53:01 UTC
Created attachment 156435 [details]
docx resaved in MSO

Repro in LO 6.5+. 
But, if DOCS resaved in MSO (any option: DOC, DOCX, compatible DOCX), it opens fine. Here is attached MSO saved DOCX (without compatibility).
Probably similar to bug 62293, although there is RTF.
I understand this is generated DOCX.
Comment 4 Timur 2019-12-09 14:03:25 UTC
I set this one as New because reporter explained that this file was written in emacs, using its org mode and then converted via pandoc https://pandoc.org/
to docx.
Although there are older bugs that may be similar or not.
attachment 100517 [details] from  bug 79722 behaves similarly, fileopen NOK but OK if resaved in MSO. Comparison in attachment 100561 [details] .
Comment 5 Timur 2019-12-09 14:15:07 UTC

*** This bug has been marked as a duplicate of bug 99440 ***