Bug Hunting Session
Bug 62670 - TABLE: Splitting a table options are mixed
Summary: TABLE: Splitting a table options are mixed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: BSA bibisected40 target:4.0.2 target:...
Keywords: needsDevEval
: 62598 62630 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-23 15:04 UTC by Gajdos Tamás
Modified: 2015-12-18 09:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A test file created for this purpose. (9.41 KB, application/vnd.oasis.opendocument.text)
2013-03-23 15:04 UTC, Gajdos Tamás
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gajdos Tamás 2013-03-23 15:04:07 UTC
Created attachment 76942 [details]
A test file created for this purpose.

Problem description: When splitting a table, and selecting no header, the header is created. 
2nd or 3rd option does the job.

Steps to reproduce:
1. Create a table in a Writer document
2. Split the table selecting the 4th option (No header)
3. The new table is created with the previous header.

Current behavior:
The header is created even if I select not to. (4th option)
Expected behavior:
There should be no header.
              
Operating System: Ubuntu
Version: 4.0.1.2 release
Comment 1 Joel Madero 2013-03-25 16:22:08 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 4.1.0.0.alpha0+ (Build ID: 9a46e5614f5a0e0bdce3c497f81ca529da8fb5c)
Date:   Mon Mar 18 18:59:09 2013 +0100 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - slows down work, but easy workaround to delete row
Low - easy workaround plus not an incredibly common task to do

Keywords - regression (works on 3.6.5.2)

Whiteboard Status - trying to bibisect now

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Joel Madero 2013-03-25 16:39:26 UTC
Joren - you interested in this regression? Seems quite easy to fix


18ab426f67674e3ca169118f1f7a3527613374a4 is the first bad commit
commit 18ab426f67674e3ca169118f1f7a3527613374a4
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 15:58:33 2012 +0000

    source-hash-4df639baacd871cb2793e75dd9721ad2ae715e20
    
    commit 4df639baacd871cb2793e75dd9721ad2ae715e20
    Author:     Norbert Thiebaud <nthiebaud@gmail.com>
    AuthorDate: Sat Sep 29 02:34:58 2012 -0500
    Commit:     Norbert Thiebaud <nthiebaud@gmail.com>
    CommitDate: Sat Sep 29 02:43:29 2012 -0500
    
        add apache_commons to tail_build
    
        Change-Id: I0365a5170011ad44b9a0ab8f1129a756884694d5

:100644 100644 66afa24b4b34cc1d198b4a9564ede557456555c3 0a27364dbfe85236f5a07a9baeb2ce5dc923140f M	autogen.log
:100644 100644 592002353c9c447688ae5ed55b4ec616e85568a3 59e71ae19992a0d27f4cd5a0660f4d0ae6a6baa9 M	ccache.log
:100644 100644 0b4eee5b69c2cc366273a7e684ebea96d6a49004 5cf4528dc90d7fb24081eba730189499b41b3364 M	commitmsg
:100644 100644 1424b8601b3a84d22208d2ad9fa54bd6aa940713 ae40a46c4d748e32f497c8be5421282bba577ac9 M	dev-install.log
:100644 100644 99903952fe667006084e3f44517e56af706a6fcf 31ff34b5efe337e22e4987f46b328e59bc699817 M	make.log
:040000 040000 1b572f2dde3a8e76bcad94e0fba6e0632bfcab87 b9e6f554ff60c2a6fdbdc177bcc35d9d7160a9b5 M	opt



# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# bad: [114fd3b76bcba890e6d702d00cef910f1493c262] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect bad 114fd3b76bcba890e6d702d00cef910f1493c262
# good: [6af64581913aa7ce3fcf0890fe671830d416a6ea] source-hash-06a8ca9339f02fccf6961c0de77c49673823b35f
git bisect good 6af64581913aa7ce3fcf0890fe671830d416a6ea
# bad: [7e20e241c1d8819d8d5edb7894baeddde33f9d3a] source-hash-2c270eeff422ef93100376ce0717a131d4f3cc2f
git bisect bad 7e20e241c1d8819d8d5edb7894baeddde33f9d3a
# bad: [18ab426f67674e3ca169118f1f7a3527613374a4] source-hash-4df639baacd871cb2793e75dd9721ad2ae715e20
git bisect bad 18ab426f67674e3ca169118f1f7a3527613374a4
# good: [8004efc7f77e76e1dc66eeb0fa7f2b9b2cf9cc05] source-hash-9351d0e4181924c3f72be24081fc7af027aa41f7
git bisect good 8004efc7f77e76e1dc66eeb0fa7f2b9b2cf9cc05
# good: [5132488fc8156d7eec31097f0e8036dbb6612b10] source-hash-fba5febdf60b37be69d2ffc66445d3e324826346
git bisect good 5132488fc8156d7eec31097f0e8036dbb6612b10
Comment 3 Joel Madero 2013-03-25 17:19:38 UTC
*** Bug 62630 has been marked as a duplicate of this bug. ***
Comment 4 Jorendc 2013-03-25 20:31:34 UTC
(In reply to comment #2)
> Joren - you interested in this regression? Seems quite easy to fix

Thanks Joel for pinging me on this one. I think I see the problem.

Related commits: http://cgit.freedesktop.org/libreoffice/core/commit/?id=e69c736c2769719027c3d26c3a8fd04be3d06b5d and http://cgit.freedesktop.org/libreoffice/core/commit/?id=90ca3b779e6086d2dc8c26cd7acbb2b30171aa87
Comment 5 Jorendc 2013-03-25 21:15:35 UTC
Fixed. Currently under review: https://gerrit.libreoffice.org/#/c/3041/
Comment 6 Commit Notification 2013-03-26 09:33:15 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=64a3b58a9ace11c6a01708e8de14712e27e02043&h=libreoffice-4-0

fix fdo#62670 - TABLE: Splitting a table options are mixed


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-03-26 09:33:34 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b23214f768e94f3fbdb0317b5fd458c55a9118db

fix fdo#62670 - TABLE: Splitting a table options are mixed



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-03-26 09:46:17 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa85ff19b4acaf98adfaa8787afce5698e7b085e&h=libreoffice-4-0-2

fix fdo#62670 - TABLE: Splitting a table options are mixed


It will be available already in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Jorendc 2013-04-17 11:00:04 UTC
*** Bug 62598 has been marked as a duplicate of this bug. ***
Comment 10 Robinson Tryon (qubit) 2015-12-18 09:48:46 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]