Bug 63766 - EDITING: Merging of merged cell and unmerged cell fails with error message
Summary: EDITING: Merging of merged cell and unmerged cell fails with error message
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: gokul
URL:
Whiteboard: target:6.1.0
Keywords:
: 71118 112184 (view as bug list)
Depends on:
Blocks: Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2013-04-21 07:13 UTC by gokul
Modified: 2019-06-09 11:30 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
merging of cells(merged and individual cells) in calc (107.75 KB, image/png)
2013-04-21 07:13 UTC, gokul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gokul 2013-04-21 07:13:36 UTC
Created attachment 78288 [details]
merging of cells(merged and individual cells) in calc

When we try to merge cells in which atleast one of cell is merged throw's 
error message( "Cell merge not possible if cells are already merged" ).
IMO this is not a correct behaviour. Meging of cells including merged cells shouls be possible.

trying to merge an already merged cell is anyway not possible as we 
disable merge option if it is merged.

this is not the beviour in writer. 
Is their any reason for such behaviour in calc.

Steps to Reproduce
1) Merge few cells in calc.
2) select the merged cell and other cells and perform merge operation.

Currect behaviour
  Throw's error message

Expected behaviour
  Merge operation should be performed
Comment 1 Rainer Bielefeld Retired 2013-04-21 08:16:42 UTC
Still  [Reproducible] with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 0b4315077a6827798e1d2bdae73298365ba9a01) TinderBox: Win-x86@6, Branch:master, Pull Time:  2013-04-18_04:00:51" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile: Message "Cell merge not possible if cells already merged"

Old OOo versions simply unmerged merged cells if you tried to merge additional cells to already merged cells (we still see this in LibO when we use "Merge and Center Contents" 

Reported problem already visible in LibO 3.3.3, I did not check where exactly appeared, I beleve with addition of feature 'merge without center contents'

Currently this is a known limitation (see help) and so more or less intended.

But we should overcome this limitation, Gnumeric and Softmaker FreeOffice have this ability (I only tested with empty cells).

@Spreadsheet Team
Please add Witeboard tag “bibisectrequest” if you think that a bibisect result can ease your work.
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 2 gokul 2013-04-21 12:43:23 UTC
I have proposed a patch for this bug. 

https://gerrit.libreoffice.org/#/c/3524/

P.S  This fixes the problem, able to reproduce desired behviour.
someone has to verify the fix.
Comment 3 ign_christian 2013-11-01 15:00:34 UTC
*** Bug 71118 has been marked as a duplicate of this bug. ***
Comment 4 ign_christian 2013-11-01 15:02:09 UTC
Perhaps gokul's patch has been reviewed?
Comment 5 Zeki Bildirici 2014-01-08 14:24:41 UTC
Seems fixed in current release. But not sure which patch is merged to which release. Anyway i'm closing this bug.

Cheers,
Zeki
Comment 6 Commit Notification 2018-02-25 14:59:11 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=218bd65271cf9d94e6a47b61c83883eea1885317

uitest Calc merged cells- tdf#51368 tdf#105412 tdf#37901 tdf#51368 tdf#63766

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Aron Budea 2018-11-23 20:20:30 UTC
Not sure why this was closed, because Calc still throws the same error message. Tested using 6.2beta1 & 4.2.0.4 / Ubuntu 18.04.
Comment 8 bob53181 2019-06-09 11:25:56 UTC
I get this error message when merging on 6.2.4.2.0+.
Comment 9 bob53181 2019-06-09 11:30:52 UTC
*** Bug 112184 has been marked as a duplicate of this bug. ***