Bug 63905 - FORMATTING: Page format in draw is not sent to the printer
Summary: FORMATTING: Page format in draw is not sent to the printer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Clément Lassieur
QA Contact:
URL:
Whiteboard: BSA target:4.4.0 target:4.3.2 target:...
Keywords:
: 73939 (view as bug list)
Depends on:
Blocks: 91362
  Show dependency treegraph
 
Reported: 2013-04-25 07:49 UTC by whoever
Modified: 2017-11-10 13:56 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Japenese Postcard Page Formatting (8.66 KB, application/vnd.oasis.opendocument.graphics)
2013-05-01 03:40 UTC, Joel Madero
Details
With test file still A4 as page format (105.21 KB, image/png)
2013-05-01 06:00 UTC, whoever
Details

Note You need to log in before you can comment on or make changes to this bug.
Description whoever 2013-04-25 07:49:35 UTC
Problem description: 
Defined page formats (Format > Page... > Page > Format) are not sent to the printer - and thus, the printer is printing just the standard page size. This bug ist NOT existing in Writer and Excel - there works everything fine. This bug is existing for a long time, when I remember correctly.

Steps to reproduce:
1. Create a new draw file
2. Change the paper format (Format > Page... > Page > Format - and choose for example A3 instead of A4). 
3. Write in each corner some letters, just to see from where to where the content is printed
4. Print the page

Current behavior:
The printer is still printing an A4 - except the standard page format is changed to A3 in the system preferences of Mac OS X. 

Expected behavior:
As known from writer or calc, I would expect that the correct page format is sent to the printer, and an A3 document would be printed.
              
Operating System: Mac OS X
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-05-01 03:39:44 UTC
CANNOT confirm on Bodhi Linux using Master built from yesterday.

Just for help to OSX QA member I have attached a sample document. It is much easier to select a much different size to see that it is working (here I selected Japanese Postcard) and I put "A" in each corner, print it and you will see it's the correct formatting.

Joren - mind printing the document and confirming?
Comment 2 Joel Madero 2013-05-01 03:40:18 UTC
Created attachment 78679 [details]
Japenese Postcard Page Formatting
Comment 3 whoever 2013-05-01 05:59:21 UTC
When I print your file, it is still printed on an A4-page (see the attached screenshot), but just a part of the paper is used. Is this different on your system? I will test the bug on the same system but with Ubuntu and Windows.
Comment 4 whoever 2013-05-01 06:00:02 UTC
Created attachment 78688 [details]
With test file still A4 as page format
Comment 5 Joel Madero 2013-05-01 06:13:55 UTC
ah you mean the actual paper feeder from the printer? I think I misunderstood the problem
Comment 6 whoever 2013-05-01 06:31:12 UTC
Yes - exactly. This is working in Writer and Calc, but not in Draw (and probably presentation?)
Comment 7 thackert 2013-06-21 16:42:28 UTC
Hello whoever, *,
I can confirm your issue with LO Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 under Debian Testing AMD64, but as well with LO Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2) (both with installed Germanophone lang- as well as helppack) ... :(
So I set the status to "New".
HTH
Thomas.
Comment 8 whoever 2013-08-23 07:39:04 UTC
The bug is also existing in Impress. Thus: Is the importance probably higher?
Comment 9 m.a.riosv 2014-01-22 21:21:49 UTC
*** Bug 73939 has been marked as a duplicate of this bug. ***
Comment 10 Stefano Fraccaro 2014-05-21 13:49:32 UTC
I have the same problem on version 4.2.4.2 with Windows 7 Pro SP1
Comment 11 Commit Notification 2014-08-19 08:35:26 UTC
Eilidh McAdam committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7b31e45ec7106d2cfbdbb7915d97667ba710f81c

Make Draw use paper size when printing - fdo#63905



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-08-20 07:16:36 UTC
Eilidh McAdam committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7eed1e17cfb101210db8aa839171f00d0730582&h=libreoffice-4-3

Make Draw use paper size when printing - fdo#63905


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-08-22 11:15:02 UTC
Eilidh McAdam committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4bd844d6842becf495834bda997d2731bd49316d&h=libreoffice-4-2

Make Draw use paper size when printing - fdo#63905


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Kevin Suo 2014-11-04 08:09:55 UTC
Hi, the fix to this bug caused a new regression, it makes the feature "Distribute on multiple sheets of paper" broken in draw. See bug 84051.
Comment 15 Mike §chinagl 2014-12-20 22:32:02 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 

Draw now uses the paper size specified in page formatting with printing.
Comment 16 tmacalp 2014-12-30 21:33:41 UTC
As mentioned in Comment #14, the fix for this bug makes it completely impossible to print distributed on multiple pages in Draw. (bug 84051)  It also appears to ruin "Fit to printable page," which now behaves exactly like "Original size."  As far as I can tell, there are no work-arounds.

Because this patch was ported to all of the branches(4.2.7, 4.3.2, and 4.4.0), it affects all recent versions.

The print dialog should use the previous behavior of actually using the printer preference's paper size/orientation instead of the page format setting in the following situations:

1. You have a custom page size in your page format
Right now, it seems to pick the paper size that is closest to the custom page.  For instance, if I'm creating a banner with a page format size is 34x11, the print interface will force me to use my printer's largest supported size, tabloid extra (18x12).  

2. You have checked "Distribute on multiple sheets," "Fit to printable page," or "Tile sheet of paper with repeated pages."
In each of these cases, you are trying to fit content to a specific paper size/orientation that you are setting in the printer preferences.  It obviously needs to honor these printer settings for these special cases.

3. Options->"Use only paper size from printer preferences" is checked
I've always hated the location of this checkbox.  If LibreOffice is going to simply ignore your basic printer preferences for page size and orientation in favor of the page format, it needs to be more clear.  Page size and orientation should be greyed out and the "Use only paper size from printer preferences" checkbox should be moved next to them.  Whatever the case, checking this option should, and currently does, cause these fields to actually be honored.
Comment 17 Clément Lassieur 2015-01-06 15:06:15 UTC
(In reply to tmacalp from comment #16)

I improved my patch (https://gerrit.libreoffice.org/#/c/13763/) so it now fixes “Fit to printable page”, “Distribute…”, and “Tile sheet…”.
Feedback is welcome.

Is there a difference between “Distribute on multiple sheets of paper” and “Tile sheet of paper with repeated pages”? I can’t find any.

> 1. You have a custom page size in your page format
> Right now, it seems to pick the paper size that is closest to the custom
> page.  For instance, if I'm creating a banner with a page format size is
> 34x11, the print interface will force me to use my printer's largest
> supported size, tabloid extra (18x12).

I think this is the expected behavior. And if you want to print the whole banner (if your printer’s largest supported size is too small), you can use “Distribute on multiple sheets of paper”.
Comment 18 tmacalp 2015-01-06 17:38:27 UTC
(In reply to Clément Lassieur from comment #17)
> (In reply to tmacalp from comment #16)
> 
> I improved my patch (https://gerrit.libreoffice.org/#/c/13763/) so it now
> fixes “Fit to printable page”, “Distribute…”, and “Tile sheet…”.
> Feedback is welcome.
> 
> Is there a difference between “Distribute on multiple sheets of paper” and
> “Tile sheet of paper with repeated pages”? I can’t find any.

Tile pages puts multiple small pages onto one large page, unscaled.  For instance, if you create a drawing with a page format of 4.25"x 5.5" (1/4th of a letter page) and print that on letter paper with tiling, it will put 4 non-scaled images on one sheet of letter paper.  Tiling worked in OpenOffice 3.2.1 and appears to work properly in LO 4.4.0.1 rc1, but only when I force it to use paper size from print preferences.  From your description above, it sounds like your commit should fix this issue.  

I don't think the description of "Tile sheet of paper with repeated pages" is very meaningful, but I can't come up with anything better.  It literally is just tiling the pages.

> > 1. You have a custom page size in your page format
> > Right now, it seems to pick the paper size that is closest to the custom
> > page.  For instance, if I'm creating a banner with a page format size is
> > 34x11, the print interface will force me to use my printer's largest
> > supported size, tabloid extra (18x12).
> 
> I think this is the expected behavior. And if you want to print the whole
> banner (if your printer’s largest supported size is too small), you can use
> “Distribute on multiple sheets of paper”.

I think I agree with you that this is the correct behavior.  The only reason I was passing a custom sized page format was to use "Distribute on multiple sheets of paper."  

Thank you for updating your patch!  I look forward to testing a nightly.

Sorry for plugging another bug, but I now only have one semi-related complaint about Draw's print dialog, bug 87981.  The printer preference page size is not recalculated after you click Fit to page, distribute on multiple sheets, or tile pages.  That bug was untestable while this bug was in effect.
Comment 19 Clément Lassieur 2015-01-07 11:14:35 UTC
(In reply to tmacalp from comment #16)

> The print dialog should use the previous behavior of actually using the
> printer preference's paper size/orientation instead of the page format
> setting in the following situations:

Changing the orientation could be helpful, for instance if one wants to distribute one A3 page on two A4 sheets, but “Distribute on multiple sheets of paper” doesn’t work well when the orientation is changed. That’s another bug.

My patch is going to force users to use the orientation defined in Page Format. It’s not expected (and I’m going to have a look at this) but “Distribute on multiple sheets of paper” doesn’t handle orientation changes anyway.

And clearly “Fit to printable page” should not allow orientation changes, should it? It’s only about size, I think.
Comment 20 Clément Lassieur 2015-01-07 14:07:32 UTC
(In reply to tmacalp from comment #18)

> > Is there a difference between “Distribute on multiple sheets of paper” and
> > “Tile sheet of paper with repeated pages”? I can’t find any.
> 
> Tile pages puts multiple small pages onto one large page, unscaled.  For
> instance, if you create a drawing with a page format of 4.25"x 5.5" (1/4th
> of a letter page) and print that on letter paper with tiling, it will put 4
> non-scaled images on one sheet of letter paper.  Tiling worked in OpenOffice
> 3.2.1 and appears to work properly in LO 4.4.0.1 rc1, but only when I force
> it to use paper size from print preferences.  From your description above,
> it sounds like your commit should fix this issue.  

What I meant is that regardless of whether you choose “Distribute on multiple sheets of paper” or “Tile sheet of paper with repeated pages”, the behavior is the same:
 - if the page format is smaller than the printer paper, they both behave like “Tile sheet of paper with repeated pages”,
 - if the page format is larger than the printer paper, they both behave like “Distribute on multiple sheets of paper”.
Comment 21 tmacalp 2015-01-07 16:24:58 UTC
(In reply to Clément Lassieur from comment #19)

> Changing the orientation could be helpful, for instance if one wants to
> distribute one A3 page on two A4 sheets, but “Distribute on multiple sheets
> of paper” doesn’t work well when the orientation is changed. That’s another
> bug.
> 
> My patch is going to force users to use the orientation defined in Page
> Format. It’s not expected (and I’m going to have a look at this) but
> “Distribute on multiple sheets of paper” doesn’t handle orientation changes
> anyway.

Agreed.  I would love the ability to change orientation with Distribute on multiple sheets, but that is another bug.

> And clearly “Fit to printable page” should not allow orientation changes,
> should it? It’s only about size, I think.

I actually would expect fit to printable page to allow/honor orientation changes.  For instance, I might want to print a banner (landscape) fit to a portrait letter size piece of paper to go in a binder.


(In reply to Clément Lassieur from comment #20)

> What I meant is that regardless of whether you choose “Distribute on
> multiple sheets of paper” or “Tile sheet of paper with repeated pages”, the
> behavior is the same:
>  - if the page format is smaller than the printer paper, they both behave
> like “Tile sheet of paper with repeated pages”,
>  - if the page format is larger than the printer paper, they both behave
> like “Distribute on multiple sheets of paper”.

Sorry, I didn't know the two options behaved exactly the same.  That actually makes a bit of sense, though.  In OpenOffice 3.2.1, there were only three options: "Default", "Fit to page", and "Tile pages".  If they both do the same thing behind the scenes, why are they separate options?
Comment 22 Clément Lassieur 2015-01-07 18:41:48 UTC
(In reply to tmacalp from comment #21)

> I actually would expect fit to printable page to allow/honor orientation
> changes.  For instance, I might want to print a banner (landscape) fit to a
> portrait letter size piece of paper to go in a binder.

I see. Did that ever work?

> Sorry, I didn't know the two options behaved exactly the same.  That
> actually makes a bit of sense, though.  In OpenOffice 3.2.1, there were only
> three options: "Default", "Fit to page", and "Tile pages".  If they both do
> the same thing behind the scenes, why are they separate options?

Maybe so that the user can find those two features more easily.
Comment 23 tmacalp 2015-01-12 00:41:16 UTC
(In reply to Clément Lassieur from comment #22)
> (In reply to tmacalp from comment #21)
> 
> > I actually would expect fit to printable page to allow/honor orientation
> > changes.  For instance, I might want to print a banner (landscape) fit to a
> > portrait letter size piece of paper to go in a binder.
> 
> I see. Did that ever work?

I just tested this under OpenOffice 3.2.1 and it did NOT honor custom rotation for either fit to page or distribute on multiple sheets.  It printed landscape both times, when I specified portrait.  That said, I still think orientation is worthy of honoring and that implementing it properly would be a worthy enhancement.  But honoring orientation seems like it'd be tricky to just enable.  It would probably require lots of testing to ensure it didn't muck with other printing workflows.  It'd probably be worthy of another enhancement request.

> > Sorry, I didn't know the two options behaved exactly the same.  That
> > actually makes a bit of sense, though.  In OpenOffice 3.2.1, there were only
> > three options: "Default", "Fit to page", and "Tile pages".  If they both do
> > the same thing behind the scenes, why are they separate options?
> 
> Maybe so that the user can find those two features more easily.

And sorry, things actually were a bit more complicated than I described above.  After a user chooses "Tile pages," in OO 3.2.1, they were presented with 3 more options when they actually try to print: "Fit page to print range", "Print on multiple pages", and "Trim".  So much for things being simpler back then.
Comment 24 Commit Notification 2015-03-31 20:21:10 UTC
Clément Lassieur committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3feb370bc82dedfd7dc281aecf8dd670176e52ff

tdf#63905: fix regression by using paper size set in printer properties

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Timur 2015-06-09 11:35:30 UTC Comment hidden (obsolete)
Comment 26 Timur 2017-01-12 08:05:37 UTC
Is Bug 68864 a duplicate? Sorry for not testing myself.