Bug 65724 - FILEOPEN: Hyperlinks are not imported from pptx files
Summary: FILEOPEN: Hyperlinks are not imported from pptx files
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.2.0
Keywords: filter:pptx
Depends on:
Blocks: PPTX-Hyperlink
  Show dependency treegraph
 
Reported: 2013-06-13 17:36 UTC by Zirneklītis
Modified: 2021-05-07 09:50 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
PPT file with hyperlinks (49.50 KB, application/vnd.ms-powerpoint)
2013-06-13 17:36 UTC, Zirneklītis
Details
PPTX file with hyperlinks (69.61 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-06-13 17:37 UTC, Zirneklītis
Details
PPT file with hyperlinks (49.50 KB, application/vnd.ms-powerpoint)
2013-06-13 17:38 UTC, Zirneklītis
Details
PPT with link (1.31 MB, application/x-ole-storage)
2015-05-13 23:16 UTC, Ofir
Details
obsolete file (deleted)
2019-04-10 08:38 UTC, Roger Wo
Details
obsolete file (deleted)
2019-04-10 08:40 UTC, Roger Wo
Details
slide_index.pptx (32.28 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-04-17 09:36 UTC, Roger Wo
Details
slide_index.ppt (85.50 KB, application/vnd.ms-powerpoint)
2019-04-17 09:36 UTC, Roger Wo
Details
Screenshot of the original document side by side in PP and Impress (135.43 KB, image/png)
2021-01-29 07:48 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zirneklītis 2013-06-13 17:36:02 UTC
Created attachment 80788 [details]
PPT file with hyperlinks

The most of the hyperlinks are missing in the imported ppt and pptx files (see attachments).

Tested with:

3.6.2.2 (Linux Mint 14)
4.0.3.3 (Fedora 18 x64)
4.0.3.3 (Windows 7)
4.1.0.0.beta2 (Windows XP SP3)
Comment 1 Zirneklītis 2013-06-13 17:37:06 UTC
Created attachment 80789 [details]
PPTX file with hyperlinks
Comment 2 Zirneklītis 2013-06-13 17:38:49 UTC
Created attachment 80790 [details]
PPT file with hyperlinks
Comment 3 Thomas van der Meulen 2013-06-20 16:58:35 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4.
Comment 4 Ofir 2015-05-13 23:16:31 UTC
Created attachment 115581 [details]
PPT with link

The Hyperlink is not imported
Comment 5 Ofir 2015-05-13 23:19:28 UTC
Added another example of PPT with hyperlinks that are missing in import.
Tested with LO 4.4.2.2, Ubuntu 15.04.
Comment 6 Uldis Kalniņš 2015-06-23 16:24:57 UTC
Bug still is present in 4.4.4.2
Comment 7 raal 2017-10-08 05:14:58 UTC
*** Bug 112944 has been marked as a duplicate of this bug. ***
Comment 8 raal 2017-10-08 05:15:53 UTC
ppt works
Comment 9 Raja 2018-04-09 21:08:34 UTC
ok. You mentioned ppt works. But reported issue is in pptx. Can you please look at 112944 which is marked duplicate of this issue. But we need an update on this issue ASAP. 

Thanks so much.
Comment 10 Roman Kuznetsov 2018-09-24 20:09:43 UTC
still repro in 

Version: 6.2.0.0.alpha0+
Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: ru-RU (ru_RU); Calc: threaded
Comment 11 Roman Kuznetsov 2018-11-30 08:57:50 UTC
*** Bug 91643 has been marked as a duplicate of this bug. ***
Comment 12 Roger Wo 2019-04-10 08:36:54 UTC Comment hidden (obsolete)
Comment 13 Roger Wo 2019-04-10 08:38:11 UTC Comment hidden (obsolete)
Comment 14 Roger Wo 2019-04-10 08:40:37 UTC Comment hidden (obsolete)
Comment 15 Roger Wo 2019-04-17 09:36:17 UTC
Created attachment 150812 [details]
slide_index.pptx
Comment 16 Roger Wo 2019-04-17 09:36:36 UTC
Created attachment 150813 [details]
slide_index.ppt
Comment 17 Roger Wo 2019-04-17 10:54:32 UTC
(In reply to Roger Wo from comment #12)
> Still repro in 6.2.2. 
> I'm also attaching the sample files from Bug 65724 for testing:
> - 6O PM User Guideline.pptx: links on slide 2 got lost.
> - 6O PM User Guideline.ppt: links on slide 2 can be displayed correctly.

Amend to comment #12:
Still repro in 6.2.2. 
I'm also attaching the sample files from Bug 112944 for testing:
- slide_index.pptx: links on slide 2 got lost.
- slide_index.ppt: links on slide 2 can be displayed correctly.
Comment 18 Guilhem Moulin 2019-04-17 12:03:48 UTC Comment hidden (obsolete)
Comment 19 Guilhem Moulin 2019-04-17 12:04:10 UTC Comment hidden (obsolete)
Comment 20 Buovjaga 2019-09-25 14:31:29 UTC
Still confirmed.

attachment 80790 [details] (PPT) also has missing hyperlinks, but not the same ones as in the PPTX version

Version: 6.4.0.0.alpha0+ (x64)
Build ID: e1b51d4588b4b39592bb94dd5bb90de5e04d061e
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-23_09:16:11
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 21 Xisco Faulí 2019-10-13 17:29:18 UTC
@Tünde Tóth, I thought you might be interested in this issue...
Comment 22 NISZ LibreOffice Team 2021-01-29 07:48:38 UTC
Created attachment 169256 [details]
Screenshot of the original document side by side in PP and Impress

Still a problem in:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7eb289c49cc7245ef3001a39be0c15d06bbe875b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 23 Commit Notification 2021-04-29 09:04:03 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d0550d1c5d0e27b8fe9d93e2c7a6dc7ffc4f8c21

tdf#65724 PPTX import: fix internal hyperlink to slide

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Timur 2021-04-29 13:28:58 UTC
I like seeing those "Inherited" being marked Fixed. 
Until I'm able to test, I'll open separately for PPT (single for open and save).
Comment 25 Buovjaga 2021-04-29 14:26:21 UTC
I verify the fix with attachment 80789 [details]

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 9224109de3cf2b620ff1165d31e9fb2a4cd680cf
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 29 April 2021
Comment 26 Timur 2021-05-05 11:32:04 UTC
PPTX attachment 80789 [details] tested in Edit mode with Ctrl and in Presentation.
Edit:
Title page OK (with links after the fix), 1st page > 3rd page NOK, 1st > Title OK, 2nd > Title OK, 2nd > Last OK
Presentation:
Title page OK (links were partially working, also seen now), 1st page > 3rd page OK (as before), 1st > Title NOK (doesn't work immediately but can work after a few clicks), 2nd > Title NOK, 2nd > Last NOK

Duplicate bug 91643 not fixed, New.
Duplicate bug 112944 is not fixed. Example wasn't quite well, attachment 80789 [details] here is better. 

New follow-up issue is that work "page" after ordinals on Title page is little too big.

This was improved but not all fixed. I set Reopen. 
Tibor, please comment if you would work more on this, or that this stays closed and remaining goes to bug 112944.
Comment 27 Buovjaga 2021-05-05 13:29:56 UTC Comment hidden (obsolete)
Comment 28 Timur 2021-05-05 13:35:45 UTC Comment hidden (obsolete)
Comment 29 Tibor Nagy (NISZ) 2021-05-05 13:46:16 UTC Comment hidden (obsolete)
Comment 30 Buovjaga 2021-05-05 14:38:48 UTC Comment hidden (obsolete)
Comment 31 Timur 2021-05-05 15:20:43 UTC
(In reply to Tibor Nagy (NISZ) from comment #29)
> > This was improved but not all fixed. I set Reopen. 
> > Tibor, please comment if you would work more on this, or that this stays
> > closed and remaining goes to bug 112944.
> 
> Hello!
> Yes, I think it stay closed and the remaining bug goes to 112944.

Ok, I'll open that one. 
Please consider to fix here the size of word "page" after ordinals on Title page,because that was fixed for link but should look good, so that fix is complete.
Comment 32 Buovjaga 2021-05-06 06:16:12 UTC
(In reply to Buovjaga from comment #30)
> Ok, I didn't notice that actually the whole text box is linkified:
> <p:cNvPr id="3076" name="Text Box 4">
>     <a:hlinkClick r:id="rId3" action="ppaction://hlinksldjump"/>
> </p:cNvPr>

Regarding this, I didn't test in practice, but from reading the code it seems that  oox/source/drawingml/shapecontext.cxx handles the text box import.

With case XML_hlinkClick it returns a HyperLinkContext. However, in this case the URL does not help. What points to slide 3 is the relationship reference r:id="rId3"

The relationship is defined in ppt/slides/_rels/slide2.xml.rels (slide4.xml is "3rd page")

So should HyperLinkContext be augmented to take these relationship-based links into account?
Comment 33 Timur 2021-05-06 07:17:37 UTC
Buovjaga, can you please write that in the other bug? Since Tibor already preferred to close this one - hopefully after format fix.
I first opted that other one is bug 112944. But now I see there's also better described bug 141704. So I'll mark bug 112944 a duplicate.
Comment 34 Buovjaga 2021-05-06 07:21:23 UTC
(In reply to Buovjaga from comment #32)
> (In reply to Buovjaga from comment #30)
> > Ok, I didn't notice that actually the whole text box is linkified:
> > <p:cNvPr id="3076" name="Text Box 4">
> >     <a:hlinkClick r:id="rId3" action="ppaction://hlinksldjump"/>
> > </p:cNvPr>
> 
> Regarding this, I didn't test in practice, but from reading the code it
> seems that  oox/source/drawingml/shapecontext.cxx handles the text box
> import.
> 
> With case XML_hlinkClick it returns a HyperLinkContext. However, in this
> case the URL does not help. What points to slide 3 is the relationship
> reference r:id="rId3"
> 
> The relationship is defined in ppt/slides/_rels/slide2.xml.rels (slide4.xml
> is "3rd page")
> 
> So should HyperLinkContext be augmented to take these relationship-based
> links into account?

Ok, I see there is a fresh bug 141704 for this. The export was fixed two days ago in bug 54037.
Comment 35 Buovjaga 2021-05-06 07:26:04 UTC
(In reply to Timur from comment #33)
> I first opted that other one is bug 112944. But now I see there's also
> better described bug 141704. So I'll mark bug 112944 a duplicate.

Yes, duplicate status seems correct as bug 112944 is again a case of a link using a relationship reference:

<a:r>
    <a:rPr lang="en-US" dirty="0">
        <a:hlinkClick r:id="rId2" action="ppaction://hlinksldjump"/>
    </a:rPr>
    <a:t>Slide 3</a:t>
</a:r>
Comment 36 Tibor Nagy (NISZ) 2021-05-07 09:45:56 UTC
(In reply to Timur from comment #33)
> Buovjaga, can you please write that in the other bug? Since Tibor already
> preferred to close this one - hopefully after format fix.
> I first opted that other one is bug 112944. But now I see there's also
> better described bug 141704. So I'll mark bug 112944 a duplicate.

Hello! 
I advise that we close this bug and I please for you to open the "size of word "page" is little too big" problem in the other bug report.