Bug 66089 - FORMATTING: Wrong currency (and number) format from file created with Excel (see comment #17 for instructions to reproduce!)
Summary: FORMATTING: Wrong currency (and number) format from file created with Excel (...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All All
: medium normal
Assignee: Aron Budea
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords:
: 64518 117018 (view as bug list)
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2013-06-23 15:53 UTC by ign_christian
Modified: 2018-06-24 00:58 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample File (7.50 KB, application/msexcel)
2013-06-23 15:53 UTC, ign_christian
Details
Screenshot from LO 4.0.5.1 (127.01 KB, image/png)
2013-08-23 04:27 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ign_christian 2013-06-23 15:53:54 UTC
Created attachment 81270 [details]
Sample File

I had file that created with MSO. Currency format misinterpreted by LO so the currency overlap left column.

Steps to reproduce;
1. Open attached file
2. See that values on column C have currency (Rp) that overlap column B

That format is:
_([$Rp-421]* #.##0,00_);_([$Rp-421]* \(#.##0,00\);_([$Rp-421]* -??_);_(@_)

Cell C6 & C7 had misallignment that I've been reported on Bug 64518.
Perhaps also related to Bug 48810

This bug still happen on LO 4.0.4.2 (Win7 Home Premium 32bit)
Comment 1 ign_christian 2013-06-23 16:01:39 UTC
Change version to 3.6.6.2 (oldest known version)
Comment 2 Cor Nouws 2013-06-23 16:39:38 UTC
hi ign_christian,

I do not see the overlap of Rp with column B in LibreOffice 3661, 4042 and 4101 on Ubuntu
Comment 3 Jorendc 2013-06-23 17:10:15 UTC
Hi,

Indeed. I fail to reproduce this using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 87c50e75633f31b54bfa1758cc0921ac53c6b418
So as far I can see -> Windows only :-). Marking it as such.

Kind regards,
Joren
Comment 4 Thomas van der Meulen 2013-06-23 17:44:58 UTC
Thank you for your bug report, I CAN't reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4. 

I also can't reproduce this bug running LibreOffice 4.1.0.0 beta2 and 4.0.4.2 on Windows 7.
Comment 5 ign_christian 2013-06-24 01:34:51 UTC
So...something wrong with my laptop :(
Ok i'll try to reset user profile & clean install LO

I've just checked that on OOO 3.3.0 (Win XP) not happen too
Comment 6 ign_christian 2013-06-24 02:06:50 UTC
Yes, currency problem solved with resetting user profile :)
Thanks all for testing
Comment 7 ign_christian 2013-08-23 04:26:21 UTC
Still happen on LO 4.0.5.1 even after resetting user profile. I don't have any idea with the inconsistent behavior..perhaps because Indonesian language setting? (but I'm using standard English installation)

Same behavior also happen with XLSX file (if required i will file new bug report).
Comment 8 ign_christian 2013-08-23 04:27:27 UTC
Created attachment 84490 [details]
Screenshot from LO 4.0.5.1
Comment 9 retired 2014-01-03 12:36:02 UTC
Hey Christian,

is this bug still valid / reproducible with the latest pre-release 4.2.0.1: http://www.libreoffice.org/download/pre-releases/

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 10 ign_christian 2014-04-13 14:06:34 UTC
Hi..unfortunately this bug still exist & same behavior.

Tested on LO 4.2.3.3 (Ubuntu 12.04 x86)
Comment 11 retired 2014-06-27 20:48:45 UTC
Christian, just a ping. Does this one here persist with 4.3RC1? http://www.libreoffice.org/download/pre-releases/

If so, please back to unconfirmed, thanks.
Comment 12 ign_christian 2014-06-28 07:17:25 UTC
(In reply to comment #11)
Thanks for the ping..encourages me to observe more deeply :)

I just found what is responsible for the problem: "Use printer metrics for text formatting" enabled. I always enable that setting though I don't really know the actual usability.

Since LO 3.6.x until 4.3.0.1, that setting generates that weird problem: overlapping / misalignment.

But that setting doesn't generate the problem in LO 3.5.7.2, OOO 3.3.0, AOO 4.1.0.

I'll observe the "printer metrics" thing in other bugs.
Comment 13 sophie 2014-08-07 15:12:37 UTC
Hi Christian, so I've check that setting in my version 4.3.0.4 Unbuntu 14.04 and the text doesn't overlap. Left as unconfirmed - Sophie
Comment 14 Jacques Guilleron 2014-08-07 21:56:39 UTC
Hi,

Sorry to be too late, but can you see also 
Bug 78503 - EDITING: Some cells overlap the cell to the left when Calc option "Use printer metrics for text formatting" is enable.

Regards,

Jacques
Comment 15 ign_christian 2014-08-08 07:08:40 UTC
Unfortunately it's still not fix, same behavior in 4.3.0.4 and 4.3.1.0.0+ Time: 2014-07-30_10:54:10

I think it's only reproducible with particular currency format like in screenshot & "Use printer metrics for text formatting" is enabled.

Sophie, would you mind checking what is the currency format in which you can't reproduce this issue?

Ok Jacques, I'll see that
Comment 16 Buovjaga 2014-11-05 13:44:32 UTC
(In reply to ign_christian from comment #15)
> Unfortunately it's still not fix, same behavior in 4.3.0.4 and 4.3.1.0.0+
> Time: 2014-07-30_10:54:10
> 
> I think it's only reproducible with particular currency format like in
> screenshot & "Use printer metrics for text formatting" is enabled.
> 

Can't reproduce.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-05_00:40:38
Comment 17 raal 2014-11-06 13:31:48 UTC
I can reproduce with LO 4.3.2, win7. For reproduce is needed to set national settings to Indonesian and set "Use printer metrics for text formatting"
Comment 18 QA Administrators 2015-12-20 16:20:45 UTC Comment hidden (obsolete)
Comment 19 Laurent BP 2016-05-16 17:12:19 UTC
*** Bug 64518 has been marked as a duplicate of this bug. ***
Comment 20 QA Administrators 2017-05-22 13:40:49 UTC Comment hidden (obsolete)
Comment 21 m.a.riosv 2018-04-16 09:32:44 UTC
*** Bug 117018 has been marked as a duplicate of this bug. ***
Comment 22 Commit Notification 2018-06-20 19:44:13 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=93e9a3e2b545c853f53ffe28d2795f55ad29f304

tdf#66089 tdf#105720: only rely on bPixelToLogic

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Aron Budea 2018-06-21 02:26:45 UTC
With the above commit the spreadsheet looks fine to me after the instructions in comment 17. Backport to 6.1 is in gerrit.
Comment 24 Commit Notification 2018-06-21 06:45:49 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b86a8857e6488bac1224a9eed471bcf930994399&h=libreoffice-6-1

tdf#66089 tdf#105720: only rely on bPixelToLogic

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Jacques Guilleron 2018-06-22 09:46:19 UTC
Works as expected now with
LO 6.2.0.0.alpha0+ Build ID: 4a82543b3419339ae554485c582a80c41a57c417
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-22_06:30:14
Locale: fr-FR (fr_FR); Calc: CL

Thank you very much, Aron.