Bug Hunting Session
Bug 66118 - FILEOPEN: MS 97 .doc Fails to import properly. Missing Separator (2/5)
Summary: FILEOPEN: MS 97 .doc Fails to import properly. Missing Separator (2/5)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.1:OSX Confirmed:4.3.0...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-24 10:00 UTC by Luke
Modified: 2014-03-29 15:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
MS .doc file fails to import correctly (552.50 KB, application/msword)
2013-06-24 10:00 UTC, Luke
Details
Comparison of Doc in Word vs Writer (1.15 MB, image/png)
2013-06-24 10:01 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-24 10:00:08 UTC
Created attachment 81318 [details]
MS .doc file fails to import correctly

This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS Word 2003 .doc files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-Hayden-Management.doc document in writer 
2. Open attached Demo-Hayden-Management.doc document in Word2003/Office 365
3. Compare the documents. 

Note item #2 in the image comparison. The separator bar is not displayed after being imported in LO.
Comment 1 Luke 2013-06-24 10:01:57 UTC
Created attachment 81319 [details]
Comparison of Doc in Word vs Writer

Note item #2, the missing separator bar
Comment 2 Jorendc 2013-06-24 11:44:05 UTC
I can confirm this behavior using Mac OSX 10.8.3 with LibreOffice 4.1.0.1 RC.

Kind regards,
Joren
Comment 3 retired 2014-01-12 15:14:23 UTC
Confirmed:4.2.0.1:OSX Confirmed:4.3.0.0a0+:OSX
Version: 4.3.0.0.alpha0+
Build ID: cbe7ab3d6188e725414cbb15ca534f96fe51d8c7
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-01-12_00:08:19

Gladly all other issues now work. Hope this remaining glitch can be addressed soon :)
Comment 4 Luke 2014-03-29 10:23:03 UTC
In the latest nightly 4.3, the separator bar is now being displayed. Nice work team! 

Tested on:
Version: 4.3.0.0.alpha0+
Build ID: 5e7aad393c0c3fab20c8298697ca96563caa7afe
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-28_07:18:14
Comment 5 retired 2014-03-29 15:29:31 UTC
Wow. Another of your bug reports resolved in nightly.

Looks like only one is remaining. Who would have thought... :)