Bug 66237 - Document preview of tables shows overlayed toolbar icons and misplaced column headers
Summary: Document preview of tables shows overlayed toolbar icons and misplaced column...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords: bibisected, bisected, regression
: 101709 105949 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-27 06:51 UTC by Alex Thurgood
Modified: 2017-02-13 08:27 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot or erroneous icon overlay (314.74 KB, image/png)
2013-06-27 06:53 UTC, Alex Thurgood
Details
previe works when window is resized. (147.55 KB, image/png)
2013-12-22 11:28 UTC, robert
Details
Confirmed Fixed on Windows 7 x64 running x86 version (123.69 KB, image/jpeg)
2017-02-12 11:16 UTC, daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2013-06-27 06:51:05 UTC
How to reproduce :

1) Open a database file containing tables.
2) Click on the Tables icon
3) Activate the Document preview mode on the right
4) Toolbar icons are overlaid on the table contents and table colum headers are misplaced.


This is a UI (re)drawing problem. We had a similar problem at one stage in Impress with document previews showing toolbar icons on top of the preview itself.

It is also a regression over 3.6.x

Alex
Comment 1 Alex Thurgood 2013-06-27 06:51:43 UTC
Adding Lionel, Julien to CC
Comment 2 Alex Thurgood 2013-06-27 06:53:43 UTC
Created attachment 81526 [details]
Screenshot or erroneous icon overlay
Comment 3 Julien Nabet 2013-06-27 20:00:44 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.
Comment 4 Alex Thurgood 2013-07-11 07:09:25 UTC
Adding Cedric to CC, as I think he worked on the preview frame code when reworking the new template management window

Cedric, if I'm wrong, just take yourself off again.

Alex
Comment 5 robert 2013-12-22 11:28:01 UTC
Created attachment 91120 [details]
previe works when window is resized.

Have tested a little bit more. The preview with buttons is introduced with LO 4.1. During the first version I could test (LO 4.1.0.0 beta1) it only shows the greyed out icons at a wrong position.
When I resize the window the buttons appear (with other buttons) at the right position and you could search, filter and order the data in the preview. Only a cursor is missing in the fields, which shows the position you clicked at last.
When you open the table for editing an then close it, the greyed out icons where shown again at the wrong position.
The only way to get is work is to resize the window. Seems to be a refresh-problem.
It doesn't work right from the beginning. Don't know, if we could call this a regression.
Comment 6 Alex Thurgood 2013-12-22 12:16:32 UTC
Hi Robert,

The problem is that the preview didn't have the buggy display in 3.6. In other words, the introduction of this "feature" has introduced imo a bug into something that worked previously and should be considered a regression. 

I didn't even know that the buttons were a new feature until you mentioned it just now ;-) 

Alex
Comment 7 thackert 2013-12-22 14:26:38 UTC
Hello Alex, *,
I can confirm your bug with LO Version: 4.2.0.1 Build-ID: 7bf567613a536ded11709b952950c9e8f7181a4a (parallel installed with Germanophone lang- as well as helppack) and my installed LO Version: 4.1.4.2 Build-ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72 (also with Germanophone lang- as well as helppack) under Debian Testing AMD64 ... :(

Robert thankfully did some further testing, which he mentioned at the QA ml at first :) So I did some additional testing ... ;) If you switch to a different desktop / workspace and/or program window, these greyed-out icons will disappear completely, until you resize your LO window, which will bring back the icon bar. So it seems really a problem with the redrawing of the window, but I am not sure, if this is dependent on your graphics chip/driver or what else ... :(
HTH
Thomas.
Comment 8 Cédric Bosdonnat 2013-12-23 09:01:22 UTC
Removing myself from CC: not hacking writer anymore
Comment 9 Julien Nabet 2014-01-20 22:16:44 UTC
Just for the update, I can still reproduce this with master sources updated today.
Comment 10 Dominik 2014-05-06 15:24:55 UTC
Still reproduce-able in Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8 on Win 7 x64
Comment 11 Julien Nabet 2014-11-14 23:06:24 UTC
On pc Debian x86-64 with master sources updated today I could still reproduce this :-(

Code pointer: it seems we must investigate from SID_DB_APP_VIEW_DOC_PREVIEW
Comment 12 Johnnyb 2014-12-23 16:59:32 UTC
Making any changes to the toolbars via 

View -> Toolbars

temporarily fixes the issue in LibreOffice version 4.2.7.2. The temporary fix disappears when another table is chosen.
Comment 13 Julien Nabet 2014-12-29 19:43:58 UTC
Caolan/Chris: I might be wrong but this kind of glitch makes me think it could be in vcl part. Any idea?
Comment 14 Alex Thurgood 2015-01-03 17:41:31 UTC Comment hidden (no-value)
Comment 15 Robinson Tryon (qubit) 2015-03-05 18:10:57 UTC
(In reply to robert from comment #5)
> It doesn't work right from the beginning. Don't know, if we could call this
> a regression.

Fair point. Sounds like it still might be helpful to bibisect on the symptoms here and see where that leads us.
Whiteboard -> bibisectRequest
Comment 16 Julien Nabet 2015-10-25 13:41:48 UTC
Just to give an update, I still reproduce this with master sources updated today.
It happens with SAL_USE_VCLPLUGIN=gen, gtk or by default gtk3 in my case.
Comment 17 Robinson Tryon (qubit) 2015-12-14 05:32:50 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]
Comment 18 robert 2016-08-25 19:06:22 UTC
*** Bug 101709 has been marked as a duplicate of this bug. ***
Comment 19 Aron Budea 2017-02-05 06:25:22 UTC Comment hidden (bibisection)
Comment 20 Aron Budea 2017-02-05 06:28:14 UTC
Two commits have influenced how the preview looks here.
The first commit added toolbar buttons above the table in the preview (probably by accident), then the second one didn't remove them completely, and resulted in the current look.
Adding Cc: to Noel Grandin and adding Cc: to Caolán McNamara, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b248624126c271c88381d3dad6e04fc954f65779
author		Noel Grandin <noel@peralex.com>	2013-03-22 07:24:15 (GMT)
committer	Noel Grandin <noel@peralex.com>	2013-04-08 11:53:04 (GMT)

"fdo#46808, Convert frame::Frame to new style"


https://cgit.freedesktop.org/libreoffice/core/commit/?id=9ca23ee5e776b80d1e8fcac4c3897cc0d0569bc3
author		Caolán McNamara <caolanm@redhat.com>	2013-04-09 09:24:32 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2013-04-09 09:27:21 (GMT)

"make help work again
This is a regression from b248624126c271c88381d3dad6e04fc954f65779 I suspect
there might be more."
Comment 21 Commit Notification 2017-02-09 15:30:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6851074c8a515ec5a7856d4b744e3425c8829a29

Resolves: tdf#66237 set layout manager the way it used to

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Caolán McNamara 2017-02-09 15:30:33 UTC
fixed in master, backport for 5-3 and 5-2 in gerrit
Comment 23 Commit Notification 2017-02-09 19:23:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2be5e763d2e03bffc692d40106212fe52a7b7304&h=libreoffice-5-3

Resolves: tdf#66237 set layout manager the way it used to

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 robert 2017-02-12 08:48:15 UTC
*** Bug 105949 has been marked as a duplicate of this bug. ***
Comment 25 daniel 2017-02-12 10:59:28 UTC
(In reply to robert from comment #24)
> *** Bug 105949 has been marked as a duplicate of this bug. ***

Thanks Robert, Thanks Caolán McNamara for your hard work! Will download the daily release soon.
Comment 26 daniel 2017-02-12 11:16:04 UTC
Created attachment 131127 [details]
Confirmed Fixed on Windows 7 x64 running x86 version
Comment 27 Commit Notification 2017-02-13 08:27:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=afeeed5235bb796ce3d0a74166957d3799f59b39&h=libreoffice-5-2

Resolves: tdf#66237 set layout manager the way it used to

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.