Download it now!
Bug 66365 - Brother QL-580N failed landscape printing
Summary: Brother QL-580N failed landscape printing
Status: CLOSED DUPLICATE of bug 33791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 14:43 UTC by Holger Bruenjes
Modified: 2013-07-11 21:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Brother QL Template for Linux (448.01 KB, application/gzip)
2013-06-29 14:43 UTC, Holger Bruenjes
Details
view in writer (54.44 KB, image/png)
2013-06-29 14:44 UTC, Holger Bruenjes
Details
view in printdialog (35.72 KB, image/png)
2013-06-29 14:44 UTC, Holger Bruenjes
Details
Printer -output-scan (2.67 MB, image/png)
2013-06-29 14:56 UTC, Holger Bruenjes
Details
printout_with_openoffice (1.90 MB, image/png)
2013-06-29 17:40 UTC, Holger Bruenjes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Bruenjes 2013-06-29 14:43:05 UTC
Created attachment 81678 [details]
Brother QL Template for Linux

used SUSE 12.3 Version 3.6:build-304 (Build ID: 360m1(Build:304))

if the bugs 55085, 57704, 65506 match this, I dont no.

with the Brother Label Printer QL-580N landscape printing failed, the output is in portrait Mode.

I use the original template from brother, see attachment.

in the printing dialog the view was correct, but the output comes in portrait.
portrait mode worked correct.

With the old version 3.2 from OpenOffice on the same maschine it worked correct, sorry.
Comment 1 Holger Bruenjes 2013-06-29 14:44:13 UTC
Created attachment 81679 [details]
view in writer
Comment 2 Holger Bruenjes 2013-06-29 14:44:48 UTC
Created attachment 81680 [details]
view in printdialog
Comment 3 Holger Bruenjes 2013-06-29 14:56:00 UTC
Created attachment 81681 [details]
Printer -output-scan
Comment 4 Julien Nabet 2013-06-29 16:38:12 UTC
Holger: 3.6.0.4 is quite old, could you give a try to a newer version 3.6.6 or even better a 4.0 branch like 4.0.3 or the brand new 4.0.4?
Comment 5 Holger Bruenjes 2013-06-29 16:58:08 UTC
hmm, this is the SUSE Version im repo 12.3 ;-)


Yes, I have tested it before with my old system SUSE 11.4 and

Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)

from LibreOffice download

and have the same effect. I setting up the SUSE 12.3 last week and complete the system step bye step now.
Comment 6 Julien Nabet 2013-06-29 17:08:43 UTC
Comment on attachment 81678 [details]
Brother QL Template for Linux

Mimetype fixed
Comment 7 Julien Nabet 2013-06-29 17:12:40 UTC
Do you reproduce this on other softwares? I'm asking because it could also be a problem with Cups config and/or drivers
Comment 8 Holger Bruenjes 2013-06-29 17:29:31 UTC
Sorry, I wrote in my first comment,

I can use the old version 3.2 from OpenOffice and it worked perfect, here on the same system.

So I think is not the problem with CUPS
Comment 9 Julien Nabet 2013-06-29 17:32:22 UTC
Holger: thank you for your quick feedback. Sorry, I thought that there could have been config changes between the time you used OOo 3.2 and LO.

Michael: any idea how to investigate here?
Comment 10 Holger Bruenjes 2013-06-29 17:40:00 UTC
Created attachment 81701 [details]
printout_with_openoffice

the printout scan with OpenOffice on the same system
Comment 11 Holger Bruenjes 2013-06-29 18:19:21 UTC
I will provide the hardware, if the developer is interested in, floeff shall order it.
Comment 12 Holger Bruenjes 2013-06-30 10:36:58 UTC
I installed from SUSE factory-snapshot 4.0.3.3 but soffice failed

a strace soffice failed with exit 137

but this is a other problem, I rollback to SUSE repo 12.3
Comment 13 Holger Bruenjes 2013-06-30 12:42:01 UTC
OK, in the first step SUSE Factory has no metadata and YAST can not work with it.

Now I come back and it worked

LibreOffice from SUSE Factory

Version 4.0:build-304 (Build ID: 400m0(Build:304))

the effect was the same, no landscape printing.
Comment 14 Florian Effenberger 2013-07-01 07:42:30 UTC
Feedback I received on what could be done:

"Installing the right pps (or whatever pdf printing uses these days), then printing to file, and then e.g. comparing the generated output with one for a
printer that is known to work is the next step."
Comment 16 Holger Bruenjes 2013-07-02 20:40:54 UTC
I fetch now a OpenOffice 3.3.0 and the landscape printing worked perfect

OOO330m20 (Build:9567)
Comment 17 Holger Bruenjes 2013-07-02 22:02:29 UTC
I found the break, I fetch the old archive from

http://downloadarchive.documentfoundation.org/libreoffice/old/

in 
LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1

landscape printing worked with the Brother Label Printer QL-580N perfect



==============================

in 
LibreOffice 3.4.0 
OOO340m1 (Build:11)

landscape printing failed
Comment 18 Michael Meeks 2013-07-03 10:38:21 UTC
Almost certainly a duplicate of a rather long standing issue; thanks for the report.

*** This bug has been marked as a duplicate of bug 33791 ***
Comment 19 Holger Bruenjes 2013-07-11 21:09:32 UTC
Solved

The default print format 'PDF' break the output. 

Do not use that!