Bug Hunting Session
Bug 66545 - FORMATTING: Disabling grey field shading of hyperlinks in CALC
Summary: FORMATTING: Disabling grey field shading of hyperlinks in CALC
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:6.2.0
Keywords:
: 83296 89271 119825 (view as bug list)
Depends on:
Blocks: Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2013-07-03 09:03 UTC by wolfgang-becker
Modified: 2019-11-13 13:50 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
example for hyperlink with grey background (32.43 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-03 10:45 UTC, wolfgang-becker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wolfgang-becker 2013-07-03 09:03:16 UTC
LibreOffice should better improve the intuitive usability of the most used basic functions than adding more and more enhancements. LibreOffice is a good program, but it's peculiarities sometimes make me crazy and let me think of choosing another office program.

1. I want to disable the ugly grey field-shading of hyperlinks in CALC. The special color of the text foreground (visited and unvisited links) would to be enough to mark hyperlinks (like in in other spreadsheet programs). If I un-check ("ON") in the check box at "Tools > Options > Appearence > Textdocument > Field Shadings" there is no change (BUG ?). I do not want to choose a different color in the color setting box, I want always the same color as the background of the cells  (transparent background).
See also http://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=32519, http://de.openoffice.info/viewtopic.php?f=2&t=8983 (german)

2. Why there is no quick function to delete a hyperlink (e.g. in right-click context-menu). Instead you have to use "Format > Clear Direct Formating". I think, nobody would intuitely get access to this solution, which does not only delete the hyperlink but all formating (colors) of the cell.
Comment 1 retired 2013-07-03 09:22:41 UTC
Wolfgang: Could you please attach an example document displaying the problem?
Comment 2 wolfgang-becker 2013-07-03 10:45:06 UTC
Created attachment 81951 [details]
example for hyperlink with grey background

Wilhelm, here it is. 

I think, if I uncheck Custom Colors, Box "On", Field shadings, there should be NO grey or other color background for the link.

If this is no bug, 
how can I get rid of the field shading (color) in CALC. 
This is a annoyance that many users have. 

To set the color of the field shading white is NO solution, if the cell has another background than white.
Comment 3 Owen Genat (retired) 2013-07-26 14:32:04 UTC
This appears to be a bit of an awkward bug. It is evidently a very old problem inherited from the original OOo code. Related AOO bug is https://issues.apache.org/ooo/show_bug.cgi?id=37988 which references v1.1.3. As such I am setting the status to NEW as I feel this is a confirmed issue, it is merely the solution that is unconfirmed.

I believe that the way in which hyperlinks are handled in Calc, needs to be made consistent with how they are handled in Writer i.e., via styles-based formatting. This would require implementing character styles in Calc.

By way of comparison, a hyperlink in Writer is controlled by the character styles Internet Link and Visited Internet Link. Unchecking the option in question (or using CTRL+F8) in Writer does remove the grey highlighting of, for example, a cross-reference field, but does not affect the appearance of a hyperlink. It is probably also worth noting that the option is listed beneath the Text Document, rather than Spreadsheet, section. 

The term "field" in particular seems to cover a broad range of possibilities with regard to shading. For example, certain Unicode characters like Zero Width Space (U+200b) and No Break Space (U+00a0) are currently included. These Appearance options probably require a reworking.
Comment 4 raal 2015-02-10 08:20:52 UTC
*** Bug 89271 has been marked as a duplicate of this bug. ***
Comment 5 enemarcel 2015-02-10 08:55:03 UTC
Any chance of seeing this solved in the near future?
Comment 6 enemarcel 2015-02-13 11:49:41 UTC
I have checked in Apache OpenOffice Calc 4.1.1 and they have solved this bug.
Are you going to sove it in LibreOffice Calc?
Comment 7 Jean-Baptiste Faure 2015-03-01 20:57:41 UTC
Workaround: use the function HYPERLINK() instead of automatic recognition of hyperlinks. 

Best regards. JBF
Comment 8 enemarcel 2015-03-09 11:52:26 UTC
This could work if I whould create the document.
But in my case, I receive documents already created by others using Microsoft Excel Office.
These excel documents have hundreds of links and I get updated documents every week. 
I thank you for geting envolved in this issue!
Comment 9 tommy27 2016-04-16 07:28:34 UTC Comment hidden (obsolete)
Comment 10 Jean-Baptiste Faure 2016-05-06 16:52:51 UTC
Nothing changed in LO 5.1.4.0.0+ and master, both build at home under Ubuntu
16.04 x86-64.

Set as enhancement because this field shading is there by design.
Set version to inherited from OOo because it was already the case in OOo and LO did not change that.

Best regards. JBF
Comment 11 ciupol 2016-06-18 21:19:35 UTC
Just want to confirm that I also have this problem. Calc version 5.1.3.2 on Windows 10.
Very annoying.
Comment 12 Pierre Lepage 2016-12-16 10:35:15 UTC
I confirm for point 2 of wolfgang-becker@online.de. I was to open a bug but by looking in Bugzilla with "Calc" "Hyperlink", I came across this bug. And I found the solution exposed long version by wolfgang-becker@online.de!
Comment 13 likivik 2018-05-15 13:42:34 UTC
Again, want to confirm this. Field shading is impossible to remove. I cannot believe it doesn't bother more people. Deleting a link from context menu would be very handy.
Tried on mac and ubuntu, version 6.0
Comment 14 Xisco Faulí 2018-09-13 13:49:39 UTC
*** Bug 119825 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2018-09-13 13:50:27 UTC
@Heiko, I thought you could be interested in this issue...
Comment 16 Heiko Tietze 2018-09-16 15:47:05 UTC
(In reply to Xisco Faulí from comment #15)
> @Heiko, I thought you could be interested in this issue...

Will have a look
Comment 17 Commit Notification 2018-10-09 16:38:19 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b8886ad7744fc48e09bb7379d8ad8e75bb3084d

Resolves: tdf#66545 display URL fields non-shaded in Calc

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Thomas Lendo 2018-10-09 18:26:19 UTC
Thank you, Eike, for your patch to close this old bug!

Now I see complains coming that the shading isn't an option to activate/deactivate.
Comment 19 Heiko Tietze 2018-10-12 09:24:46 UTC
*** Bug 83296 has been marked as a duplicate of this bug. ***
Comment 20 BogdanB 2018-10-29 08:58:37 UTC
Solved. Ferified on:
Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-21_02:45:54
Locale: en-US (ro_RO.UTF-8); Calc: threaded
Comment 21 marc.tremblay.23789 2019-11-13 13:50:23 UTC
OMG.  Thank you so much for FINALLY getting rid of this decade old aggravating bug! These kind of details are the reason some people don't fully switch to LibreOffice.  I've been reluctant to switch until this was fixed and forgot to re-check this thread last year.  I'll update to 6.3.3 now! Thanks Eike Rathke!