Bug 67146 - FILESAVE: Validation is removed in XLSX
Summary: FILESAVE: Validation is removed in XLSX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 80407 88494 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-21 20:06 UTC by mraetsen
Modified: 2017-01-25 08:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sheet with validation on column A1 (11.23 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-07-21 20:06 UTC, mraetsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mraetsen 2013-07-21 20:06:06 UTC
Created attachment 82786 [details]
Sheet with validation on column A1

Problem description: 
Trying to move to using libreOffice Clac but need to support Excel as well. If you have an XLSX file that has validation on the entire column, when you save (as xlsx), only the last cell that has data retains the validation. Cells below that remove the validation.

Steps to reproduce:
1. Attached xlsx has cell validation from A1:A200
2. Modify any cell (say A10)
3. Save as xlsx
4. When re-opened, cells below A10 have no validation.

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.2.0.0.alpha0+ Master
Comment 1 m.a.riosv 2013-07-22 01:03:53 UTC
Reproducible.
Win7x64i3Ultimate
Version: 4.2.0.0.alpha0+ Build ID: 2cce78137bbf9810421b9fdedd45127b019b1188
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-18_23:43:36
Comment 2 hesth 2013-09-13 15:47:57 UTC
Bug reproduced using Ubuntu 13.04 with two Calc versions -  4.0.2.2 and 4.1.1.2
Comment 3 ign_christian 2014-06-24 06:09:43 UTC
*** Bug 80407 has been marked as a duplicate of this bug. ***
Comment 4 ign_christian 2014-06-24 06:17:50 UTC
Change Version to 3.5.4 -> based on Bug 56823
Platform All

For XLS : Bug 41425
Comment 5 raal 2015-01-21 10:23:47 UTC
*** Bug 88494 has been marked as a duplicate of this bug. ***
Comment 6 sammy.trojette 2016-02-25 09:56:53 UTC
Bug is still reproducible.
Win 7, LibreOffice Version: 5.0.3.2 (x64)
Build-ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Comment 7 Bartosz 2016-08-07 03:59:50 UTC
I tested with LibreOffice 5.1 on Ubuntu 16.04 and it is validation list is showing correctly.