Download it now!
Bug 67387 - JDBC: time part of timestamp read as 00:00:00
Summary: JDBC: time part of timestamp read as 00:00:00
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.2.0 target:4.1.1
Keywords: regression
: 67447 68101 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-27 08:20 UTC by Robert Großkopf
Modified: 2013-08-14 18:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-07-27 08:20:30 UTC
Open the forms of https://bugs.freedesktop.org/attachment.cgi?id=83080 . There is a time-input in a timefield, which doesn't work since 4.0.0.0. beta1. The formatted field works well in this version and other 4.0.*-versions. So you could input a timestamp into a formatted field without any problem.

With version 4.1 the input of a timestamp in a formatted field works only for the date, not for the time. Time is shown as 00:00.

There has been something changed in the API. Cuold be it is a hint for this problem: https://bugs.freedesktop.org/attachment.cgi?id=83078
Comment 1 Robert Großkopf 2013-07-27 08:23:42 UTC
This bug has been confirmed by https://bugs.freedesktop.org/show_bug.cgi?id=67235#c11
Comment 2 Robert Großkopf 2013-07-27 08:59:22 UTC
Have tested where the bug first appears: LO 4.1.0.2.0. With LO 4.1.0.1 the formatted field works well with a timestamp.
Could this have been introduced with the fix of https://bugs.freedesktop.org/show_bug.cgi?id=66252
I will set Colan in CC.
Comment 3 Lionel Elie Mamane 2013-07-28 15:25:26 UTC
Fix is at https://gerrit.libreoffice.org/5149, but raises issues, so to be discussed.
Comment 4 Commit Notification 2013-07-29 13:37:00 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13fe681d6039ce39793b27629edfd22727f155f8

fdo#67387 skip separating space between date and time in timestamp



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Lionel Elie Mamane 2013-07-29 13:39:47 UTC
The update (write to database) was actually working alright; if one opened the .odb in an older LibreOffice, one saw the right value.

It was the *reading* of a Timestamp value that was broken, and always reading the time value as 00:00:00.

Review for backport to 4.1.1 requested at https://gerrit.libreoffice.org/5166
Comment 6 Lionel Elie Mamane 2013-07-29 13:41:16 UTC
(I thought that this bug was similar to bug 67235, but actually very different reason and nearly independent.)
Comment 7 Commit Notification 2013-07-31 13:43:16 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f9c340b4f8f54872eb97880d03c802a1620a1b6&h=libreoffice-4-1

fdo#67387 skip separating space between date and time in timestamp


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Lionel Elie Mamane 2013-08-01 05:41:51 UTC
*** Bug 67447 has been marked as a duplicate of this bug. ***
Comment 9 Robert Großkopf 2013-08-14 18:14:21 UTC
*** Bug 68101 has been marked as a duplicate of this bug. ***