Download it now!
Bug 67576 - setting printing page size in File->Print requires clicking new "Use only paper size from printer preferences" checkbox
Summary: setting printing page size in File->Print requires clicking new "Use only pap...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 67727 72070 89493 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-07-31 10:48 UTC by chilamchilam
Modified: 2016-02-04 03:10 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chilamchilam 2013-07-31 10:48:27 UTC
Since I have LibreOffice 4.1.0 installed, the paper format used by the print menu (and also finally used by the printer) does not correspond to what I've set in the printer properties menu. It always uses the page size of the document or the nearest bigger format which is the printer compatible with. (I'm sorry I have tested it only in writer before I went back to 4.0.4). I have Windows7 and the HP PSC-1510 printer, I also tried some virtual pdf printers with the same result.
Comment 1 Karl Relton 2013-11-05 19:26:33 UTC
I have this problem too.

E.g. if my document has a page size of A5 (set via Format->Page), then when I go to the print dialog LO now ALWAYS shows the thumbnail preview as an A5 page, regardless of what I set the page size too on the printer properties sub-form.

Previous release of LO would first show the thumbnail as A5, and then when I chose an appropriate page size on the printer properties that thumbnail would then change. E.g. if I selected A4 paper, the thumbnail preview would change to A4 (with the A5 image centred in the middle of the page).


This is a regression in 4.1.

I am using Linux, built with (I belive) a gtk based print dialog.
Comment 2 Karl Relton 2013-11-06 18:33:36 UTC
A clarification - for me its libreoffice using the libreoffice print dialog (not a gtk based one)
Comment 3 Michael Stahl (CIB) 2013-12-02 18:25:41 UTC
This was changed by:

commit f937ef20f57b306191f7583c2d47b5ad3f2a73ee
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Mon May 20 11:00:19 2013 +0100

    Related: fdo#61186 add a toggle to override the paper format

... but it's not clear to me whether this is a bug or intended behavior.

to use the page size from printer properties one has to
go to the "options" tab and click the item
"Use only paper size from printer preferences"
Comment 4 Karl Relton 2013-12-04 19:03:27 UTC
Ah I see now. I never tried the "Use only paper size from printer preferences" option.

Selecting that and the preview does indeed reconfigure to my chosen printer paper size ... which enables me to do the 2up (2 of A5 on an A4 sheet) printing that I was able to do before.

This solves the problem for me.
Comment 5 Caolán McNamara 2013-12-05 10:56:42 UTC
Yeah, this is intentional, see the long discussion at bug 61186 about trying to make the bundle of options and dialogs behave in some logical fashion.

The summary is that now to force the printer to only use the default paper size from the printer preferences then manually select the option "Use only paper size from printer preferences" under the options tab.
Comment 6 Michael Stahl (CIB) 2014-01-30 22:41:15 UTC
ok it's a feature apparently, have added it to https://wiki.documentfoundation.org/ReleaseNotes/4.1#Other
Comment 7 Michael Stahl (CIB) 2014-01-30 22:41:46 UTC
*** Bug 67727 has been marked as a duplicate of this bug. ***
Comment 8 Michael Stahl (CIB) 2014-01-30 22:45:27 UTC
*** Bug 72070 has been marked as a duplicate of this bug. ***
Comment 9 KDM 2014-02-26 18:07:49 UTC
(In reply to comment #6)
> ok it's a feature apparently, have added it to
> https://wiki.documentfoundation.org/ReleaseNotes/4.1#Other

Any chance of making it possible for the user to set "Use only paper size from printer preferences" as the default behavior in the preferences?
Comment 10 tmacalp 2014-07-11 21:30:20 UTC
I'm reopening this bug because I think the current behavior is unacceptably ambiguous and confusing.  Please let me know if I need to just open a new report, instead.

To define the current behavior, users are allowed to change the basic print setting, paper size, in the print dialog.  This setting is then completely ignored unless the user selects the infrequently used "Options" tab and enables the ambiguously worded setting, "Use only paper size from print preferences."  

I have the following issues with this behavior:

* The interface should be honest.  A user should expect that if they've taken the time to manually specify a paper size, that setting should be passed to the printer.

My recommendation for this particular issue is to either...
1. Add an entry "Automatic (by page format)" to the top of the paper size list and make that the default.
I think this is the most elegant solution.  It will be obvious to users that page size is being handled for them.  If someone manually changes their paper size from this automatic setting, we should actually honor it.  We can then remove "Use only paper size from print preferences" from the options tab.

2. Gray-out the Paper size drop-down.
If the intended behavior is to not use that field, we should make it obvious.  Graying-out the drop-down lets users know that it's not being used.  Unfortunately, this might cause other complications.  In special cases, like brochure printing, the page size IS honored.  Well, brochure printing currently ignores your page size the first try, but I recently reported bug 81065 on that issue.  Basically, a user would have to either enable brochure printing before selecting a different paper size or they would have to first check the setting that enables the override.


* The setting "Use only paper size from print preferences" is far away from the field that it modifies.  If checking this box is required for the paper size drop-down to do anything, it should be adjacent to the drop-down.  I would suggest putting the toggle right above Paper size on the "Paper" tab of Properties.  I know this is prime real estate and probably would require the UX Committee's input, but I think it'd be worth it, we're keeping the current behavior.


* "Use only paper size from print preferences" is worded in a way that means nothing to me.  I've seen this option many times, but incorrectly interpreted it.  It should be changed to something like "Allow print dialog to change paper size."


* There is no way to set a default policy for LO, through settings.  I would expect this to be a setting found under Tools -> Options -> Writer -> Print, under the "Other" section.  This is where the option "Paper tray from printer selection" exists already.


This also opens up the discussion for what Writer should actually do with the request for larger/smaller paper than is set up with the page format.  Draw, Impress, and Calc all have ways to scale print jobs to fit different sized paper using "Fit to Width" or "Fit to page" options.  Writer should have the same ability.  Of course, this will need to be reported elsewhere as an enhancement request.
Comment 11 Caolán McNamara 2014-07-14 08:01:10 UTC
never, never reopen bugs unless the time gap is very very small and the problem is very very clear
Comment 12 Cor Nouws 2016-02-03 13:42:54 UTC
*** Bug 89493 has been marked as a duplicate of this bug. ***
Comment 13 KDM 2016-02-03 17:34:10 UTC
(In reply to tmacalp from comment #10)
> I'm reopening this bug because I think the current behavior is unacceptably
> ambiguous and confusing.  Please let me know if I need to just open a new
> report, instead.
> 
> To define the current behavior, users are allowed to change the basic print
> setting, paper size, in the print dialog.  This setting is then completely
> ignored unless the user selects the infrequently used "Options" tab and
> enables the ambiguously worded setting, "Use only paper size from print
> preferences."  
> 
> I have the following issues with this behavior:
> 
> * The interface should be honest.  A user should expect that if they've
> taken the time to manually specify a paper size, that setting should be
> passed to the printer.
> 
> My recommendation for this particular issue is to either...
> 1. Add an entry "Automatic (by page format)" to the top of the paper size
> list and make that the default.
> I think this is the most elegant solution.  It will be obvious to users that
> page size is being handled for them.  If someone manually changes their
> paper size from this automatic setting, we should actually honor it.  We can
> then remove "Use only paper size from print preferences" from the options
> tab.
> 
> 2. Gray-out the Paper size drop-down.
> If the intended behavior is to not use that field, we should make it
> obvious.  Graying-out the drop-down lets users know that it's not being
> used.  Unfortunately, this might cause other complications.  In special
> cases, like brochure printing, the page size IS honored.  Well, brochure
> printing currently ignores your page size the first try, but I recently
> reported bug 81065 on that issue.  Basically, a user would have to either
> enable brochure printing before selecting a different paper size or they
> would have to first check the setting that enables the override.
> 
> 
> * The setting "Use only paper size from print preferences" is far away from
> the field that it modifies.  If checking this box is required for the paper
> size drop-down to do anything, it should be adjacent to the drop-down.  I
> would suggest putting the toggle right above Paper size on the "Paper" tab
> of Properties.  I know this is prime real estate and probably would require
> the UX Committee's input, but I think it'd be worth it, we're keeping the
> current behavior.
> 
> 
> * "Use only paper size from print preferences" is worded in a way that means
> nothing to me.  I've seen this option many times, but incorrectly
> interpreted it.  It should be changed to something like "Allow print dialog
> to change paper size."
> 
> 
> * There is no way to set a default policy for LO, through settings.  I would
> expect this to be a setting found under Tools -> Options -> Writer -> Print,
> under the "Other" section.  This is where the option "Paper tray from
> printer selection" exists already.
> 
> 
> This also opens up the discussion for what Writer should actually do with
> the request for larger/smaller paper than is set up with the page format. 
> Draw, Impress, and Calc all have ways to scale print jobs to fit different
> sized paper using "Fit to Width" or "Fit to page" options.  Writer should
> have the same ability.  Of course, this will need to be reported elsewhere
> as an enhancement request.

Thank You. Excellent summary of the issue. I agree with your first suggestion.
Comment 14 tmacalp 2016-02-04 03:09:32 UTC
(In reply to KDM from comment #13)
> (In reply to tmacalp from comment #10)
> > ...
> > My recommendation for this particular issue is to either...
> > 1. Add an entry "Automatic (by page format)" to the top of the paper size
> > list and make that the default.
> > I think this is the most elegant solution.  It will be obvious to users that
> > page size is being handled for them.  If someone manually changes their
> > paper size from this automatic setting, we should actually honor it.  We can
> > then remove "Use only paper size from print preferences" from the options
> > tab.
> > 
> > 2. Gray-out the Paper size drop-down.
> > If the intended behavior is to not use that field, we should make it
> > obvious.  Graying-out the drop-down lets users know that it's not being
> > used.  Unfortunately, this might cause other complications.  In special
> > cases, like brochure printing, the page size IS honored.  Well, brochure
> > printing currently ignores your page size the first try, but I recently
> > reported bug 81065 on that issue.  Basically, a user would have to either
> > enable brochure printing before selecting a different paper size or they
> > would have to first check the setting that enables the override.
> > ...
> 
> Thank You. Excellent summary of the issue. I agree with your first
> suggestion.

Thanks.  Unfortunately, as of LO 5.0.X, my suggested option #2 was implemented with exactly the complication I saw it coming with.  I've since opened bug 94342 (PRINTING: Printing certain page layouts (brochure/multiple pages-per-sheet) should enable fields for setting page size/orientation) to address that quirk.  I've also opened bug 94343 (UI: Move "Use only paper size from printer preferences" to print properties dialog).  I guess I'll add those to the see-also list.