Bug 72070 - Other: Page size when printing
Summary: Other: Page size when printing
Status: RESOLVED DUPLICATE of bug 67576
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-11-27 13:24 UTC by M Greig
Modified: 2015-12-15 10:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description M Greig 2013-11-27 13:24:20 UTC
Problem description: 
Print preview (and printout) cannot be changed from document page size, regardless of other print options

Steps to reproduce:
1. ....Create multi-page document with A5 page size
2. ....In print dialogue select 2 pages per sheet OR select brochure
3. ....In printer properties select A4 paper size

Current behavior:
Print preview will still show A5 paper size, and printout will reduce the multiple pages to fit on A5

Expected behavior:
Preview should show A4 paper dimensions, printout should have 2 full size A5 pages per A4 sheet
              
Operating System: openSUSE
Version: 4.1.3.2 release
Last worked in: 3.6.7.2 release
Comment 1 Benjamin 2013-12-07 21:03:01 UTC
This bug also exists in Writer 4.2 beta2 under Windows. Please fix it.
Comment 2 KDM 2013-12-12 20:32:21 UTC
Yes, I'm  Same behavior as described, printing from Writer running on Win7. Changing the size in the 'Properties' dialog does not effect the page size in the 'Print' dialog or the actual printout. This bug/regression has forced me to revert to an older edition of LibreOffice. It makes LO unusable for purposes of my job.
Comment 3 M Greig 2013-12-12 22:57:25 UTC
OK.  It now appears that "they" have added an extra tick-box on the Options tab of the LibreOffice print dialogue, where you can tick "Use only paper size from printer preferences".  If you do this, then the Print Preview (and the printout) should behave as they used to.  The change wasn't exactly highlighted in the release notes (! :) ), but it has a certain logic to it, and I'm now using 4.1.3 happily.
Comment 4 Owen Genat (retired) 2013-12-22 00:25:35 UTC
Added Caolán McNamara to CC List to determine how best to resolve this bug. Commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=f937ef20f57b306191f7583c2d47b5ad3f2a73ee which was made for bug 61186, seems consistent with what is observed / described here. Should this report be RESOLVED as NOTABUG?

I tested the Print dialog behaviour with a basic 4-page A5 document with all pages in portrait orientation. Under Ubuntu 10.04 x86_64 running In v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a the General tab > printer Properties... (HP LaserJet 4050TN exposed via CUPS) > initially shows a Paper Size of A4 (presumably obtained from a general setting such as the locale or printer). This is not reflected in the preview (shows A5) and is a change in behaviour from prior versions (which appear to obtain the paper size from the document). 

As indicated in comment #0 and comment #3 in the Page Layout tab > changing Pages per sheet or selecting Brochure uses the initially displayed paper size (A5) and adjusts the preview accordingly by resizing each instances on the n-up copy. It is necessary to select Options tab > "Use only paper size from printer preferences" to obtain the expected preview. 

(In reply to comment #3)
> The change wasn't exactly highlighted in the release notes (! :) ), 
> but it has a certain logic to it, and I'm now using 4.1.3 happily.

Yes. It is not possible to list every change in the release notes. https://wiki.documentfoundation.org/ReleaseNotes/4.1#Bug_fixes_.2F_commits indicates the sheer number of bug fixes and commits is difficult to translate into a concise list of feature changes. Even so, I do feel the release notes for LO are among the best out there and concerted efforts are made to ensure this is the case (I say this as someone who is not a developer).
Comment 5 retired 2013-12-23 13:17:42 UTC
Setting this one here to WORKSFORME as of comment  #3.

Re-open to UNCONFIRMED if you disagree.
Comment 6 Michael Stahl (CIB) 2014-01-30 22:45:27 UTC

*** This bug has been marked as a duplicate of bug 67576 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 10:53:47 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]