Bug 67727 - PRINTING: Paper Size and Orientation Fail in Brochure and Multi-Up Printing
Summary: PRINTING: Paper Size and Orientation Fail in Brochure and Multi-Up Printing
Status: RESOLVED DUPLICATE of bug 67576
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 67729 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-04 03:46 UTC by bach_leipzig
Modified: 2014-01-30 22:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Steps to reproduce Bug. (26.19 KB, application/vnd.oasis.opendocument.text)
2013-12-24 00:54 UTC, KDM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bach_leipzig 2013-08-04 03:46:33 UTC
Problem description: 
When trying to print brochures or multi-up pages using Letter sized landscape paper, the print preview and actual printing fails.

Steps to reproduce:
1. Start a new text document
2. Set the page size to 5.5x8.5
3. Paste or type in some text that runs onto both pages
4. Go to the print dialog
5. Preview incorrectly switches to A5 paper size
6. Set page layout to either brochure or 2-up
7. Attempt to change size/orientation to letter landscape (it fails)

Current behavior: Have tested on both Linux and Windows with similar results. OpenOffice4 which uses a similar printing dialog does not seem to exhibit this bug. There have been problems like this since LibreOffice 3.5 or so, but certain combinations of button clicks have previously been able to work around it. I found no workaround this time.

Expected behavior:
One should be able to print two Organizer L (5.5x8.5) sheets side by side on a letter sized landscape sheet. Printing brochures or 2-up pages on letter landscape paper is a common printing task that seems to be broken in the current version.
Operating System: All
Version: 4.1.0.4 release
Comment 1 D. Hugh Redelmeier 2013-08-14 16:32:54 UTC
*** Bug 67729 has been marked as a duplicate of this bug. ***
Comment 2 KDM 2013-12-24 00:54:07 UTC
Created attachment 91167 [details]
Steps to reproduce Bug.

I apologize that my description is pretty wordy.
Comment 3 KDM 2013-12-24 01:10:35 UTC
In the comments to Bug 67903 I found the suggestion from Karl Relton to select the "Use only paper size from printer settings" option, and this does work for me! Many Thanks! 

Now, if I can set things up so that is the default for all my templates...

Thanks!
Comment 4 bach_leipzig 2014-01-01 15:38:09 UTC
Thank you for pulling those threads together! It sounds like you were fighting exactly the same battles that I was. I had searched nearly a year for an answer to this and had all but given up on using Libreoffice anymore. But it appears that I too can get the results I want checking "use only paper size from printer settings."

Another thing I did in the course of trying to run this down was add a "Statement" sized paper definition to the printer PPD file. I don't know what the equivalent in Windows would be, but in Linux this seemed to solve the problem of LO "guessing" at the size you were intending. Instead of insisting I was trying to set A5 when I wasn't, LO recognized the 5.5x8.5 size after I added that definition to the PPD manually.
Comment 5 KDM 2014-01-04 17:14:43 UTC
(In reply to comment #4)
> Thank you for pulling those threads together! It sounds like you were
> fighting exactly the same battles that I was. I had searched nearly a year
> for an answer to this and had all but given up on using Libreoffice anymore.
> But it appears that I too can get the results I want checking "use only
> paper size from printer settings."
> 
> Another thing I did in the course of trying to run this down was add a
> "Statement" sized paper definition to the printer PPD file. I don't know
> what the equivalent in Windows would be, but in Linux this seemed to solve
> the problem of LO "guessing" at the size you were intending. Instead of
> insisting I was trying to set A5 when I wasn't, LO recognized the 5.5x8.5
> size after I added that definition to the PPD manually.

Useful suggestion. Thanks.
Comment 6 Michael Stahl (CIB) 2014-01-30 22:41:46 UTC

*** This bug has been marked as a duplicate of bug 67576 ***