Bug 68140 - FILESAVE: User fields displayed with "User Field NAME =" prefixed on converting to DOCX
Summary: FILESAVE: User fields displayed with "User Field NAME =" prefixed on converti...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.0.0
Keywords: filter:docx, implementationError
: 95089 100083 105153 (view as bug list)
Depends on:
Blocks: DOCX-Fields
  Show dependency treegraph
 
Reported: 2013-08-15 09:58 UTC by Robert Sharp
Modified: 2020-07-16 13:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of user fields (9.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-08-15 09:58 UTC, Robert Sharp
Details
Simple ODT file with user field (10.21 KB, application/vnd.oasis.opendocument.text)
2016-03-01 08:16 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Sharp 2013-08-15 09:58:27 UTC
Created attachment 84093 [details]
Example of user fields

I was testing out list styles and saving to docx when I noticed that the fields in the header were replaced with "User Field <name> =\n<value>" where <name> is the name of the user field and <value> its value.

Given that prior versions just seem to ignore user fields I guess this is looking like progress and someone maybe already knows about the problem?

Example docx file attached.
Comment 1 Buovjaga 2014-11-07 15:20:02 UTC
Reproduced by creating a user field in a new document and saving as docx.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 8b21b5cbe78945b27525b4ce78ae3d981f90590f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-06_03:55:51
Comment 2 Buovjaga 2015-01-07 18:52:47 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-01-07 20:02:18 UTC
Did a little poor man's bibisecting:

The problem doesn't yet exist in:
LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1

The problem appeared in:
LibreOffice 3.4.0 
OOO340m1 (Build:11)
Comment 4 QA Administrators 2016-01-17 20:03:33 UTC Comment hidden (obsolete)
Comment 5 Kevin Suo 2016-03-01 08:16:48 UTC
Created attachment 123102 [details]
Simple ODT file with user field

Bug still exists in:
Version: 5.1.1.2 (x64)
Build ID: fe4d9e69c82c6ee6db3c27cd5e2d47558afa80ac
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: zh-CN (zh_CN)

Steps to reproduce:
1. Save the attached simple odt file as DOCX.
--> Unwanted "User Field NAME =" added to user field.

"User Field" = Insert -> Fields -> More Fields -> Variables -> User Fields

It works for other fields such as page numbers, subject etc, but broken for User Field .
It works OK when save as DOC format.
Comment 6 Kevin Suo 2016-03-01 08:18:27 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2016-05-27 07:47:23 UTC
marking as duplicate of the oldest I can find..

*** This bug has been marked as a duplicate of bug 67207 ***
Comment 8 Timur 2017-11-27 12:13:15 UTC
This is Implementation error, started from LO 3.3. Never worked.
Comment 9 Timur 2017-11-27 12:15:44 UTC
*** Bug 95089 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2017-11-27 12:16:50 UTC
*** Bug 100083 has been marked as a duplicate of this bug. ***
Comment 11 QA Administrators 2018-11-29 03:52:44 UTC Comment hidden (obsolete)
Comment 12 Roman Kuznetsov 2018-12-24 19:33:17 UTC
still repro in

Версия: 6.2.0.1 (x64)
ID сборки: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded
Comment 13 Kevin Suo 2020-01-31 14:43:49 UTC
Just for the record, the following commit seems to try fixing this bug:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=676862bb8aa043f116615e5d0dac59254eaa8138

author	Miklos Vajna <vmiklos@collabora.com>	2020-01-30 10:21:08 +0100
committer Miklos Vajna <vmiklos@collabora.com>	2020-01-30 11:06:20 +0100
commit	676862bb8aa043f116615e5d0dac59254eaa8138 

Need testing.
Comment 14 Kevin Suo 2020-02-01 03:55:25 UTC
I confirm that this is fixed by commit 676862bb8aa043f116615e5d0dac59254eaa8138.
Comment 15 Timur 2020-07-16 13:23:55 UTC
*** Bug 105153 has been marked as a duplicate of this bug. ***