Bug 68160 - "View - Task Pane" menu missing in Calc, Writer
Summary: "View - Task Pane" menu missing in Calc, Writer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.1.1 rc
Hardware: Other All
: medium normal
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:4.1.5
Keywords:
: 68405 69707 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-15 18:17 UTC by clio
Modified: 2013-12-13 12:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2013-08-15 18:17:19 UTC
Menu command "View - TaskPane" missing in Impress, Calc, Writer. It should be present in Calc and Writer when extensions that use taskpane are installed. These extensions are Watching Window (http://extensions.openoffice.org/project/watchingwindow) and Writer Copy Color (http://extensions.libreoffice.org/extension-center/writer-copy-color).
Comment 1 thackert 2013-08-19 16:51:08 UTC
Hello clio, *,
I have tested your bug with Impress only, but can confirm your bug with LO Version: 4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 as well as with Version: 4.1.2.0.0+ Build ID: 9c0b035c617b0ee4095e673e756d0a93df7864a
TinderBox: Linux-x86_64@31-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-08-16_00:12:39 and installed Germanophone help- as well as langpack under Debian Testing AMD64 ... :( So I will set the status to "New".

But I am not sure, if it is really an Extension bug, as it is in Impress as well ... :( And as LO' own help has an entry for "View - Task pane", it seems to be more than an Extension bug, or am I wrong? Should this not be either an UI or an general LO bug? Maybe some QA expert and/or developer can help here ... ;)
Thanks for your bug report
Thomas.
Comment 2 joseph.bylund+bugzilla 2013-09-06 21:10:28 UTC
*** Bug 68405 has been marked as a duplicate of this bug. ***
Comment 3 Maxim Monastirsky 2013-09-23 20:09:26 UTC
*** Bug 69707 has been marked as a duplicate of this bug. ***
Comment 4 Oliver 2013-09-24 07:21:12 UTC
I think it must be a more general bug, as even without the above mentionned extensions, in impress the task pane is necessary to manage animations and IMHOP there should be a menu point "show tasks pane" in the View menu point

Cheers

Oliver
Comment 5 Maxim Monastirsky 2013-09-24 07:46:35 UTC
*** Bug 69707 has been marked as a duplicate of this bug. ***
Comment 6 clio 2013-10-06 21:18:22 UTC
As turned out, there is a setting in Tools/Options.../Advanced menu to enable sidebar. The checkbox says: "Enable experimental sidebar (on restart)".
Comment 7 clio 2013-10-07 07:45:03 UTC
Not sure, but maybe this is still a bug. If Sidebar is disabled by default, then the TaskPane should be enabled. For now, it seems, that TaskPane doesn't function properly. I tried to show/hide it with macros, using dispatcher  .uno:TaskBarVisible command. But this command does nothing. As for the sidebar, new command .uno:Sidebar is used, but it works only when Sidebar is enabled in experimental features.
Comment 8 Oliver 2013-11-12 10:32:07 UTC
I think that there should be a menu point in the View menu point to switch on or off the Tasks side bar, as there is for the left side slides side bar, that would seem logical to me

Cheers

Oliver
Comment 9 Maxim Monastirsky 2013-12-05 21:35:51 UTC

*** This bug has been marked as a duplicate of bug 72371 ***
Comment 10 Rob Snelders 2013-12-11 21:35:29 UTC
This is partly solved in https://gerrit.libreoffice.org/#/c/6943/

Only for Impress it is rolled back.

Adding Eike for this problem
Comment 11 Eike Rathke 2013-12-11 22:20:29 UTC
grr.. I didn't find a way in Calc to actually enable a task pane so didn't revert that part as well, didn't take extensions into account.
Comment 12 Eike Rathke 2013-12-11 23:15:34 UTC
Pending review for 4-1 at https://gerrit.libreoffice.org/7042
Comment 13 Eike Rathke 2013-12-12 12:12:52 UTC
Please note that these extensions use unpublished API and will probably cease to work with LibreOffice 4.2
Comment 14 Commit Notification 2013-12-12 14:34:26 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c0ac90b4864d5eee401b54cdcd54e29ae4ddc53&h=libreoffice-4-1

fdo#68160 Revert "Resolves: #ii122335# Disabling the old task pane"


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.