Bug Hunting Session
Bug 69011 - How to Induce (and Fix) Character Corruption if OpenGL not used (disable and re-enable anti-aliasing)
Summary: How to Induce (and Fix) Character Corruption if OpenGL not used (disable and ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OpenGL KDE
  Show dependency treegraph
 
Reported: 2013-09-06 02:46 UTC by John L. ten Wolde
Modified: 2019-08-12 19:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John L. ten Wolde 2013-09-06 02:46:38 UTC
Hi all.  I hope this discovery proves useful.  It seems that activating font hinting under KDE induces character corruption identical to that described in Bugs 60537 and Bug 60840 with both the opensource Radeon and Nouveau drivers.  It may also destabilize (and eventually hard lock) a system using the proprietary Nvidia driver while LO is running.  I do not have a Radeon card new enough to test behaviour of the proprietary ATI/AMD driver.

I'm using LO 4.0.4.2 on Mageia 3 (GNU/Linux) with KDE 4.10.5.

TO INDUCE THE BREAKAGE:

While LO is *not* running, open KDE System Settings and navigate to "Application Appearance" > "Fonts"

Set "Use anti-aliasing" to "Enabled" and click "Configure..."

Activate "Use sub-pixel rendering" and "RGB" (I'm not sure it matters what you pick) and lastly, set "Hinting style" to "Full".

Apply these changes and start LO Writer.

Open a multi-page ODT file or select a long topic from the Help documentation, and mouse wheel up and down on the text.

I'd be surprised if you *don't* see corruption identical to that in the screencaps provided in Bug 60537 and Bug 60840.

Note that in my tests nothing except LO misbehaved with these settings applied.


TO UNDO THE BREAKAGE:

Go back in KDE System Settings, click the "Configure..." button at the end of the "Use anti-aliasing" line again.

Deactivate every option and click "OK". Apply these changes.

From the drop-box to the right of "Use anti-aliasing" select "Disabled". Apply this change. (In my tests, skipping this step prevented hinting from being completely deactivated for some reason).

Now, from that same drop box select either "System Settings" or "Enabled" (but don't touch the "Configure..." dialogue again). Apply this change.

Start LO Writer as above.  Corruption should be cleared.

That you have to first disable anti-aliasing altogether before re-enabling it might suggest a bug in KDE's implementation of font hinting, but I can't really speak to that, nor can I speak to behaviour under Gnome as I never use it.
Comment 1 John L. ten Wolde 2013-09-06 02:57:06 UTC
I should add I was able to reproduce all of the above identically on an x86 Radeon system, and x86_64 Radeon system, and on an x86_64 Nvidia system.
Comment 2 ign_christian 2013-09-30 02:07:47 UTC
Hi John, probably different case but please see Bug 69342. Have you tried Xrender instead of OpenGL?
Comment 3 John L. ten Wolde 2013-09-30 20:54:53 UTC
Hi Christian.  Thanks, but yeah, I'm sure Bug 69342 is unrelated.  I've always used the ogygen-gtk theme in KDE4 and never experienced corruption of the GUI.

XRender does not meet my needs in general, and IIRC made no difference regarding the issue related to font hinting and/or sub-pixel rendering.

Lastly I should add that I've determined the occasional hard lock I've been experiencing with the NVidia proprietary driver has nothing to do with LO.
Comment 4 ign_christian 2014-07-05 09:03:24 UTC
Hello John..just a ping since it's been reported months ago. Does it still happen in 4.2.5.2 or 4.3.0.2 ?

If resolved please change status to RESOLVED WORKSFORME, unless UNCONFIRMED & provide additional info regarding current condition if any.
Comment 5 John L. ten Wolde 2014-07-14 04:17:33 UTC
Hi Christian,

Unfortunately, yes, I can confirm that the behaviour has neither changed nor the problem been resolved.  Tested on my x86_64 machine with 4.2.5.2 release.

Changing to UNCONFIRMED.  Nothing further to report.
Comment 6 Daniel Pastushchak 2014-12-12 18:19:14 UTC
Could not reproduce. I'm using Ubuntu 14.10 with KDE(4.14.1) and LibreOfficeDev Version: 4.5.0.0.alpha0+
Build ID: dad173d9588e6abc2a465198b7d2881d4629246a
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-10_22:53:28
Comment 7 John L. ten Wolde 2014-12-12 20:24:08 UTC
Thanks Daniel.  I hope this means things have gotten sorted.  This issue still adversely affects me at this time with my latest (yet older than your) packages:

Mageia 4; KDE 4.12.5; and LibreOffice Fresh 4.3.4.1
Comment 8 Buovjaga 2014-12-12 21:50:22 UTC
@John: you could try a master build from here: http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF-dbg/

The debug builds are pretty big, 6 GB unpacked, but you can run ./soffice directly from the program subfolder.
Comment 9 Buovjaga 2015-01-21 06:31:56 UTC
I don't know, if trying in a virtual machine is enough for this, but I could not reproduce in Kubuntu 14.10 64-bit, LibO Version: 4.3.3.2
Build ID: 430m0(Build:2)
Comment 10 retired 2015-02-08 10:25:22 UTC
John, does this issue persist with LO 4.4?
http://www.libreoffice.org/download/libreoffice-fresh/

After providing that info please back to UNCONFIRMED
Comment 11 John L. ten Wolde 2015-02-09 21:04:22 UTC
@foss

Yes, unfortunately the issue persists without change.  I just checked on my i686 system.

Mageia 4; KDE 4.12.5; and LibreOffice Fresh 4.4.0.3


I still wonder if the problem isn't actually with KDE, but if that is the case, LO is the only software I've found to be adversely effected.  Mageia 5 should be out in a month or so sporting KDE >= 4.14.3.  Maybe that will make a difference.
Comment 12 nomnex 2015-04-05 04:38:26 UTC
Hello, could you please read my reply in bug 58358, comment 43 and possibly merge these two reports which appear to be identical? Thanks again to John for this! Prior to your last comment, I simply could not use LO at all.
Comment 13 John L. ten Wolde 2015-04-06 21:10:39 UTC
@nomnex

Hi.  I'm delighted to hear my discovery helped you, but I'm not sure what you mean by "merge" the two bugs.

Whatever is causing this issue might possibly depend on or (conversely) be blocking bug 58358, but I'm in no way qualified to determine either case.
Comment 14 John L. ten Wolde 2015-04-06 21:47:29 UTC
Some interesting new developments:

1) I can confirm the issue described here and its workaround persists after updating to 4.4.2.2.

2) nomnex has confirmed the workaround on two Fedora machines using LXDE and XFCE, so whatever the problem, it is not exclusive to KDE (see bug 58358, comment 43).  I am therefore marking as NEW and removing "needsKDE" from the Whiteboard.

3) After the update to 4.4.2.2, I ran across the OpenGL* settings new to the 4.4.x branch.  To my amazement, activating OpenGL causes windows to redraw without error on mouse scroll even with hinting/sub-pixel rendering enabled (i.e. seems to resolve the issue), but unfortunately it also breeds a whole hornets' nest of other troubles including crashes to desktop, screen freezes while editing, plus bug 88747.


* Tools > Options > LibreOffice > View > "Use OpenGL for all rendering"
Comment 15 John L. ten Wolde 2015-11-03 20:50:47 UTC
Giving this an informational bump to report that this issue still persists without OpenGL active in 5.0.3.2 just as I described in comment #0. Activating OpenGL (as per remark [3] in comment #14) seems to resolve it, but I see a lot of tearing (especially on my old x86 box) likely because hardware acceleration won't activate.

I look forward to the day hardware acceleration works with OpenGL.
Comment 16 QA Administrators 2017-11-02 08:44:29 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug