Bug Hunting Session
Bug 70287 - Saving a document as certain file types does not populate "History" in KDE Plasma Kickoff menu
Summary: Saving a document as certain file types does not populate "History" in KDE Pl...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: needsKDE kde4
Keywords:
: 114698 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2013-10-08 16:02 UTC by Scott Baker
Modified: 2019-04-03 20:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Baker 2013-10-08 16:02:01 UTC
I use the "Recently Used" files section of the KDE Start menu to to view the most recently used/saved files in my applications. Libre Office does not populate the KDE "Recently Used" menu when I save a file. It populates the internal LO "Recently Used" menu, but not the KDE one.

Seeing the files at the KDE level would be EXTREMELY helpful.

Steps to reproduce:

1) Save a new or existing document
2) Notice that the file shows up in the LO recently used menu
3) Notice that the file does *NOT* show up in the KDE recently used menu

I'm running Fedora 19, KDE 4.11.1 and LibreOffice 4.1.2.3
Comment 1 ign_christian 2013-10-11 09:08:18 UTC
Not reproducible with LO 4.0.4.2, Kubuntu 12.04 32bit, KDE 4.11.1
Comment 2 Marco Menardi 2014-01-04 17:56:18 UTC
Reproducible with 4.1.4~rc2 and 4.2.0 rc1, kde 4.12 kubuntu 12.04
Comment 3 Julien Nabet 2015-02-15 14:45:51 UTC
It seems that depending on file type, the file won't be in recent docs.
I'm waiting a feedback to be sure, but for example, template files won't be in recent docs.

Do you reproduce this with an plain odt file + recent LO version? (last stable one is 4.3.5 and 4.4.0 has just been released)
Comment 4 Nis Jørgensen 2015-07-13 21:48:38 UTC
Testing using LO 4.4.3.2, KDE 4.14.3

Saving text document as odt: Appears in "Recently used"
Saving text document as doc: Does not appear
Saving spreadsheet as ods: Does not appear
Saving spreadsheet as xls: Does not appear

So confirming the bug, and providing info requested by Julien Nabet
Comment 5 Buovjaga 2015-07-29 16:57:43 UTC
NEW per comment 4.
Comment 6 Buovjaga 2015-07-29 16:59:04 UTC
Lowering priority and severity.
Comment 7 QA Administrators 2016-09-20 10:20:49 UTC Comment hidden (obsolete)
Comment 8 Marco Menardi 2016-09-20 19:17:22 UTC
Bug still present, I've Debian GNU/Linux Sid 64 bit, KDE Plasma Desktop 5.7.4, LiBo 5.2.1.
I've tried creating a new file in Writer and saved as odt, then a new file in Calc and saved as ods, but neither were then in the "most recent" list.
I've tried with KWrite to create and save a new text document, and it worked (so is not Kde broken).
Note that I've also the "libreoffice-kde" integration package installed.
Comment 9 QA Administrators 2017-10-23 14:12:12 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2019-01-01 18:44:20 UTC
Same story with the new kde5 backend.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 January 2019
Comment 11 Michael Weghorn 2019-03-28 22:42:44 UTC
Is an entry created for any other KDE application when it saves a file? If so, can you give any examples?

At least Okular and Kate also didn't create any entries there in a quick test of mine.

Entries in that "History" are created whenever a file is double-clicked from Dolphin, and that seems to be the case no matter what application is used to open the file, i.e. it works for odt files opened by LibreOffice in the same way as for text files opened by Kate or PDF files opened by Okular.

No idea whether that's the way this is supposed to work (would probably have to check the Plasma source code), but at a quick glance it seems to me like LibreOffice was behaving just the same way as other KDE apps...
Comment 12 Buovjaga 2019-03-29 17:22:03 UTC
(In reply to Michael Weghorn from comment #11)
> Is an entry created for any other KDE application when it saves a file? If
> so, can you give any examples?
> 
> At least Okular and Kate also didn't create any entries there in a quick
> test of mine.
> 
> Entries in that "History" are created whenever a file is double-clicked from
> Dolphin, and that seems to be the case no matter what application is used to
> open the file, i.e. it works for odt files opened by LibreOffice in the same
> way as for text files opened by Kate or PDF files opened by Okular.
> 
> No idea whether that's the way this is supposed to work (would probably have
> to check the Plasma source code), but at a quick glance it seems to me like
> LibreOffice was behaving just the same way as other KDE apps...

You are right, we have misunderstood the behaviour. Thanks.
Comment 13 Michael Weghorn 2019-04-03 20:27:46 UTC
*** Bug 114698 has been marked as a duplicate of this bug. ***