Download it now!
Bug 70531 - FILESAVE: Exporting PDF to existing file name returns two dialogs instead of one
Summary: FILESAVE: Exporting PDF to existing file name returns two dialogs instead of one
Status: RESOLVED DUPLICATE of bug 53530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2013-10-16 13:05 UTC by grofaty
Modified: 2019-12-03 21:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2013-10-16 13:05:52 UTC
Problem description: 

Steps to reproduce:
1. Open Writer and type in some text like: test
2. Click on "Export Directly as PDF" icon from toolbar.
3. In Export window type in some file name, e.g. mypdf.pdf
4. Open PDF file with PDF viewer. I use PDF XChange Viewer on Windows XP. Document opens without a problem. Leave file opened in PDF viewer.
5. In Writer type in some text like: test 2
6. Repeat step 2 and 3.
7. The dialog "File mypdf.pdf already exists. Do you want to replace it?" opens.
8. Click on Yes.
9. Error message appears: "Error saving the document Untitled1: Access to mypdf.pdf was denied." So far no problem. Perfectly OK message.
10. Click on OK button, to close dialog.
11. Nothing happens!
12. Click on OK button for second time. Dialog closes, but immediately new error message is displayed: "Error saving the document Untitled1: General Error. General input/output error."
13. Click on OK button and dialog finally closes.

Expected behavior:
There should be no steps 11, 12 and 13.

This problem is specially annoying if constantly working with PDF export and viewing the PDF file. Just clicking several times without real reason for.
              
Operating System: Windows XP
Version: 4.1.2.3 rc
Comment 1 Dominique Boutry 2013-10-23 16:39:16 UTC
Bug reproduced (LibO 4.1.2.3 on Win7 also)
Comment 2 tommy27 2014-11-02 09:00:33 UTC
still reproducible with 4.4.0.0.alpha1+
Build ID: 1baad070d8c2a38581cf33d803c5043f1974647f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-01_00:15:06
Comment 3 grofaty 2015-05-06 12:55:37 UTC
Retested in LibreOffice 4.4.2.2 on Windows 7 and problem still appears.
Comment 4 grofaty 2015-07-02 05:37:26 UTC
Retested on LibreOffice v.4.4.4.3 on Windows 7 and problem still persists.
Comment 5 grofaty 2015-07-06 10:51:14 UTC
Retested on LibreOffice v.5.0.0.2 on Windows 7 and problem still persists.
Comment 6 grofaty 2015-07-06 11:09:41 UTC
Retested on master on Windows 7 and problem still persists.

From Help | About dialog:

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 89c77994d4638c86635c70535fab6508e2f3d900
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-06_06:19:35
Locale: sl-SI (sl_SI)
Comment 7 QA Administrators 2016-09-20 10:14:38 UTC Comment hidden (obsolete)
Comment 8 Bob Smith 2016-11-03 19:11:19 UTC
I have tested this bug on version 5.2.2.2 and it is substantially the same as before.  Moreover, I have a different conclusion from the original bug reporter.  For the sake of completeness, I'll repeat the steps to reproduce:

1.  Open a PDF file in some other application such as PDF Reader.

2.  In LibreOffice Writer, choose from the application menu
    "File | Export as PDF..."

3.  In the "PDF Options" dialog, click on "Export".

4.  In the "Export" File Save As dialog, choose an existing file name
    and click on "Save" so as to trigger a conflict.

5.  In the "Confirm Save As" dialog, click on "Yes".

6.  The response from LibreOffice is three error dialogs all on the order of
    "Error saving ..." and the file is not saved.  The file reference in
    Step 1 must be closed and the whole process (Steps 2-5) repeated.

Instead of this error, I would prefer to see a "Retry/Cancel" dialog to allow the
user to close the file reference in Step 1 above and then Retry the file save.
Comment 9 grofaty 2016-11-04 08:27:11 UTC
I have tried to reproduce a problem in LibreOffice 5.2.3.3 and first 5 steps on Comment 8 appear but the last step 6 does not appear anymore in my special case! Why? I just get tired on having this multiple dialog problem in LibreOffice and I uninstalled "PDF XChange Viewer" and installed "Sumatra PDF" viewer that does not lock the PDF file when opening it and if PDF file is changed it automatically refreshes display with new file.

I can't confirm if this is still a problem, because PDF viewer which lock the PDF file when opening is required. But if other users can reproduce the problem, then it should probably be fixed.

P.S. I have marked "Ignore Bug Mail (never email me about this bug)", so I don't get notified for this bug anymore, because for me it is not a problem anymore.
Comment 10 tommy27 2016-11-05 13:13:39 UTC
bug still reproducibile under Win8.1 x64 using LibO 5.3.0.0.alpha1+
Build ID: 32bdc5097013e7efd9c85e1b8df697880e66e925
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_23:30:30
Locale: it-IT (it_IT); Calc: group

my default PDF Viewer is an old Adobe Acrobat 7 version.
Comment 11 QA Administrators 2017-11-06 15:37:26 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2019-12-03 14:12:38 UTC Comment hidden (obsolete)
Comment 13 Bob Smith 2019-12-03 16:49:45 UTC
(In reply to Bob Smith from comment #8)
> I have tested this bug on version 5.2.2.2 and it is substantially the same
> as before.  Moreover, I have a different conclusion from the original bug
> reporter.  For the sake of completeness, I'll repeat the steps to reproduce:
> 
> 1.  Open a PDF file in some other application such as PDF Reader.
> 
> 2.  In LibreOffice Writer, choose from the application menu
>     "File | Export as PDF..."
> 
> 3.  In the "PDF Options" dialog, click on "Export".
> 
> 4.  In the "Export" File Save As dialog, choose an existing file name
>     and click on "Save" so as to trigger a conflict.
> 
> 5.  In the "Confirm Save As" dialog, click on "Yes".
> 
> 6.  The response from LibreOffice is three error dialogs all on the order of
>     "Error saving ..." and the file is not saved.  The file reference in
>     Step 1 must be closed and the whole process (Steps 2-5) repeated.
> 
> Instead of this error, I would prefer to see a "Retry/Cancel" dialog to
> allow the
> user to close the file reference in Step 1 above and then Retry the file
> save.

I can confirm that on version 6.3.3.2 (x64) of LO, this bug no longer displays any spurious dialog.
Comment 14 Timur 2019-12-03 21:36:24 UTC
This looks like a duplicate of unresolved bug.

*** This bug has been marked as a duplicate of bug 53530 ***