Bug Hunting Session
Bug 70596 - master install set broken on Debian systems: dependency problems
Summary: master install set broken on Debian systems: dependency problems
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0 target:4.3.0
Keywords:
: 77396 78234 78852 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-18 04:53 UTC by Jean-Baptiste Faure
Modified: 2014-11-05 04:00 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
log of dpkg (50.17 KB, text/plain)
2014-01-09 13:56 UTC, Jean-Baptiste Faure
Details
log of dpkg in English (44.91 KB, text/plain)
2014-01-09 14:16 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-10-18 04:53:57 UTC
Hi,

There is a problem with the DEB files produced by the build system for the master. When installing them as a normal release (sudo dpkg -i etc.), I get the same error message several times. The message says that there is dependency problem.

English translation of French error message:
> dpkg: dependency problems prevent configuration of libreofficedev4.2 :
> libreofficedev4.2 depend on libreofficedev4.2-ure (<= 4.2.0.0.alpha0) ; but : The version of libreofficedev4.2-ure on the system is 4.2.0.0.alpha0-1.


If I compare the DEBs for LO 4.1.x and the DEBs for the master, I see that the /DEBIAN/control files set the dependency constraints differently. For example for the Math module (it's the same thing for others):
in LO 4.1.4.0.0+ : 
Version: 4.1.4.0.0-1
[...]
Depends: libobasis4.1-core01

in the master: 
Version: 4.2.0.0.alpha0-1
[...]
Depends: libobasis4.2-core01 (>= 4.2.0.0.alpha0), libobasis4.2-core01 (<= 4.2.0.0.alpha0)

I have the same problem with my own build and with the daily build from http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF/

I do not know where to look in the code to fix the problem.

Best regards. JBF
Comment 1 Thomas Hackert 2013-10-18 07:03:30 UTC
Hello Jean-Baptiste, *,
I can confirm this bug with Debian Testing AMD64 and LO Version: 4.2.0.0.alpha0+
Build ID: 6aa0488da21ef21b9da68253682b174f11f305f5
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-10-17_00:51:48 ... :(
I will change the status to new.
Sorry for the inconvenience
Thomas.
Comment 2 Stephan Bergmann 2013-10-18 07:46:52 UTC
The dependencies on both >= %PACKAGEVERSION and <= %PACKAGEVERSION were introduced into the setup_native/source/packinfo/packinfo_*.txt files with the fix for bug 65541.  But it looks like that %PACKAGEVERSION expands to a shorter value than what is actually used for the DEB Version, "4.2.0.0.alpha0" vs. "4.2.0.0.alpha0-1".

See the comment "There appears to be some confusion in those files between %PACKAGEVERSION and %ABOUTBOXPRODUCTVERSION, but those seem to always get identical values in instsetoo_native/util/openoffice.lst.in." [<http://cgit.freedesktop.org/libreoffice/core/commit/?id=d07cbe86f34ca6dfc6580b63879235c339831a5e> "http://cgit.freedesktop.org/libreoffice/core/commit/?id=d07cbe86f34ca6dfc6580b63879235c339831a5e"]  Maybe %ABOUTBOXPRODUCTVERSION started to expand to the longer value now, leading to the mismatch?
Comment 3 Stephan Bergmann 2013-10-18 08:02:22 UTC
(In reply to comment #2)
> See the comment "There appears to be some confusion in those files between
> %PACKAGEVERSION and %ABOUTBOXPRODUCTVERSION, but those seem to always get
> identical values in instsetoo_native/util/openoffice.lst.in."
> [<http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=d07cbe86f34ca6dfc6580b63879235c339831a5e>
> "http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=d07cbe86f34ca6dfc6580b63879235c339831a5e"]  Maybe
> %ABOUTBOXPRODUCTVERSION started to expand to the longer value now, leading
> to the mismatch?

Unlikely, as (a) ABOUTBOXPRODUCTVERSION and PACKAGEVERSION are still defined the same in instsetoo_native/util/openoffice.lst.in and (b) the "-1" suffix was already there in the 4.1 DEB Versions according to comment 0.

So might be a problem in EPM and/or our use of EPM, that DEB Versions get a "-1" suffix appended to the packinfo_*.txt "packageversion" value somewhere along the way, but which is not reflected in the corresponding version information encoded in packinfo_*.txt "requires" values?  Adding some people on CC who might be knowledgeable.
Comment 4 Commit Notification 2013-11-20 00:41:37 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=65a7e714292dbf4c5a2a4f5760f3b546d603c40c

fdo#70596 - fix version dependency for deb-packages



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Jean-Baptiste Faure 2013-11-20 13:06:41 UTC
Thank you very much Christian. With your fix I can install the master under Ubuntu without error messages from dpkg.

Sophie: good news for you :-)

Best regards. JBF
Comment 6 Commit Notification 2014-01-09 12:29:35 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4356aef48a8fcbd9dd019c0ca2d6a189d7332d0c

fdo#70596 - fix version dependency for linux package - 2nd try



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-01-09 12:33:02 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c002aa137860fc91be815eaf44a489c2653e39f9&h=libreoffice-4-2

fdo#70596 - fix version dependency for linux package - 2nd try


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-01-09 12:36:23 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28ad7024bb21ff27316c0af7ebd082506f555432&h=libreoffice-4-2-0

fdo#70596 - fix version dependency for linux package - 2nd try


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Jean-Baptiste Faure 2014-01-09 13:56:16 UTC
Created attachment 91747 [details]
log of dpkg

Hi Christian,

I am afraid that your patch broke something. When I install my release build of LO 4.2.1.0+ I get many error messages for dependency problems. 

I attached the log from dpkg on Ubuntu 13.10 x86-64
I did 2 trials, firstly I installed the new packages over the old ones, then I removed all LO 4.2.1 packages and tried again.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2014-01-09 14:02:05 UTC
Reopened according to my previous comment.

Best regards. JBF
Comment 11 Christian Lohmaier 2014-01-09 14:11:16 UTC
Thanks.

So while the first patch did only work for RC1 versions, the second/current one does work for all RCs, but still doesn't work for branch/master builds (as they have additional part in version-number)
Comment 12 Jean-Baptiste Faure 2014-01-09 14:16:52 UTC
Created attachment 91749 [details]
log of dpkg in English

Same log but in English. 

Best regards. JBF
Comment 13 Christian Lohmaier 2014-01-16 13:56:56 UTC
removing from the mab4.2 issue, as it won't occur for release-builds, only master/branch when there's the additional version element that isn't dealt with yet. (i.e. not only maj.min.mic.rel but maj.min.mic.rel.0+)
Comment 14 Jim Avera 2014-03-25 20:11:52 UTC
Hi, just wondering if any more headway has been made on fixing this in the master builds.

When installing a daily 4.2 build, I get many of the "dependency problems prevent configuration" errors described previously.   Ditto with master (4.3alpha)

Thanks.
Comment 15 Björn Michaelsen 2014-03-25 23:36:02 UTC
Note that you get a rather recent releases from https://launchpad.net/~libreoffice/+archive/ppa and even prereleases from https://launchpad.net/~libreoffice/+archive/libreoffice-prereleases
Comment 16 sophie 2014-04-22 14:49:52 UTC
*** Bug 77396 has been marked as a duplicate of this bug. ***
Comment 17 tim 2014-04-22 17:07:40 UTC
Hi,

I copy here my notes from my duplicate of this bug (#77396), for those wanting to carry on with daily builds:




I had, possibly foolishly, followed the normal README_en-US instructions, ie doing a "sudo dpkg -i *.deb" to install.

The instructions ate https://wiki.documentfoundation.org/Installing_in_parallel indicate that it's better to install as a normal user in a directory within the DEBS, using "for i in ../*.deb; do dpkg-deb -x $i . ; done"

Using this second technique the installation of 4.2.4.0 daily build (dated 14/04/14) succeeded.

So I guess that the fault (if it's agreed there is an issue) is the instructions within the daily build readmes.  It would help if these were omitted completely, and a URL to the wiki document above was supplied, or corrected for daily builds.
Comment 18 Olly Betts 2014-05-13 02:42:35 UTC
A simple fix for this would be to just append a '+' to the version in the generated upper bound dependency, so the dependencies would look like:

Depends: libreofficedev4.2-ure (>= 4.2.0.0.alpha0), libreofficedev4.2-ure (<= 4.2.0.0.alpha0+)

Since + sorts after - in dpkg version comparisons, this will achieve what's wanted here:

$ dpkg --compare-versions '4.2.0.0.alpha0-1' \<= '4.2.0.0.alpha0' && echo OK
$ dpkg --compare-versions '4.2.0.0.alpha0-1' \<= '4.2.0.0.alpha0+' && echo OK
OK
$ dpkg --compare-versions '4.2.0.0.alpha1-1' \<= '4.2.0.0.alpha0+' && echo OK

That's assuming that the dependency just needs a package with the same upstream version ("4.2.0.0.alpha0" in this case), or that you just never produce packages with a debian revision other than "-1".
Comment 19 Olly Betts 2014-05-13 23:38:45 UTC
Or if you want an exact version dependency, you can specify that using:

Depends: libreofficedev4.2-ure (= ${binary:Version})

The "${binary:Version}" is literal - it gets expanded by deb-substvars when the binary packages are assembled.
Comment 20 Christian Lohmaier 2014-05-15 12:11:25 UTC
*** Bug 78234 has been marked as a duplicate of this bug. ***
Comment 21 Jorendc 2014-05-18 10:00:30 UTC
*** Bug 78852 has been marked as a duplicate of this bug. ***
Comment 22 p_kongstad 2014-05-18 10:15:16 UTC
On 05/18/2014 12:00 PM, bugzilla-daemon@freedesktop.org wrote:
> Jorendc <mailto:jorendc@libreoffice.org> changed bug 70596 
> <https://bugs.freedesktop.org/show_bug.cgi?id=70596>
> What 	Removed 	Added
> CC 		p_kongstad@op.pl
>
> *Comment # 21 <https://bugs.freedesktop.org/show_bug.cgi?id=70596#c21> 
> on bug 70596 <https://bugs.freedesktop.org/show_bug.cgi?id=70596> from 
> Jorendc <mailto:jorendc@libreoffice.org> *
> ***Bug 78852  <show_bug.cgi?id=78852>  has been marked as a duplicate of this bug. ***
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>
Hi,

This has not been an issue for me in the past only on 4.3, so I disagree 
that this is resolved and a duplicate of 70596
Comment 23 Commit Notification 2014-05-21 15:41:45 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a95d12b547e2635e10aa074fe42f12a0ea151163

fdo#70596 dependency problem with debian packages for master/dev builds



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2014-06-02 09:54:26 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ffba8e88ac527e473ca74996c6a453f392e63f1&h=libreoffice-4-2

fdo#70596 dependency problem with debian packages for master/dev builds


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Ernest Bledsoe 2014-07-23 09:02:31 UTC
Hi,
This is so trivial I wasn't sure if I should report it, but when you enable the "Systray Quickstarter" in Linux, it doesn't work. Or it doesn't work with MY Linux.

I am using Zorin-OS version 8.

I have been using LibreOffice for quite some time, donated $10 awhile back and I have been very happy seeing how this software has developed. I am using it more than MS-Office.

Everything else is great.
Comment 26 Rene Engelhard 2014-07-23 11:28:18 UTC
and this is relevant to this issue how? correct it isn't.
Comment 27 Joel Madero 2014-11-05 04:00:51 UTC
This seems to be fixed - if I'm incorrect, apologies. Setting to RESOLVED->FIXED.