Bug Hunting Session
Bug 71075 - chart mangling on paste
Summary: chart mangling on paste
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
: 68249 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-10-31 07:25 UTC by Michael Meeks
Modified: 2015-12-15 11:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
a simple calc file with a chart. (13.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-31 07:25 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2013-10-31 07:25:56 UTC
Created attachment 88396 [details]
a simple calc file with a chart.

Create the world's simplest chart in calc (sample attached), copy/paste it to impress - to show off the latest numbers.

Notice the chart is completely mangled, geometry is busted, data is lost, looks totally different.
Comment 1 Michael Meeks 2013-10-31 07:29:45 UTC
Muthu - do you have some cycles to look at this ? my experience with chart copy/paste is -so- enduringly terrible that I suspect that there are zero unit tests at all for this functionality :-) I believe that this used to work in 4.0 anyhow :-)
Comment 2 Kevin Suo 2013-10-31 07:46:31 UTC
Tested and confirm in L.O. 4.1.3.2 Ubuntu 13.10 x86.

* CTRL+c and CTRL+v to another application (writer,impress,draw...), "x" and "y" are reversed, so data are loss.

* CTRL+c and "paste special (CTRL+v) -> StarObjectDescriptor(XML)" to another application (writer,impress,draw...), "x" and "y" are reversed.

* CTRL+c and "paste special (CTRL+v) -> GDIMetafile" to another application (writer,impress,draw...), everything is OK.

Maybe a regression but need confirm.
Comment 3 Kevin Suo 2013-10-31 09:45:07 UTC
changing version to 4.1.3.2.
Comment 4 Terrence Enger 2013-11-01 00:20:17 UTC
Subject to damage by retyping (because of Internet connection difficulties) the first bad commit in 4.0+ bibisect is commit 3057631, source hash bb5196b.
Comment 5 Michael Meeks 2013-11-01 17:54:39 UTC
Hi Markus, it looks like this may be related to:

commit 14fa5488a829936275f79a7693b13da55114220e
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Sun Jun 30 03:44:05 2013 +0200

    transpose "data in rows" ranges for internal data provider, fdo#62057
    
    This is an ugly hack but it at least works. This regression has been
    introduced by the merge from the AOO code. The order of calls during
    import is totally screwed and I have no idea how to properly fix all
    these problems without introducing new regressions.

:-) this also appears to break (quite badly) not just paste but importing those sheets too ...
Comment 6 Markus Mohrhard 2013-11-02 18:47:57 UTC
(In reply to comment #5)
> Hi Markus, it looks like this may be related to:
> 
> commit 14fa5488a829936275f79a7693b13da55114220e
> Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
> Date:   Sun Jun 30 03:44:05 2013 +0200
> 
>     transpose "data in rows" ranges for internal data provider, fdo#62057
>     
>     This is an ugly hack but it at least works. This regression has been
>     introduced by the merge from the AOO code. The order of calls during
>     import is totally screwed and I have no idea how to properly fix all
>     these problems without introducing new regressions.
> 
> :-) this also appears to break (quite badly) not just paste but importing
> those sheets too ...

So I just reverted this patch. I was not that happy with the patch as I have explained in the commit message and the patch is not important enough to break something for it.
Comment 7 Kevin Suo 2013-11-06 03:13:05 UTC
*** Bug 68249 has been marked as a duplicate of this bug. ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 11:03:08 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]