Download it now!
Bug 71076 - gdi metafile breakage on paste
Summary: gdi metafile breakage on paste
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium major
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.4.0 target:4.3.0.2 target:4.2.7
Keywords:
: 68940 68942 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-31 07:27 UTC by Michael Meeks
Modified: 2018-09-14 14:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2013-10-31 07:27:59 UTC
Grab from bug #71075 the test file:

https://bugs.freedesktop.org/attachment.cgi?id=88396

Now paste-as-GDI-metafile the data; notice that the chart x axis legends instead of being textual dates are numbers: not ideal :-)
Comment 1 Kevin Suo 2013-10-31 07:54:53 UTC
Tested and confirm in L.O. 4.1.3.2 x86.

Not only date format but also comma-seperated number formats are changed to general numbers. Text format seems not affected.
Comment 2 Kohei Yoshida 2014-06-12 19:47:44 UTC
As with any other chart bugs, this one is also hard-to-solve both conceptually and implementation-wise....

Workaround is to uncheck the "Source Format" in the number format dialog for the X-axis option dialog, then the format will get carried over just fine.
Comment 3 Kohei Yoshida 2014-06-18 14:35:11 UTC
Already spent close to a week on this.  Hopefully the end is near.
Comment 4 Kohei Yoshida 2014-06-18 16:29:07 UTC
This seemingly innocuous little mis-behavior is caused by a collection of many different issues each of which is non-trivial to solve... :-(
Comment 5 Kohei Yoshida 2014-06-18 19:25:23 UTC
Finally got to the bottom of this.  What a journey...
Comment 6 Francisco 2014-06-19 14:40:03 UTC
Thank you very much, Koei :-)
Comment 7 Commit Notification 2014-06-19 18:47:46 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1d38cb365543924f9c50014e6b2227e77de1d0c9

fdo#71076, fdo#71767: Preserve number formats when charts are copied.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Kohei Yoshida 2014-06-20 00:51:21 UTC
4.3 backport:

https://gerrit.libreoffice.org/9835
https://gerrit.libreoffice.org/9836
Comment 9 Commit Notification 2014-06-20 13:59:49 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01dd299bded81700bc976881c6ea954a09015f9f

fdo#71076: Write test for this.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-06-23 15:03:14 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22cd19eeeb476c40b68bb1ff040fce6103fdeba4&h=libreoffice-4-3

fdo#71076, fdo#71767: Preserve number formats when charts are copied.


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Kohei Yoshida 2014-06-23 16:08:41 UTC
Fixed in 4.3.
Comment 12 ign_christian 2014-06-26 16:41:52 UTC
*** Bug 68940 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2014-07-16 05:51:03 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=388f2fa9fcabe1b2adaff282fa9509216f3af6de&h=libreoffice-4-2

fdo#71076, fdo#71767: Preserve number formats when charts are copied.


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Kevin Suo 2014-07-16 06:00:06 UTC
*** Bug 68942 has been marked as a duplicate of this bug. ***