Bug Hunting Session
Bug 71278 - UI mouse pointer disappears during presentation and does not come back after exiting presentation
Summary: UI mouse pointer disappears during presentation and does not come back after ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0 target:4.4.4
Keywords: preBibisect, regression
: 75157 81929 84049 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2013-11-05 19:18 UTC by Vossman
Modified: 2015-12-17 11:00 UTC (History)
17 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vossman 2013-11-05 19:18:23 UTC
Mouse pointer disappears during presentation

Steps to reproduce:
1. Open new presentation
2. Click present slideshow (F5)
3. Mouse pointer should be present
4. Wait about 60 seconds
5. Slightly move mouse
6. Mouse pointer disappears
7. Exit presentation (ESC)
8. Mouse pointer still missing

Expected results:
After exiting presentation, mouse pointer should be available for use

Work-around:
Try to maneuver "hidden" mouse to another application or desktop and click. Opening new application restores the mouse. 

I think it is mac only related. I am running Mac OS X 10.8.5 on a white MacBook using 4.1.3rc2 (release?). The wait time varies, but if I wait it always happens. I think it started happening in 4.1.3 (or 4.1.2), but definitely did NOT happen in 4.0 series.
Comment 1 retired 2013-11-21 10:34:09 UTC
Wow, this is an ugly bug.

Confirming on OS X 10.9 and LO Version: 4.2.0.0.alpha1+
Build ID: d93433ba1181f5d8f6ded0ed0c103df10ebb1f22
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-20_13:04:00

Setting to NEW.

Raising importance to "High" since this makes Impress pretty unusable and forces to user the restart LO which makes for a pretty bad user experience.

The mouse cursor is still there when switching away from LO, but in Impress the cursor is gone. The mouse still triggers actions when hovering around but without a cursor that isn't really worth a lot.
Comment 2 Peter Hedlund 2014-02-25 21:52:38 UTC
Still present in 4.2.1.1 on Mavericks 10.9.1.
Comment 3 Joel Madero 2014-03-03 17:06:40 UTC
Vossman - can you try to track down the pre-release version that this was introduced in? 

http://downloadarchive.documentfoundation.org/libreoffice/old/

You can install/uninstall from there and then tell us the exact version that it was introduced in - that'll help narrow it down. Thanks!
Comment 4 Vossman 2014-03-03 18:08:30 UTC
4.0.6.2: GOOD - mouse disappears, but reappears after exiting

4.1.0.0.beta1: mouse disappears
4.1.1.2: mouse disappears
4.1.3.2: mouse disappears
4.2.1.1: mouse disappears
4.2.2.1: mouse disappears

here is my quick break down, apparently it was there from the start of 4.1 series.
Comment 5 Joel Madero 2014-03-03 18:10:41 UTC
With that info going to mark as a regression - thanks for the info!
Comment 6 Michael Stahl (CIB) 2014-03-11 12:21:22 UTC
adjust version according to comment #4
Comment 7 sophie 2014-03-12 12:15:32 UTC
*** Bug 75157 has been marked as a duplicate of this bug. ***
Comment 8 Anastasius 2014-04-10 16:43:05 UTC
Confirmed on Mac OS X 10.6.8, LibreOffice 4.2.2.1.

I found our that I can get the cursor back by moving the mouse far up (So I am sure that it is in the Mac's menu bar) and then clicking there.
Before knowing this, it made me crazy - I had to quit LO each time!
Comment 9 tommy27 2014-05-03 08:06:41 UTC
moving it to mab4.2 list since 4.1.x is END OF LIFE
Comment 10 helge 2014-06-15 19:40:41 UTC
Found as a good workaround to briefly hit the power button twice: this
brings the presentation almost instantly back and the cursor is repaired
(until the bug hits the next time).
Works for me on MacBook Pro OS X 10.9.1 with LibreOffice 4.2.4.
Comment 11 ign_christian 2014-07-31 08:55:59 UTC
*** Bug 81929 has been marked as a duplicate of this bug. ***
Comment 12 Mac Dude 2014-08-20 21:38:28 UTC
This bug is still present in 4.4.0.0.alpha2 nightly of July 11, running on 10.6.8.

Uli
Comment 13 Vossman 2014-09-01 02:26:25 UTC
4.2.6.3: mouse still disappears and does not return on OS X 10.9.4 and MBP retina.

Work around is to click on menu heading and open a dialog. Such as Format -> Character... Once a dialog has been opened mouse returns permanently.

Note it can take awhile for the mouse to disappear during the presentation. Also the mouse must be moved (in presenter mode) for it to actually disappear.
Comment 14 Kristian Rietveld 2014-09-16 17:04:03 UTC
I have seen this on OS X 10.6 and 10.9 as well with several LibreOffice 4.x releases. As a workaround I simply click on the global menu bar after exiting the presentation.
Comment 15 ign_christian 2014-09-19 05:34:36 UTC
*** Bug 84049 has been marked as a duplicate of this bug. ***
Comment 16 Antonio Goncalves 2014-11-30 17:57:23 UTC
The bug is still present in 4.3.4.1 on Mac OS 10.9.x but also on Mac OS 10.10.x (as I just updated to Yosemite)

Antonio
Comment 17 tommy27 2014-11-30 18:02:32 UTC
moving bug to mab4.3 list since 4.2.x is END OF LIFE
Comment 18 Evan Bontrager 2014-12-31 16:40:16 UTC
Mouse pointer / cursor continues to disappear within Presentation in release 4.3.5.2.
Bug 71278 ended with comment 
"tommy27 2014-11-30 18:02:32 UTC
moving bug to mab4.3 list since 4.2.x is END OF LIFE"

But bug could not be found in mab4.3  Was this dropped accidentally?  Remains a constant problem.  Later bug reports 75157, 81929, 84049 all refer back to 71278 which indicates is was at end of life.
Comment 19 Evan Bontrager 2014-12-31 16:41:25 UTC
(In reply to tommy27 from comment #17)
> moving bug to mab4.3 list since 4.2.x is END OF LIFE

Bug continues but looking through mab4.3 it could not be found as listed.  Was this bug moved for continued fix as indicated?
Comment 20 tommy27 2014-12-31 16:58:05 UTC
bug was already moved to mab4.3 list  weeks ago (see the "Blocks" field)

moreover when you changed the version field in an incorrect way and you did not pay attention to this alert: 

"You are changing the version of the bug to a later version. As the version field of the bug should show the earliest version manifesting the bug, please reconsider, if you really want to do this. Please do not change a version, because it also manifests in a later version. for details, please see the guidelines"

so I'm reverting version to the earliest version where it was reproduced
Comment 21 Louis.Steinberg39 2015-01-25 03:42:42 UTC
This bug has been around for a long, long time, and is very annoying.  Are there any plans to fix it???
Comment 22 Joel Madero 2015-01-25 06:09:37 UTC
@Louis - this isn't right on point (not trying to blame you) but it kind of points out the reality of bug fixing 

https://joelmadero.wordpress.com/2014/10/11/user-expectations-and-the-reality-of-our-community/

There is a bibisect request on this bug so it would help if someone would do that. If you need help doing so, feel free to jump into the QA chat for guidance: http://webchat.freenode.net/?channels=libreoffice-qa
Comment 23 Jonata 2015-02-04 10:55:48 UTC
This bug is still present on version 4.4.0.3
Comment 24 Vincent Boudry 2015-02-17 15:49:13 UTC
In my version 4.4.0.3 on Yosemite 10.10.2, the bug is still there 
but the cursor can be recovered by a right click (or control-click).

Vincent.
Comment 25 Stan Sporkistan 2015-02-17 17:54:48 UTC
This bug affects me too, running Mac OS X 10.6.8 & Impress 4.3.2.2.  This bug has been around for a while.

My workaround is to throw the (invisible) mouse pointer all the way to the top of the screen and to click on the menu bar, which causes the pointer to reappear.
Comment 26 Stan Sporkistan 2015-02-17 22:18:58 UTC
This bug has existed for a while and is very annoying.

My workaround is to throw the (invisible) mouse pointer to the top of the screen; clicking on the menu bar at the top of the screen restores the visibility of the pointer.
Comment 27 Dave Thomson 2015-04-12 10:18:04 UTC
This bug is still in place in version Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_

The suggested work around is not effective when trying to manage live material in the presentation - video's, web site links as clicking to recover the cursor moves the page on as well. One solution is to open the page menu (right click on the touch pad and then that brings the cursor back. Not very impressive though when trying to promote the value of open source to school teachers!

Its a pity that something like this cannot be sorted as it spoils the experience for users and watchers.
Comment 28 Matthew Francis 2015-04-12 12:14:02 UTC
Unfortunately there's no bibisect coverage for that region, and building source from that far back on modern OSX is not at all easy.

However, from reading through the commits between 4-0-branch-point and 4-1-branch-point I wonder if this one could have anything to do with it:

commit 8d351c59d4393aa37ab38139b3a741f15a49dbfe
Author: jorendc <joren.libreoffice@telenet.be>
Date:   Sun Apr 14 00:33:19 2013 +0200

    fdo#31082 cursor visible during impress presentation
    
    Change-Id: I8983676244d0b996c237cbfc487ed68a535803d1
    Reviewed-on: https://gerrit.libreoffice.org/3376
    Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org>
    Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Comment 29 Matthew Francis 2015-04-12 15:14:21 UTC
-> https://gerrit.libreoffice.org/15269
Comment 31 Commit Notification 2015-04-20 09:04:05 UTC
Matthew Francis committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=255884bd221d0521f5c99add4b9af8723668c300&h=libreoffice-4-4

tdf#71278 Fix cursor hiding in presentation mode

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Dave Thomson 2015-04-20 20:52:02 UTC
Just tried the patched version

Version: 4.4.4.0.0+
Build ID: db74d31a2416681cc35d9fe5fc2741ad29c6e695
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-4-4, Time: 2015-04-20_06:59:59
Locale: en_

Cursor still vanished after about 30 seconds and could only be retrieved by exiting and moving to top left of the screen - cursor reappeared.
Comment 33 steve -_- 2015-04-20 20:56:09 UTC
Dave you write your version is from 06:59h.

Matthew commited the patch at 11.xxh.

please retry with the next nightly build from tomorrow from http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/
Comment 34 bugzilla 2015-06-02 16:53:21 UTC
I was using LO v441 yesterday on my MacbookAir running OS X. The missing cursor prevented me doing any work on an LO presentation forwarded to me which had been created in MS Office XP under OS W2k. (Sorry, don't know which version of LO had been used to create it)

Today I found this bug report and updated to LO v433 then reloaded the presentation. Everything worked fine - cursor present throughout on both editing and in presentation mode, but when I exited LO I found I had no cursor in "Messages". I could restore cursor by clicking in the main menu bar.

I have since tried to duplicate the problem but it has not recurred and all now seems fine. However I thought I should report it in case others experience this or there maybe an issue when the new version is loaded for the first time?
Comment 35 steve -_- 2015-06-02 20:53:15 UTC
Whiteboard says fixed in 4.4.4 and 5.0.
So those versions should be tested. If anybody could report back if this is indeed fixed, that would be really helpful.
Nightlies for OSX are here: http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/current/
Comment 36 Robinson Tryon (qubit) 2015-12-17 11:00:36 UTC
Migrating Whiteboard tags to Keywords: (preBibisect)
[NinjaEdit]