Bug 72247 - EDITING: UNDO does not remove pasted images (from webpages)
Summary: EDITING: UNDO does not remove pasted images (from webpages)
Status: RESOLVED DUPLICATE of bug 39217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 84634 91747 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-02 20:53 UTC by lovejesus
Modified: 2016-05-13 06:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lovejesus 2013-12-02 20:53:25 UTC
Problem description: 
The UNDO feature (CTRL-Z) does not remove a pasted image which was inserted from a webpage.

Steps to reproduce:
1. go to some website with images (using Firefox 25.0.1)
2. select some text + an image
3. paste it into LibreOffice Calc
4. press CTRL-Z (UNDO)

Current behavior:
UNDO for inserted text is OK
UNDO for inserted image is not OK (the image stays in the spreadsheet)

Expected behavior:
image should be deleted
              
Operating System: Windows 8
Version: 4.1.3.2 release
Comment 1 retired 2013-12-03 12:54:05 UTC
Confirmed on OS X 10.9, LO Version: 4.3.0.0.alpha0+
Build ID: 532b2f48185c9ee3f389f1a3fbdfffcf113c15c0
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-12-03_00:32:32

cmd + z (undo on os x) does nothing after the image from the browser is pasted into LO spreadsheet.

Setting to NEW + OS to ALL.
Comment 2 raal 2014-10-05 19:59:41 UTC
*** Bug 84634 has been marked as a duplicate of this bug. ***
Comment 3 QA Administrators 2015-10-14 19:56:38 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.1 or preferably 5.0.2.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-10-14
Comment 4 lovejesus 2015-10-15 17:21:18 UTC
bug is still present in 5.0.2.2
Comment 5 tmacalp 2015-12-29 19:51:05 UTC
*** Bug 91747 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2016-05-13 06:05:33 UTC

*** This bug has been marked as a duplicate of bug 39217 ***