Download it now!
Bug 72400 - SLIDESHOW: Movies are shown as a question mark during a transition
Summary: SLIDESHOW: Movies are shown as a question mark during a transition
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86-64 (AMD64) other
: high critical
Assignee: Tamás Zolnai
URL:
Whiteboard: BSA target:4.3.0 target:4.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-06 14:52 UTC by Henrik
Modified: 2014-04-16 12:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
mp4 video of libreoffiece presentation slide show (239.87 KB, video/mp4)
2014-02-01 01:02 UTC, NoWorries
Details
More detailed example of bug (1.48 MB, video/mp4)
2014-02-02 02:43 UTC, NoWorries
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik 2013-12-06 14:52:45 UTC
Problem description: 

Steps to reproduce:
1. Add a movie to a slide
2. Add a transition to the same slide
3. View slide show

Current behavior:
While the transition is taking place the video is shown as a grey box with a question mark.

Expected behavior:
A frame from the movie should be shown instead.
              
Operating System: Ubuntu
Version: 4.2.0.0.beta2
Comment 1 Cor Nouws 2013-12-06 15:22:11 UTC
Hi Henrik

thanks for filing the bug.
I can confirm this in 4.2.0beta1.
Should test for previous versions - or do you know if it worked fine before?

Best,
Cor
Comment 2 Henrik 2013-12-06 15:36:03 UTC
I just tested it on 4.1.2 and there it's just black during the transition instead of showing the question mark.
Comment 3 NoWorries 2014-02-01 01:02:41 UTC
Created attachment 93152 [details]
mp4 video of libreoffiece presentation slide show

Impress 4.2.0.4 has a large Question Mark before start of a Movie on Kubuntu 14.04 Alpha 2.  This was also present in 4.2.0.2 rc

Steps to reproduce:
1. Start Impress and make the first slide blank with a black back ground for all slides.
2. Add another slide and insert a movie, eg mp4 file.
3. Start a slideshow with F5 and advance to the movie.

Current behavior: A large light grey question mark is displayed for about 47 frames before the start of the movie.

Expected behavior:  No question mark should be displayed.  The movie should start with no preamble image that is not part of the movie.
Comment 4 retired 2014-02-01 08:30:38 UTC

*** This bug has been marked as a duplicate of bug 56847 ***
Comment 5 NoWorries 2014-02-01 10:54:13 UTC
(In reply to comment #1)
> Hi Henrik
> 
> thanks for filing the bug.
> I can confirm this in 4.2.0beta1.
> Should test for previous versions - or do you know if it worked fine before?
> 
> Best,
> Cor

I have found this behaviour in all 4.2 versions of Impress up to 4.2.0.4.  I can play videos successfully and the first image in the video is shown in the slide for the video.  The problem is that for about 47 frames, a grey question mark is displayed before the start of the video.

This problem was not present in the previous version 4.1.2.3.  In this case there was a brief white flash before the video replay started.

This bug is definitely NOT A DUPLICATE of 56847.  The 56847 bug is caused by not having all the required dependencies installed.  For Kubuntu, I install the package gst123 and the videos always work, except for the LO Impress added flash or the question mark preceding the start of the video.
Comment 6 NoWorries 2014-02-02 02:43:02 UTC
Created attachment 93206 [details]
More detailed example of bug

This new attachment shows the LO Impress before starting the slideshow as well as the slide show with the question mark preceding the video.
Comment 7 Commit Notification 2014-04-11 18:19:26 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=539017f1d96b0ca2c062ed7ffd2f48166f831493

fdo#72400: slideshow: display a snapshot of movie until its not started



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 retired 2014-04-13 09:55:09 UTC
Zolnai, thanks a lot for this patch.

In my test with Version: 4.3.0.0.alpha0+
Build ID: f9cc0daec26016722bf5260e4e2634e6dcfe25a2
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-12_01:40:37

I still see a grey box with questionmark after adding a mp4 video in presentation. Maybe another bug? I use no transition nor is it necessary to view the slideshow.

When I start the slideshow, the video plays fine.
Comment 9 retired 2014-04-13 10:00:50 UTC
Zolnai, thanks a lot for this patch.

In my test with Version: 4.3.0.0.alpha0+
Build ID: f9cc0daec26016722bf5260e4e2634e6dcfe25a2
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-12_01:40:37

I still see a grey box with questionmark after adding a mp4 video in presentation. Maybe another bug? I use no transition nor is it necessary to view the slideshow.

When I start the slideshow, the video plays fine.

This is on OSX 10.9.2. Being able to add the video is news to me. See also: https://bugs.freedesktop.org/show_bug.cgi?id=76903

Would be great if now a still from the video would be displayed when working on the presentation.

Let me know if you think a new bug for this is needed or if we should re-open this existing bug.
Comment 10 Tamás Zolnai 2014-04-13 16:31:39 UTC
(In reply to comment #9)
> Zolnai, thanks a lot for this patch.
> 
> In my test with Version: 4.3.0.0.alpha0+
> Build ID: f9cc0daec26016722bf5260e4e2634e6dcfe25a2
> TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-12_01:40:37
> 
> I still see a grey box with questionmark after adding a mp4 video in
> presentation. Maybe another bug? I use no transition nor is it necessary to
> view the slideshow.
> 
> When I start the slideshow, the video plays fine.
> 
> This is on OSX 10.9.2. Being able to add the video is news to me. See also:
> https://bugs.freedesktop.org/show_bug.cgi?id=76903
> 
> Would be great if now a still from the video would be displayed when working
> on the presentation.
> 
> Let me know if you think a new bug for this is needed or if we should
> re-open this existing bug.

Yes, I think it's an other bug. The original bug which I fixed was that the question mark was displayed during translation, but in edit mode a valid snapshot were displayed. So the bug comes up only during the slide show.
If I understand you correctly then you see a question mark on the slides in edit mode, directly after you insert the movie, right?
If yes, you should open a new bug and upload the mp4 file which cause the problem. It must be some mp4 specific bug, I guess. In general, question mark means LO can't construct a player for the specific file (it doesn't support the format of the file) but if you can play it then it must be some bug in the detection code.
Comment 11 Tamás Zolnai 2014-04-13 16:43:12 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Zolnai, thanks a lot for this patch.
> > 
> > In my test with Version: 4.3.0.0.alpha0+
> > Build ID: f9cc0daec26016722bf5260e4e2634e6dcfe25a2
> > TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-12_01:40:37
> > 
> > I still see a grey box with questionmark after adding a mp4 video in
> > presentation. Maybe another bug? I use no transition nor is it necessary to
> > view the slideshow.
> > 
> > When I start the slideshow, the video plays fine.
> > 
> > This is on OSX 10.9.2. Being able to add the video is news to me. See also:
> > https://bugs.freedesktop.org/show_bug.cgi?id=76903
> > 
> > Would be great if now a still from the video would be displayed when working
> > on the presentation.
> > 
> > Let me know if you think a new bug for this is needed or if we should
> > re-open this existing bug.
> 
> Yes, I think it's an other bug. The original bug which I fixed was that the
> question mark was displayed during translation, but in edit mode a valid
> snapshot were displayed. So the bug comes up only during the slide show.
> If I understand you correctly then you see a question mark on the slides in
> edit mode, directly after you insert the movie, right?
> If yes, you should open a new bug and upload the mp4 file which cause the
> problem. It must be some mp4 specific bug, I guess. In general, question
> mark means LO can't construct a player for the specific file (it doesn't
> support the format of the file) but if you can play it then it must be some
> bug in the detection code.

I mean transition not translation :)
Comment 12 Tamás Zolnai 2014-04-13 16:56:22 UTC
I see in the history the summary were changed in a wrong way. Here we have too different bugs. I changed it back to the original one, which is say "question mark during transition". I fixed that bug. So if you see a valid snapshot in edit mode you will see the same snapshot during transition.
Other bug is that LO can't display a snapshot in edit mode at all. I think this bug most affect not just Impress, but Writer too, because in edit mode the same method is used for both. So we need an other bug report which says something like that: LO can't display a snapshot of some movie file (or mp4 files) and must be uploaded the example files.
Comment 13 retired 2014-04-13 20:56:23 UTC
Thanks for elaborating on this!

Back to Resolved - Fixed.

And here's the new bug for the questionmark being displayed instead of a still form the imported movie:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=77410
Comment 14 Commit Notification 2014-04-16 12:22:49 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5dfb92d506e1aed643dcc84a219882edeac1a9a7&h=libreoffice-4-2

fdo#72400: slideshow: display a snapshot of movie until its not started


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.