Bug 72776 - FILEOPEN: Writer doesn't show embedded chart text boxes in .docx files
Summary: FILEOPEN: Writer doesn't show embedded chart text boxes in .docx files
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard:
Keywords: filter:docx
: 93641 113609 (view as bug list)
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2013-12-17 06:08 UTC by David Delma
Modified: 2020-12-30 09:54 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
file (24.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-12-17 06:08 UTC, David Delma
Details
full version of graph not well rendering in libreoffice (100.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-12-19 15:35 UTC, David Delma
Details
illustration (30.78 KB, image/png)
2013-12-19 17:56 UTC, David Delma
Details
screenshot in 4.2.6, 4.3.2 and current 4.4master (5.32 KB, image/png)
2014-10-05 18:40 UTC, tommy27
Details
screenshot in current 5.1 master (5.18 KB, image/png)
2015-05-29 21:39 UTC, tommy27
Details
Calc Correctly Imports Charts with Text Boxes (12.40 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-02-04 20:33 UTC, Luke
Details
How it looks in LibreOffice 6.4 master (11.11 KB, image/png)
2019-10-22 19:17 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Delma 2013-12-17 06:08:22 UTC
Created attachment 90858 [details]
file

The attached document does not reproduce the chart graphic as it should. I get one unique color from 2 and the number that should be visible is not displayed at all
Comment 1 David Delma 2013-12-17 06:13:31 UTC
The attached document does not reproduce the chart graphic as it should. I get one unique color from 2 and the number that should be visible is not displayed at all
Comment 2 David Delma 2013-12-19 15:35:59 UTC
Created attachment 90992 [details]
full version of graph not well rendering in libreoffice

Here is an extended version of the graphic for the charts seems to be interdependant
Comment 3 David Delma 2013-12-19 15:41:35 UTC
If you save this file in libreoffice it will break the charts
Comment 4 David Delma 2013-12-19 17:56:29 UTC
Created attachment 90997 [details]
illustration
Comment 5 Joel Madero 2013-12-20 15:17:42 UTC Comment hidden (obsolete)
Comment 6 Joel Madero 2013-12-20 15:18:07 UTC Comment hidden (obsolete)
Comment 7 Luke 2014-07-15 20:28:24 UTC
Some progress has been made with the latest builds of LO. Both of the 2 colors are now being displayed. However, the number and percent are still not visible.
Comment 8 tommy27 2014-10-05 18:40:00 UTC
Created attachment 107365 [details]
screenshot in 4.2.6, 4.3.2 and current 4.4master

I confirm the behaviour described by Luke in previous comment in 4.2.6.2, 4.3.2.2 and 4.4.0.0.alpha0+
Build ID: 268b9c10c9ff27c74678ace99762f28d58d33012
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-02_23:35:24

see my attached screenshot.
Comment 9 tommy27 2014-11-21 22:41:17 UTC Comment hidden (obsolete)
Comment 10 tommy27 2015-05-29 21:39:41 UTC Comment hidden (obsolete)
Comment 11 Luke 2015-05-30 00:42:46 UTC Comment hidden (obsolete)
Comment 12 tommy27 2015-10-18 03:43:00 UTC
after that regression has being fixed we are now back to the same situation as in attachment 107365 [details]

Both the 2 colors are being displayed but the number and percent are still not visible.

retested with LibO 5.1.0.0.alpha1+
Build ID: 4b55c28940d741e53648115a9cfb58f2d6db38a5
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-15_06:14:50
Locale: it-IT (it_IT)
Comment 13 Robinson Tryon (qubit) 2015-12-09 18:44:51 UTC Comment hidden (no-value, obsolete)
Comment 14 oo.o+libreoffice 2017-02-03 10:27:19 UTC
I have taken your bug to learn something about the drawingml from libreoffice.

What I found is the following:
- In the chart1.xml is the <c:showPercent> to "1" set
- In chart1.xml is a reference (chart1.xml.rels) to the drawing1.xml. This File has the percent value of the chart. This percent value is in a usershape.
- The parsing of the chart gives the following error:
warn:legacy.osl:15270:1:oox/source/drawingml/chart/objectformatter.cxx:1100: ObjectFormatter::convertNumberFormat - cannot create number format ''
warn:chart2.tools:15270:1:chart2/source/tools/WrappedPropertySet.cxx:152: found no inner property set to map to
warn:chart2.tools:15270:1:chart2/source/tools/WrappedPropertySet.cxx:152: found no inner property set to map to
warn:chart2.tools:15270:1:chart2/source/tools/WrappedPropertySet.cxx:152: found no inner property set to map to
warn:chart2:15270:1:chart2/source/tools/LifeTime.cxx:120: This component is already disposed
warn:legacy.osl:15270:1:chart2/source/model/main/DataPoint.cxx:176: data point needs a parent property set to provide values correctly
warn:legacy.osl:15270:1:chart2/source/model/main/DataPoint.cxx:176: data point needs a parent property set to provide values correctly
warn:legacy.osl:15270:1:chart2/source/model/main/DataPoint.cxx:176: data point needs a parent property set to provide values correctly
warn:legacy.osl:15270:1:chart2/source/model/main/DataPoint.cxx:176: data point needs a parent property set to provide values correctly
warn:legacy.osl:15270:1:svx/source/unodraw/unoshape.cxx:3672: SvxShape::_getSupportedServiceNames: could not determine object type!
warn:legacy.osl:15270:1:svx/source/unodraw/unoshape.cxx:3672: SvxShape::_getSupportedServiceNames: could not determine object type!

I think axes format is tried to be parsed (because showPercent is set) but none is defined. The Value is in an other drawingml file and only referenced in the chart (<userShapes>).

Hope this helps to finde the cause
Comment 15 Luke 2017-02-04 20:33:40 UTC
Created attachment 130905 [details]
Calc Correctly Imports Charts with Text Boxes

The missing label is actually an embedded Text Box in the Chart Element. 

Calc correctly imports this kind of chart. This is a Writer only bug. 

The attached file was made by copying the bug doc from Word to Excel and changing the Text Box's content to make it clear that it's not a data label.
Comment 16 tommy27 2017-02-18 14:54:41 UTC Comment hidden (obsolete)
Comment 17 oo.o+libreoffice 2017-03-03 08:13:07 UTC
I tried to find the difference between the calc and writer version but the callgrind trace is to huge to find anything. It's like finding the needle in a haystack.
Has somebody a hint for me, where to look?
Or is there a parsing tool for MS files without that dumps the parsed file structure?
Comment 18 tommy27 2017-07-18 19:04:43 UTC Comment hidden (obsolete)
Comment 19 Amanda 2018-02-07 20:41:53 UTC Comment hidden (spam)
Comment 20 tommy27 2018-09-26 19:32:04 UTC
bug unchanged in LibO 6.2.0.0.alpha0+ (x64)
Build ID: 3017396a26f22ea193b4fd74bc485bc31cd547fe
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-04_01:08:03
Locale: it-IT (it_IT); Calc: threaded

same look as in screenshot depicted in attachment 107365 [details]
Comment 21 Gabor Kelemen (allotropia) 2019-01-15 15:28:17 UTC
*** Bug 113609 has been marked as a duplicate of this bug. ***
Comment 22 Xisco Faulí 2019-10-22 19:17:34 UTC
Created attachment 155245 [details]
How it looks in LibreOffice 6.4 master

Percentage is displayed in master

Version: 6.4.0.0.alpha1+
Build ID: de4839e66d3d195315729b95cc144cdab96b6e74
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

although not in the center
Comment 23 Xisco Faulí 2019-10-22 19:20:03 UTC
The percentage became visible after https://cgit.freedesktop.org/libreoffice/core/commit/?id=48480d4f19d2fb92ca4ae0527eec4753cdc439c0

@Balazs Varga, I thought you might be interested in this issue...
Comment 24 NISZ LibreOffice Team 2019-12-04 11:35:42 UTC
(In reply to Xisco Faulí from comment #22)
> Created attachment 155245 [details]
> How it looks in LibreOffice 6.4 master
> 
> Percentage is displayed in master
> 
> Version: 6.4.0.0.alpha1+
> Build ID: de4839e66d3d195315729b95cc144cdab96b6e74
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> although not in the center

Even that is now invisible in bibisect-win64-6.5, since: 

https://gerrit.libreoffice.org/plugins/gitiles/core/+/6f62a5c4ee2c1b7654c7fcaa618fb495e0d32f0a%5E%21/#F0
Comment 25 Xisco Faulí 2019-12-04 13:50:38 UTC
(In reply to NISZ LibreOffice Team from comment #24)
> (In reply to Xisco Faulí from comment #22)
> > Created attachment 155245 [details]
> > How it looks in LibreOffice 6.4 master
> > 
> > Percentage is displayed in master
> > 
> > Version: 6.4.0.0.alpha1+
> > Build ID: de4839e66d3d195315729b95cc144cdab96b6e74
> > CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> > Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> > Calc: threaded
> > 
> > although not in the center
> 
> Even that is now invisible in bibisect-win64-6.5, since: 
> 
> https://gerrit.libreoffice.org/plugins/gitiles/core/+/
> 6f62a5c4ee2c1b7654c7fcaa618fb495e0d32f0a%5E%21/#F0

Indeed!, but it shouldn't be invisible...

@Tamás Zolnai, I thought you might be interested in this issue, that changed after 6f62a5c4ee2c1b7654c7fcaa618fb495e0d32f0a
Comment 26 Balázs Varga 2020-11-27 12:31:00 UTC
With this patch, custom shapes visible again. Let's close it with Resolved Fixed and create another report for the wrong position and size of the embedded custom shapes.

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/71b66b0039819f38c935b4eb5d5951ceaf6e8468

tdf#138307 Chart import: fix lost custom shape text

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Balázs Varga 2020-11-27 12:31:54 UTC
*** Bug 93641 has been marked as a duplicate of this bug. ***
Comment 28 NISZ LibreOffice Team 2020-12-30 09:54:35 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 368c56144aab5794c39d5bc2082d9b3d6d7cebdb
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!