Bug 93641 - Writer embedded graph is missing lines and words
Summary: Writer embedded graph is missing lines and words
Status: RESOLVED DUPLICATE of bug 72776
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-Chart DOCX-Limitations
  Show dependency treegraph
 
Reported: 2015-08-25 00:18 UTC by Matthew Holloway
Modified: 2020-11-30 08:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Source document (283.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-08-25 00:18 UTC, Matthew Holloway
Details
msword rendering of document (106.83 KB, image/png)
2015-08-25 00:19 UTC, Matthew Holloway
Details
Rendering in LibreOffice 5.0.0.5 (61.12 KB, application/pdf)
2015-08-25 00:20 UTC, Matthew Holloway
Details
Minimized test file from Word 13 (16.16 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-22 09:02 UTC, Gabor Kelemen (allotropia)
Details
The minimized file in Word and LO 6.3 (66.06 KB, image/png)
2019-01-22 09:03 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Holloway 2015-08-25 00:18:28 UTC
Created attachment 118148 [details]
Source document

In the attached document the graph is missing some lines, arrows, and words.
Comment 1 Matthew Holloway 2015-08-25 00:19:33 UTC
Created attachment 118149 [details]
msword rendering of document
Comment 2 Matthew Holloway 2015-08-25 00:20:05 UTC
Created attachment 118150 [details]
Rendering in LibreOffice 5.0.0.5
Comment 3 Joel Madero 2015-08-25 03:49:53 UTC
It's actually how the header is anchored - it's anchored as a character instead of to the page. Objects anchored as a character cannot be aligned Horizontally (the option is greyed out). 

Confirmed:
Ubuntu 15.04 x64
LibreOffice 5.0.0.4


Setting as:
NEW
Normal - can prevent high quality work
Medium - default

@Matthew - I should have said this in the other 3 bugs but it would be great to get *much simpler* test documents. Devs hate having to look through tens or hundreds of pages of xml code - if you can attach a new document to each bug that focuses on the exact issue - remove everything else that is unrelated to the bug - that would be MUCH appreciated.
Comment 4 Joel Madero 2015-08-25 03:50:55 UTC
@Eike - is this just a matter of missing a feature and thus this is an enhancement request? I've never seen a vertical bar in a chart like this nor those arrows that you can see in the document. If you think it's appropriate - please set this to Enhancement instead of a normal bug.

Thanks!
Comment 5 Eike Rathke 2015-08-25 11:44:51 UTC
@Joel: What do I know about Writer or Chart? ;-P
Might be drawing objects on the chart.
Comment 6 Joel Madero 2015-08-25 15:30:20 UTC
@Eike - figured as Calc expert you'd be in the best position to comment about charts... :-b
Comment 7 Matthew Holloway 2015-08-26 05:00:17 UTC
Doesn't appear to be a regression.

Graphs of the type were first supported in 4.2.0.0.beta2 and have remained unchanged until 5.0.0.5.
Comment 8 QA Administrators 2016-09-20 10:26:11 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2019-01-09 11:48:58 UTC
still repro in

Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 10 Gabor Kelemen (allotropia) 2019-01-22 09:01:56 UTC
Indeed, it's shapes over chart. Might be related/duplicate to this text boxes bug, after all text boxes are just a kind of shapes.
Comment 11 Gabor Kelemen (allotropia) 2019-01-22 09:02:30 UTC
Created attachment 148502 [details]
Minimized test file from Word 13
Comment 12 Gabor Kelemen (allotropia) 2019-01-22 09:03:20 UTC
Created attachment 148503 [details]
The minimized file in Word and LO 6.3

Version: 6.3.0.0.alpha0+
Build ID: 309ab4419b1d1a4cd0ce939c3a0af4d4af5d4b6b
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 13 Balázs Varga 2020-11-27 12:31:54 UTC

*** This bug has been marked as a duplicate of bug 72776 ***