Bug 74542 - FILEOPEN: Unable to manage Templates
Summary: FILEOPEN: Unable to manage Templates
Status: RESOLVED DUPLICATE of bug 74506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-04 23:39 UTC by maccabbeo
Modified: 2014-02-07 00:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maccabbeo 2014-02-04 23:39:26 UTC
Problem description: 

Steps to reproduce:
1. Save a file as template MyTemplate.ott
2. open a new file from such template and modify it
3. save it as a template by overwriting the MyTemplate file

Current behavior: trying to save the template in two different ways which are both unsuccessful. First way: try to clic on the icon of the MyTemplate file in the pop-up window and then click "Save". If you open a new file from such a template you will see that NONE OF THE CHANGES you made while executing step two of above has been applied.
Second Way: as the popup window opens, just click on "Save" without selecting any template icon, then give the template exactly the MyTemplate name. Opening a new file from MyTemplate will not be possible since you get an error like that "unable to find MyTemplate" or something like that. Actually the MyTemplate icon on the popup menu is different than others (no preview, just the standard Writer icon). Opening the templates directory actually you will see there's no more the MyTemplate.ott file but there's a MyTemplate1.ott file (the character "1" has been added to the MyTemplate name, the MyTemplate.ott file has disappeared). Renaming back MyTemplate1.ott to MyTemplate.ott and then open a new file as a MyTemplate template will cause you an error similar to "unable to find MyTemplate1" (!!!yes, now you want it, now that I changed it!!!)

Expected behavior: save the modification to the template.

              
Operating System: Linux (Other)
Version: 4.1.4.2 release
Comment 1 retired 2014-02-05 08:53:18 UTC
Is this bug still valid / reproducible with the latest LO release?  Currently 4.2.0.4: http://www.libreoffice.org/download/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 2 Cor Nouws 2014-02-05 09:16:47 UTC
Hi,

there are various issues mentioned in this report.
pls see
  Bug 64359 - [Template Manager] Duplicate template in list when overwriting existing template
  Bug 74506 - [Template Manager] Saving as template fails without a warning when a folder is selected but not opened 
  Bug 64333 - [Template Manager] [UI]: Overwriting an existing template with a new one, demands that the name is typed; should be picked up by selecting the existing template 

Let me close as duplicate of 74506

*** This bug has been marked as a duplicate of bug 74506 ***
Comment 3 gagrilli 2014-02-07 00:50:18 UTC
(In reply to comment #0)

Cannot reproduce the described behaviour.


> Problem description: 
> 
> Steps to reproduce:
> 1. Save a file as template MyTemplate.ott
> 2. open a new file from such template and modify it
> 3. save it as a template by overwriting the MyTemplate file
> 
> Current behavior: trying to save the template in two different ways which
> are both unsuccessful. First way: try to clic on the icon of the MyTemplate
> file in the pop-up window and then click "Save". If you open a new file from
> such a template you will see that NONE OF THE CHANGES you made while
> executing step two of above has been applied.

In my system, the template is saved normally. Upon opening, the changes ARE PRESERVED as applied.

> Second Way: as the popup window opens, just click on "Save" without
> selecting any template icon, then give the template exactly the MyTemplate
> name. 

Did jjust that. Libreoffice asked me if I want tooverwrite thtemplate, which I did. The icon of the template with the same name appeared briefly on the template manager, next to  the old one.. I clicked the upper-right gear icon and selected "Refresh". The "extra" icon disappeared


>Opening a new file from MyTemplate will not be possible since you get
> an error like that "unable to find MyTemplate" or something like that.

This message did NOT appear. The file opened normally.


> Actually the MyTemplate icon on the popup menu is different than others (no
> preview, just the standard Writer icon). Opening the templates directory
> actually you will see there's no more the MyTemplate.ott file but there's a
> MyTemplate1.ott file (the character "1" has been added to the MyTemplate
> name, the MyTemplate.ott file has disappeared). Renaming back
> MyTemplate1.ott to MyTemplate.ott and then open a new file as a MyTemplate
> template will cause you an error similar to "unable to find MyTemplate1"
> (!!!yes, now you want it, now that I changed it!!!)
> 
> Expected behavior: save the modification to the template.

 
               
Operating System: Linux (Opensuse 12.2 64bit)
Version: 4.1.4.2 release