Bug Hunting Session
Bug 74686 - incorrect ODT to PDF export of WMF picture
Summary: incorrect ODT to PDF export of WMF picture
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:emf, filter:pdf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2014-02-07 17:24 UTC by mslab
Modified: 2016-12-28 15:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A doc file (.odt) which cannot be exported to pdf correctly ! (64.33 KB, application/vnd.oasis.opendocument.text)
2014-02-07 17:24 UTC, mslab
Details
PDF with bug (154.26 KB, application/pdf)
2014-02-12 11:34 UTC, mslab
Details
PDF export with LO 4.1.5 under Ubuntu (1.02 MB, application/pdf)
2014-02-12 20:34 UTC, Jean-Baptiste Faure
Details
Export to pdf with Open Office 4.x (108.82 KB, application/pdf)
2014-02-20 17:53 UTC, mslab
Details
edited test case (36.92 KB, application/vnd.oasis.opendocument.text)
2014-05-03 09:38 UTC, tommy27
Details
screenshot ODT LibO 5.0.4.2 (15.77 KB, image/png)
2016-02-21 09:04 UTC, tommy27
Details
screenshot PDF output LibO 5.0.4.2 (45.42 KB, image/png)
2016-02-21 09:05 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mslab 2014-02-07 17:24:11 UTC
Created attachment 93624 [details]
A doc file (.odt) which cannot be exported to pdf correctly !

Hi !

Here is a file "Bug_export_2_pdf.odt" which cannot be exported to a pdf file correctly.
See pages 3/5 and 4/5.
I've got the same problem with previous version 4.1.3 and with the next 4.2 too !
I've no problem with Open Office 4.x...

Thanks in advance for your help...
Regards
B.PICARD

              
Operating System: Windows XP
Version: 4.1.4.2 release
Comment 1 A (Andy) 2014-02-09 12:24:43 UTC
reproducible with LO 4.2.0.4 (Win 8.1)
Comment 2 Jean-Baptiste Faure 2014-02-12 05:53:17 UTC
I do not have any problem to export your odt file to pdf with LibreOffice 4.2.1.0.0+ (development version) under Ubuntu 13.10.

Please, could you describe what is wrong in the pdf you got and attach you own pdf to this bug?

Best regards. JBF
Comment 3 mslab 2014-02-12 11:34:15 UTC
Created attachment 93932 [details]
PDF with bug

Hi !
Many thanks for your answer.
Here is the pdf and you can see page 3/5 and page 4/5 are not correct.
I've the problem under Windows XP SP3 and under Windows 7.
(I've no problem with oOo 4.x)
Best regards
B.PICARD
Comment 4 Jean-Baptiste Faure 2014-02-12 20:34:12 UTC
Created attachment 93960 [details]
PDF export with LO 4.1.5 under Ubuntu

Interesting :-(

Still not reproducible for me with version 4.1.5 under Ubuntu 13.10. Here is the pdf I got with LO 4.1.5

Current version for branch 4.1 is now 4.1.5. Please, could you be so kind to test with this new version?
Did you try to play with the options of the pdf export dialog?

Best regards. JBF
Comment 5 mslab 2014-02-13 18:01:55 UTC
Hi,
Thanks for your answer.
I've got the same problem with LO 4.1.5.
(The process takes 23 seconds (export to pdf) with LO4.1.5 and 1 second for oOo 4.0.1!)
Comment 6 mslab 2014-02-13 18:04:23 UTC
I dont remember but I think that I've not change the pdf options...
Comment 7 mslab 2014-02-19 18:59:54 UTC
Hi !
I've tried today the same file under Ubuntu 12.04.1LTS and effectively, the export works fine.
So the problem is only with Windows XP-SP3 (32 bits) or Seven (64 bits).
I'll try with Windows 8 next time...
Comment 8 Jean-Baptiste Faure 2014-02-19 21:45:49 UTC
(In reply to comment #6)
> I dont remember but I think that I've not change the pdf options...

You should try to change various pdf export options to see if that change something. For example you can change compression option for images.

Best regards. JBF
Comment 9 mslab 2014-02-20 17:53:26 UTC
Created attachment 94449 [details]
Export to pdf with Open Office 4.x

Just to show the result with oOo 4.x
Comment 10 mslab 2014-02-20 17:54:17 UTC
Hi !

I've tried to export the file with LO 4.1.5 under Windows 8.1 and I get the same problem.

I've tried pdf export options (with Windows 8.1) :
- Compress method (without lost? sorry I'm french !)
- Reducing the quality for JPEG 90% to 75%
- Image resolution 300 dpi to 150 dpi
- Create PDF formular? unchecked
- PDF/A-1a

The problem is always the same !

PS : Here is (attached) the same file exported with Open Office 4.0.1. It works fine.
Comment 11 Jean-Baptiste Faure 2014-02-20 21:06:46 UTC
Please do not change the version number, it is intended to show the oldest version in which the problem has been observed.

Requested informations provided, status set back to unconfirmed.

Best regards. JBF
Comment 12 tommy27 2014-05-03 09:38:40 UTC
Created attachment 98366 [details]
edited test case

bug confirmed under Win7x64 using 4.2.3.3 and 4.3.0.0alpha+1 (30 april build)

I attach here an edited version of the test case with just the pages that do not export correctly (@mlasb --> next time upload minimal test case removing unneeded pages).

I also confirm that the .pdf created in Ubuntu by JBF and the one created in AOO 4.x are correct.

so the bug is limited to LibO and Windows.
Comment 13 tommy27 2014-05-03 09:44:05 UTC
I'm also wondering if the 2 pages of your document represent the same issue or rather 2 different issue about Charts exported to PDF.

maybe we should file 2 separate reports for each one of the bad PDF export results.

I ask advise from more experienced QA guys

p.s. changed summary notes and component as well
Comment 14 tommy27 2014-05-03 10:01:16 UTC
please take a look at Bug 78220 which is about a different issue regarding pages 1 and 5 of the original attachment
Comment 15 QA Administrators 2016-02-21 08:37:44 UTC Comment hidden (obsolete)
Comment 16 tommy27 2016-02-21 09:04:47 UTC
Created attachment 122837 [details]
screenshot ODT LibO 5.0.4.2
Comment 17 tommy27 2016-02-21 09:05:26 UTC
Created attachment 122838 [details]
screenshot PDF output LibO 5.0.4.2
Comment 18 tommy27 2016-02-21 09:07:18 UTC
retested ODT to PDF export from attachment 98366 [details] under Win8.1 x64 using LibO 
bug is still present with missing elements in the PDF output

compare screenshots
attachment 122837 [details]
screenshot ODT LibO 5.0.4.2

attachment 122838 [details]
screenshot PDF output LibO 5.0.4.2
Comment 19 tommy27 2016-02-21 09:21:39 UTC
same issue on LinO 5.1.0.3 as well
Comment 20 mslab 2016-02-22 17:43:32 UTC
Still present under LO 5.1.0.3 (Windows XP)
Works fine (and export is very quick) under OpenOffice 4.1.1 and 4.1.2
Regards
B. PICARD
Comment 21 Timur 2016-02-23 16:42:10 UTC
It's not export of table and chart but rather export of WMF pictures.
Comment 22 Timur 2016-11-17 08:02:27 UTC
WorksForMe. I'll mark as a duplicate of Bug 77525 which seems solved from 5.2.1. If proved otherwise please reopen.

*** This bug has been marked as a duplicate of bug 77525 ***
Comment 23 V Stuart Foote 2016-12-28 15:26:46 UTC
Workaround 

disable Tools -> Options -> View: "Use hardware acceleration" (or enable "OpenGL rendering" if system supports).


=-=-=
QA clean up of 77525, splitting it to bug 104252 and bug 103833

*** This bug has been marked as a duplicate of bug 104252 ***