Download it now!
Bug 75456 - FILEOPEN: DOCX Importing fails to import line break in vertical text-box
Summary: FILEOPEN: DOCX Importing fails to import line break in vertical text-box
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.1.1:OSX
Keywords: filter:docx
: 38066 91959 (view as bug list)
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2014-02-24 17:28 UTC by Xisco Faulí
Modified: 2019-10-03 13:00 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
docx file (23.41 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-24 17:28 UTC, Xisco Faulí
Details
Screenshot of the example document in Word and Writer (110.89 KB, image/png)
2019-10-02 14:40 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2014-02-24 17:28:11 UTC
Created attachment 94672 [details]
docx file

Problem description: 
When you load a DOCX that contains a line-break in a vertical text-box, LO doesn't render it.

Steps to reproduce:
1. Load attached DOCX in LO

Current behavior:
LO doesn't imports line-breaks in vertical text-box correctly

Expected behavior:
LO imports line-breaks in vertical text-box correctly

Tested on:             
- 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
- 4.3.0.0.alpha0+ Build ID: f839b5dd16c05c0eda21345ec36ec0cb024eb732
Comment 1 retired 2014-02-27 12:40:24 UTC
Confirmed:4.2.1.1:OSX as well as latest nightly from today.
NEW
Comment 2 Xisco Faulí 2015-04-20 15:41:34 UTC
This issue is still reproducible with

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
OS: Windows 7 64bits
Comment 3 Xisco Faulí 2016-04-20 10:10:52 UTC
This issue is still reproducible in

Version: 5.2.0.0.alpha0+
Build ID: d6bf3bcd8b51012d55a2ec962800a8549e2b85e1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-04-15_06:45:16
Locale: es-ES (es_ES)
Comment 4 Gülşah Köse 2017-07-11 11:29:28 UTC
Still reproducable LibreOfficeDev 6.0.0.0.alpha0 4250b25c6ae361359300ab6ccde27230f8e01039
Comment 5 Xisco Faulí 2017-10-03 15:16:28 UTC
*** Bug 38066 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2017-10-03 15:18:39 UTC
*** Bug 91959 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2018-11-05 03:43:12 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2018-11-05 16:57:55 UTC
still repro in

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 0b2d153f58c83fb289c96b348631e44e553b1a9a
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2018-11-02_21:11:48
Locale: ru-RU (ru_RU); Calc: threaded
Comment 9 NISZ LibreOffice Team 2019-10-02 14:40:16 UTC
Created attachment 154710 [details]
Screenshot of the example document in Word and Writer

Looks pretty good regarding the line break in: 

Version: 6.4.0.0.alpha0+ (x86)
Build ID: c45d477b0a0038d9c25176cf7cff299e5ddf3a7a
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-09-30_05:06:55
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 10 NISZ LibreOffice Team 2019-10-03 13:00:55 UTC
Bibisected with bibisect-win64-6.4 this commit fixed the problem:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9c945cdbe170104cbacafa2c37babec5210b9ca2

author	Miklos Vajna <vmiklos@collabora.com>	2019-06-06 21:32:07 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-06-07 09:05:08 +0200

sw btlr writing mode: DOCX drawingML import for fly frames